Проблема с SquidGuard и авторизацией прокси



  • Всем привет!
    Подскажите пожалуйста, я в очередной раз не понимаю, что происходит…
    Ситуация следующая: установлены пакеты Lightsquid и squid
    SquidGuard - ставлю пакет, начинаю действовать как написано здесь http://www.thin.kiev.ua/router-os/50-pfsense/530-pfsense-squid.html и после того, как нажимаю кнопочку save у меня блочится вход на прокси через веб морду! Далее великий Бэкап

    Локальная авторизация Proxy Server - добавляю пользователя в графе Local Users, в графе Auth Settings выбираю Auth metod -> Local и всё, при попытке выйти в инет выдаётся окно для ввода логина и пароля, но он не подходит! Админский так же не идёт! И на сам прокси зайти не могу! Далее великий Бэкап!
    Что я делаю не так?



  • @Volk170288:

    Всем привет!
    Подскажите пожалуйста, я в очередной раз не понимаю, что происходит…
    Ситуация следующая: установлены пакеты Lightsquid и squid
    SquidGuard - ставлю пакет, начинаю действовать как написано здесь http://www.thin.kiev.ua/router-os/50-pfsense/530-pfsense-squid.html и после того, как нажимаю кнопочку save у меня блочится вход на прокси через веб морду! Далее великий Бэкап

    1. Используйте версию ПФ i386
    2. Существует зависимость и совместимость версий пакетов squid подходящей версии SquidGuard. Поищите по форуму, на вскидку не момню.
    3. Измените порт админки на отличный от 80 и 443. Таким образом вы всегда сможете зайти на пф миную сквид.
    4. В доке на которую вы ссылаетесь, нет ни слова про авторизацию. А именно в ней у вас проблема как  я понимаю.



  • 1. Используйте версию ПФ i386

    Такую именно использую! pfSense-LiveCD-2.0.3-RELEASE-i386-20130412-1022
    Дистрибутив не обновлял!
    Lightsquid v. 1.8.2 pkg v.2.33
    squid v. 2.7.9 pkg v.4.3.3

    3. Измените порт админки на отличный от 80 и 443. Таким образом вы всегда сможете зайти на пф миную сквид.

    Менять порт, как я понял, надо в графе Advanced -> Admin Access
    Протокол у меня https, ставлю порт, например 7777! Предварительно, на всякий случай, прописал правило:
    Proto Source       Port Destination      Port       Gateway
    TCP         Admin_PC * Proxy         7777           *

    В результате заблокировался доступ, пришлось бэкапить…

    4. В доке на которую вы ссылаетесь, нет ни слова про авторизацию. А именно в ней у вас проблема как  я понимаю.

    Это я в один топик решил вписать две свои проблемы)))



  • Proto    Source          Port    Destination      Port          Gateway
    TCP            Admin_PC    *    Proxy            7777              *

    На мой взгляд, правило правильное, вроде как разрешаю доступ со своего компа на прокси по порту 7777, но меня заблокировало…



  • Проблему со SquidGuard вроде как решил!
    После установки зашёл на вкладку Common ACL и в Target Rules List правило Default Access [ALL] установил в Allow! После уже поставил галку Enabled и все дальнейшие настройки!
    Но сподвиг меня на эксперименты один непонятный для меня глюк, у меня закрыт доступ на один сайт (других пока не обнаружил), причём блокировался он без установленного пакета SquidGuard!
    Поставил пакет, вроде как настроил, добавил сайт в белый список, через Target Categories и не помогло!
    Кстати, прошу прощения, я не знаю, как так получилось, но настраивал я изначально не по той ссылке, что выше, а вот по этой:
    http://macrodmin.ru/2012/01/proksi-server-v-pfsense-chast-2-antivirus




  • Самое интересное, что при попытке зайти на этот сайт через мозилу, меня не пускает прокси, а попытался через другой браузер (dragon на основе хрома), так меня на сайт пускает!
    Попробовал на соседнем компе, ситуация аналогичная! Мозилу блокирует, а ослика - нет!
    Кто-нить с таким сталкивался? Что может быть причиной такого поведения?