OpenVPN



  • Boa tarde.

    Configurei o OpenVPN no pfsense, consigo fechar a conexão (Interrnet > Pfsense), mas não consigo enxergar a minha rede interna.

    O que pode ser?

    Obrigado



  • Poste o print da configuração que você realizou na openvpn.
    Liberou o trafego na interface openvpn?



  • Segue a configuração, não sei se falta alguma coisa ainda.

    Obrigado.






  • Compressão está desmarcada, geralmente se utiliza essa opção no cliente.
    As redes do tunnel e local estão certas? por exemplo, você não inverteu?



  • voce esta conectando o que? ponto a ponto (matriz - filial) ou acesso remoto (client - matriz)



  • Estou utilizando cliente x matriz.

    Minha rede é a 192.168.0.0/24 (Pfsense é o 192.168.0.1)



  • Esta é a configuração do cliente OVPN que o pfsense gerou.

    dev tun
    persist-tun
    persist-key
    cipher AES-128-CBC
    auth SHA1
    tls-client
    client
    resolv-retry infinite
    remote IPWAN 1194 udp
    lport 0
    verify-x509-name "PfsenseCA" name
    auth-user-pass
    pkcs12 pfsense-udp-1194-eduardo.p12
    tls-auth pfsense-udp-1194-eduardo-tls.key 1
    ns-cert-type server



  • O teste que você fez foi do cliente Openvpn tentar pingar maquinas atraz do Servidor Pfsense Openvpn?



  • Eu conectei com o client e após isto tentei acessar algumas máquinas pelo remote desktop e testei ping também. Nenhum deles deu certo.



  • ok vamos do comeco, sua wan esta com ip publico fixo ou é uma adsl? se for adsl ta em bridge? na configuracao do server ovpn, vc colocou o ip publico para conexao, ou a interface wan?



  • Coloca o cliente para conectar e posta o print do status -> openvpn para verificar-mos



  • bom dia.

    Esta é a configuração do server. (Enviei também o log da conexão)



    log.txt



  • o ip da lan ou ip do tunel esta igual ao da rede que vc esta tentando fazer a conexao.. nao vai conectar…



  • Lucas, bom dia.

    Esta é a configuração que fiz.

    IPV4 Tunnel: 192.168.1.0/24 (IP diferente da minha rede)
    IPV4 Local Network: 192.168.0.0/24 (Esta é a minha LAN)

    Quando coloco usuário e senha o status fica "Conectado" e vejo a conexão na console do pfsense, mas não enxergo a rede.



  • @eduardoh_c:

    Lucas, bom dia.

    Esta é a configuração que fiz.

    IPV4 Tunnel: 192.168.1.0/24 (IP diferente da minha rede)
    IPV4 Local Network: 192.168.0.0/24 (Esta é a minha LAN)

    Quando coloco usuário e senha o status fica "Conectado" e vejo a conexão na console do pfsense, mas não enxergo a rede.

    essa parte esta OK, mais o local onde esta o computador que esta tentando fazer a conexao esta com faixa de ips igual a um desses de sua configuracao, dessa forma ele ate conecta mais nao consegue fechar as rotas, pode ver no finado do seu log o erro

    o computador que esta tentando conectar nao pode ter ip: 192.168.1.x ou 192.168.0.x

    pra nao ter problemas coloque o ip do tunel 10.0.8.0/24 ou outra faixa diferente e bem distante da atual



  • Entendi.. Vou alterar o IP e fazer um novo teste.

    Obrigado.



  • Srs, boa noite.

    Desculpem a demora, mas consegui testar somente ontem.
    Fiz as alterações discutidas, agora consigo pingar o gateway 192.168.0.1 (pfsense), mas não consegui acessar/pingar as outras máquinas da rede.



  • @eduardoh_c:

    Srs, boa noite.

    Desculpem a demora, mas consegui testar somente ontem.
    Fiz as alterações discutidas, agora consigo pingar o gateway 192.168.0.1 (pfsense), mas não consegui acessar/pingar as outras máquinas da rede.

    pode postar o log novamente? vc tentou pingar por ip ou nome?



  • Mon May 05 00:37:56 2014 Warning: cannot open –log file: C:\Program Files\OpenVPN\log\pfsense-udp-1194-eduardo.log: Access is denied.  (errno=5)
    Mon May 05 00:37:56 2014 OpenVPN 2.3.3 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [IPv6] built on Apr  9 2014
    Mon May 05 00:38:04 2014 Control Channel Authentication: using 'pfsense-udp-1194-eduardo-tls.key' as a OpenVPN static key file
    Mon May 05 00:38:04 2014 UDPv4 link local (bound): [undef]
    Mon May 05 00:38:04 2014 UDPv4 link remote: [AF_INET]IPWAN:1194
    Mon May 05 00:38:04 2014 WARNING: this configuration may cache passwords in memory – use the auth-nocache option to prevent this
    Mon May 05 00:38:04 2014 [PfsenseCA] Peer Connection Initiated with [AF_INET]IPWAN:1194
    Mon May 05 00:38:06 2014 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
    Mon May 05 00:38:06 2014 open_tun, tt->ipv6=0
    Mon May 05 00:38:06 2014 TAP-WIN32 device [Local Area Connection 3] opened: \.\Global{0F75F6CB-8827-4C3A-BD56-5DCB34DE53E5}.tap
    Mon May 05 00:38:06 2014 Notified TAP-Windows driver to set a DHCP IP/netmask of 10.0.8.6/255.255.255.252 on interface {0F75F6CB-8827-4C3A-BD56-5DCB34DE53E5} [DHCP-serv: 10.0.8.5, lease-time: 31536000]
    Mon May 05 00:38:11 2014 ROUTE: route addition failed using CreateIpForwardEntry: Access is denied.  [status=5 if_index=29]
    Mon May 05 00:38:11 2014 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
    Mon May 05 00:38:12 2014 ERROR: Windows route add command failed [adaptive]: returned error code 1
    Mon May 05 00:38:12 2014 ROUTE: route addition failed using CreateIpForwardEntry: Access is denied.  [status=5 if_index=29]
    Mon May 05 00:38:12 2014 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
    Mon May 05 00:38:12 2014 ERROR: Windows route add command failed [adaptive]: returned error code 1
    Mon May 05 00:38:12 2014 Initialization Sequence Completed

    Eu faço um teste de ping no ip do pfsense



  • @eduardoh_c:

    Mon May 05 00:38:12 2014 ERROR: Windows route add command failed [adaptive]: returned error code 1

    esse é o seu erro agora.. provavelmente voce esta usando windows 8 na ponta.. esse cara é bem chato, mesmo vc sendo administrador do pc ele nao roda os programas dessa forma, vc deve executar o OpenVPN Client como administrador, clique com o botao direito do mouse no atalho e execute como administrador, sem isso ele nao consegue criar a rota, depois basta conectar normalmente..



  • Lucas,

    Obrigado pela ajuda. Executei como adm e funcionou.

    Obrigado aos que ajudaram também



  • @eduardoh_c:

    Boa tarde.

    Configurei o OpenVPN no pfsense, consigo fechar a conexão (Interrnet > Pfsense), mas não consigo enxergar a minha rede interna.

    O que pode ser?

    Obrigado