Kernel: arpresolve: can't allocate llinfo for XX.XX.XX.



  • После создания PPTP соединения и ребута pfsense, комп становится недоступен.
    Лечится вытыканием обоих шнуров из сетевых (одна WAN, другая LAN)
    В лог кладет крипичи:

    kernel: arpresolve: can't allocate llinfo for 10.0.0.1

    10.0.0.1 это мой шлюз, на ubuntu server 10.04, через который pfSens получает инет и раздает его в сеть за собой.
    внутренние ip 192.168.1.1
    маска  что убунты что pfsense, 255.255.255.0
    PPTP соединение подключается, присваевается левый IP (hideme.ru), с маской 255.255.255.255

    Что делать?



  • После создания PPTP соединения и ребута pfsense, комп становится недоступен

    Создания где , на чем ?



  • @werter:

    После создания PPTP соединения и ребута pfsense, комп становится недоступен

    Создания где , на чем ?

    на pfSense конечно
    заходим в интерфейсы, вкладка PPs, там создаем подключение
    далее в интерфейсах добавляем интерфейс (OPT1 у меня) и все.
    после ребута, пф сенс недоступен.
    напрямую с роутера если подключатся, выдает тож самое только с другим ip (и опять ip шлюза)



  • После создания PPTP соединения и ребута pfsense, комп становится недоступен

    В свое время  экспериментируя с тестовым PPTP-доступом к  hideme.ru получил другую проблему - pfsense  (тогда еще 2.0.2) уходил в циклическую перезагрузку.
    Выходом стало подключение к hideme.ru через OpenVPN, hideme.ru его поддерживает.



  • @pigbrother:

    После создания PPTP соединения и ребута pfsense, комп становится недоступен

    В свое время  экспериментируя с тестовым PPTP-доступом к  hideme.ru получил другую проблему - pfsense  (тогда еще 2.0.2) уходил в циклическую перезагрузку.
    Выходом стало подключение к hideme.ru через OpenVPN, hideme.ru его поддерживает.

    я бы рад был;0
    но я чет непонимаю как openvpn настроить с хайдми
    вроде клиента настроить получилось, но когда создаю интерфейс, непонятно что там писать
    none, dhcp, pptp, l2tp, static ?
    и так и сяк делал, чет не вкурил
    новичок я:)



  • Вот инструкция с картинками правда для другого VPN-провайдера, но вполне подойдет и для для hideme.ru:

    https://forum.pfsense.org/index.php/topic,29944.0.html

    Не забыть сделать это:

    edit - March 9 2011*
    – from now on, in order for traffic to be routed through the vpn gateway; from the pfSense interface, navigate to the dropdown menus: FIREWALL --> NAT --> OUTBOUND --| enable "Manual Outbound NAT rule generation" and select save.

    В Outbound NAT должны будут создаться правила для OpenVPN-интерфейса, как на скриншоте, если нет - их придется сделать самому, копируя правила для WAN. 10.0.2.0 - моя LAN

    Еще одна ссылка:
    http://forum.hidemyass.com/index.php/topic/6256-pfsense-openvpn-connection-issues/

    Для hideme.ru логин\пароль в OpenVPN не нужны, этот пункт:
    Type your HMA username and password into the input box, one on it's own individual line. Type /conf/hmauser.conf into the Save/Load from path box, then click Save.
    не нужен

    В Advanced configuration у меня следующее:

    persist-key;persist-tun;ns-cert-type server;verb 3;redirect-gateway def1;




  • методом проб и ошибок, пришел к месту затыка
    а именно, строчка:

    Local IP address

    в настройках что L2TP, что PPTP. Если в L2TP её прописать, то кома после ребута, так же не отвечает, приходится вынимать/внимать lan/wan кабеля.
    В PPTP соединении без неё даже настройки не сохраняются.
    буду копать дальше….



  • РЕШЕНИЕ НАЙДЕНО!

    надо в строчке local ip address писать 0.0.0.0, ну или хз че, может адрес удаленного сервака к которому подсоединяюсь.

    Вообщем, я прописал 0.0.0.0, на эту мысль меня подтолкнуло гугление самой строчки pfsense: local ip address
    и авторская статья
    http://fk88.blogspot.ru/2012/12/pfsense-pptp.html

    спасибо автору статьи огромное:)
    всем учавствующим, так же, спасибо.
    я сам затупил, никогда этого просто не делал:(
    по поводу open vpn надо будет разобраться, так как я по ней делал, но в конце уткнулся
    я создал юзера open vnp, pfsens схавал сертификаты, создал интерфейс (OPT1), но в настройках интерфейса нифига не понял что указывать, то ли none, или static, или dhcp;pptp;l2tp :o испробовал все, но так ничего и не заработало. указывал гейтом OPT, иду на 2ip.ru, а там мой реальный IP, т.е. не работает.
    вообщем, если есть идеи, прошу высказаться.