[Gelöst] Dauerhafter Traffic auf ungenutzen Interface



  • Hallo ihr,
    ich habe eine Multi-Wan Config . Tier 1 ist mein Kabel-Unitymedia, Tier 2 DSL und Tier 3 UMTS(OPT2).
    Ich möchte nun also das wenn Tier 1 ausfällt DSL übernimmt und falls beides ausfällt UMTS übernimmt. Das klappt auch :)
    Jedoch und das ist grade bei dem UMTS ein Problem. Habe ich Traffic auf DSL und UMTS ohne das ich was mache. Sind etwa 800KB in einer Stunde. Das Problem bei UMTS, ich habe nur 100MB frei, diese sind nach ~100 Stunden aufgebraucht… Grade mal ~5 Tage...

    Kann mir einer sagen woher dieser Traffic kommt? Ich habe bereits versucht das Gateway monitoring abzuschalten, was jedoch nicht die Ursache war...

    Grüße

    Marv



  • Moderator

    Kannst du mal einen Screenshot posten wie du das UMTS Interface und Gateway konfiguriert hast?



  • Wenn Du auf den Regeln das Logging aktivierst, siehst Du dann vielleicht den verursachten traffic ?
    Kommt mir grad son in den Kopf, da ja beide Interfaces Online sind und der Traffic mitunter von extern erzeugt werden könnte.



  • Also ich habe die regeln nun mal deaktiviert. Da kommt immer noch Traffic (auch na reboot) obwohl das Interface gar nicht mehr genutzt ist.
    Unter Status: Traffic Graph ist sowohl incomming and outgoing traffic zu beobachten…

    Selbst wenn ich OPT2 aus den Gateway Groups rausnehme, ist weiterhin IN/OUT Traffic vorhanden…


  • Moderator

    Hi Marv

    ich sehe leider die Interface Konfiguration nicht. Ich empfehle ein Screenshot-Tool oder eine Extension, die die gesamte Seite in voller Länge "knipsen" kann :) (in Chrome bspw. "Bildschirmerfassung" von Google selbst)

    Zum Test würde ich beim Gateway das Probing von 30s auf 300s erhöhen. Und dann mal das Wachstum bzw. die Größe des Verbrauchs an Bytes im Auge behalten. Wenns weniger wird, ist es wohl das Probing via ICMP ob das Interface noch Up ist.

    Eine Alternative - da es ja ein DialUp Interface ist - wäre genau das einzuschalten und im ErrorCase 3 (beide festen Leitungen weg) sich einzuwählen. Hat man vllt. dann initial etwas mehr Lag (bis die Einwahl komplett ist und der Traffic fließt) aber bei geschlossenem Interface kann auch kein Traffic fließen. Da das ja nur Fallback 3 sein soll, würde ichs auf Einwahl umstellen und nicht als Standleitung offen halten.

    Grüße



  • @JeGr:

    Hi Marv

    ich sehe leider die Interface Konfiguration nicht. Ich empfehle ein Screenshot-Tool oder eine Extension, die die gesamte Seite in voller Länge "knipsen" kann :) (in Chrome bspw. "Bildschirmerfassung" von Google selbst)

    Zum Test würde ich beim Gateway das Probing von 30s auf 300s erhöhen. Und dann mal das Wachstum bzw. die Größe des Verbrauchs an Bytes im Auge behalten. Wenns weniger wird, ist es wohl das Probing via ICMP ob das Interface noch Up ist.

    Eine Alternative - da es ja ein DialUp Interface ist - wäre genau das einzuschalten und im ErrorCase 3 (beide festen Leitungen weg) sich einzuwählen. Hat man vllt. dann initial etwas mehr Lag (bis die Einwahl komplett ist und der Traffic fließt) aber bei geschlossenem Interface kann auch kein Traffic fließen. Da das ja nur Fallback 3 sein soll, würde ichs auf Einwahl umstellen und nicht als Standleitung offen halten.

    Grüße

    Habe nun Dial UP und 300 eingestellt. Mal sehen. Verbraucht ICMP soviel? sind das nicht 32 bytes pro Sekunde (zumindestens bei Windows?) Wären dann grade mal 2 MB pro Tag.. (auch nicht schön aber aber das wäre auch 1xpro Sekunde..)



  • naja, jetzt ist er dauerhaft offline, also auch kein Traffic :)


  • Moderator

    Hast du mal getestet, wenn du die beiden WAN Lines ziehst, ob er dann die Verbindung aufbaut und einspringt/funktioniert?



  • Ja hatte er gemacht.
    Allerdings hat er nachdem er sich jetzt einmal gestartet hat, sich nie wieder getrennt und es laufen wieder 2-4 MB pro Tag drüber…



  • So.
    Habe jetzt aus Verzweiflung PFsense komplett neu aufgespielt und keine zusätzlichen Pakete installiert.
    Habe keine Regeln erstellt und mein UM Kabel als default gateway gesetzt. Er dürfte jetzt nichts über UMTS abwickeln können.
    Trotzdem gehen immer noch 2-4 MB Daten pro Tag durch ( GW Monitoring ist komplett aus geschaltet).


  • Moderator

    Incoming oder Outgoing? Und warum wieder als always-on definiert und nicht als Dial-Up? Genau dafür ist Dial-Up ja da, dass man sich nur einwählt "bei Bedarf", um ansonsten keinen Traffic zu verschwenden?!?



  • @JeGr:

    Incoming oder Outgoing? Und warum wieder als always-on definiert und nicht als Dial-Up? Genau dafür ist Dial-Up ja da, dass man sich nur einwählt "bei Bedarf", um ansonsten keinen Traffic zu verschwenden?!?

    Das ist ja das interresante. Sobald er sich einmal mit Dial-Up einwählt, bleibt er aktiv. Ich habe jetzt mal mit packet capture die Pakete mir ausgewertet. Alles DNS.
    Es sieht so aus, als würde er alles was auf den anderen Interfaces gesurft wird auch im DNS auflösen…
    Wenn ich eine Floating rule erstelle mit Block any @ UMTS habe ich keinen Traffic mehr auf dem UMTS Interface - und internet funktioniert weiterhin. Er macht also sinnlose DNS anfragen über UMTS...
    Abgestellt habe ich das bischer nicht bekommen. Und allen DNS Traffic zu blocken macht auch keinen Sinn, wenn im Notfall das Interface alleine da ist..



  • Moderator

    Ah, hast du unter General einen dedizierten DNS Server auf das UMTS Interface konfiguriert?



  • @JeGr:

    Ah, hast du unter General einen dedizierten DNS Server auf das UMTS Interface konfiguriert?

    Nein, habe ich nicht. ABer ich hab für die DSL und Kabel dezidierte angegeben.


  • Moderator

    Hmm ich wäre jetzt genau von umgekehrten Verhalten ausgegangen, dass du einen DNS für alle definiert hast und er deshalb den auch immer anfragt. Ansonsten würde mir nur einfallen:

    • Haken bei Einwahl darf DNS Server überschreiben

    rausnehmen, damit die Liste an DNSen nicht vom UMTS Interface überschrieben wird. Ansonsten auch den DNS Forwarder prüfen, ob der die Server nutzt und ggf. parallel abfragt.



  • @JeGr:

    Hmm ich wäre jetzt genau von umgekehrten Verhalten ausgegangen, dass du einen DNS für alle definiert hast und er deshalb den auch immer anfragt. Ansonsten würde mir nur einfallen:

    • Haken bei Einwahl darf DNS Server überschreiben

    @JeGr:

    Wo steht das? ;)

    rausnehmen, damit die Liste an DNSen nicht vom UMTS Interface überschrieben wird. Ansonsten auch den DNS Forwarder prüfen, ob der die Server nutzt und ggf. parallel abfragt.






  • Er fragt sie parallel ab.
    Das ist default einstellung…

    Löse ich mein Problem mit der Einstellung "Query DNS servers sequentially" dann? Oder vermindere ich damit nur den Zugriff weil er die der Reihe nach durchschaltet.
    Oder heißt es er probiert die der Reihe nach durch - bis er eine passende Antwort bekommt. <- Wäre das was ich bräcuhte



  • Auf jedenfall funktioniert es jetzt. Klar schöner wäre wenn ich UMTS von DNS anfragen ausschließen könnte, außer im Failover fall. Aber so funktionierts auch.

    Hab jetzt an 10 Tagen 1 MB wenn ich den Ping auf 60 Sekunden einstelle.

    Danke JeGr


  • Moderator

    Evtl. würde in deinem speziellen Fall die sequentielle Methode wirklich was bringen. Dann sollte er wirklich nach dem ersten Match aufhören zu suchen und damit auch keinen Traffic auf dem UMTS provozieren.

    Aber wenn es jetzt so auch klappt, bestens. WAN und FB kannst du beim DNSMasq übrigens rausnehmen, du WILLST nur für LAN DNS anbieten und nicht für die Welt ;) Binden auf LAN und Localhost genügt. :)

    Ansonsten immer gern.



  • @JeGr:

    Evtl. würde in deinem speziellen Fall die sequentielle Methode wirklich was bringen. Dann sollte er wirklich nach dem ersten Match aufhören zu suchen und damit auch keinen Traffic auf dem UMTS provozieren.

    Aber wenn es jetzt so auch klappt, bestens. WAN und FB kannst du beim DNSMasq übrigens rausnehmen, du WILLST nur für LAN DNS anbieten und nicht für die Welt ;) Binden auf LAN und Localhost genügt. :)

    Ansonsten immer gern.

    Ich habe die es auf jetzt auf sequentielle  eingestellt :) Genau damit klappt es ja. Oh das zweite hab ich dann auch mal geändert :)
    Danke nochmal :D


  • Moderator

    Könntest du uns noch wissen lassen, was du für eine UMTS Karte genutzt hast (oder ob das USB o.ä. war)?



  • Mehrere getestet. Alles nicht so das wahre.
    Werde Novatel 4620L wohl mal nen Versuch geben.