Outbount Nat ile Squid sorunu



  • Merhaba,

    Kurumumuz bünyesine Pfsense kurduk her şey çok iyi çalışıyor Fakat aşağıdaki sorun ile karşı kaşıyayız yardımcı olur musunuz ?

    10 adet vlan ımız var ve kütüphane databaselerine erişim sağladığı için bu vlan ları farklı ip lerden manuel NAT yapmamız gerekiyor. Nat yapılıyor sorun yok ama SQUID kurulup ta içerik filitreleme yapacağım diyorsanız sizi wan ip adresinden internete çıkarıyor ve istediğimiz ipler ile erişim sağlayamıyoruz bunun bir çözümü var mı ?



  • Merhaba ;

    Her vlan için squid custom options bölümünde acl oluşturmanız gerekiyor. Aşağıdaki link size oldukça yardımcı olacaktır.

    http://linuxaria.com/pills/setup-squid-to-use-multiple-outgoing-ip-addresses?lang=en

    Her vlan için bir acl olusturacaksınız sonra hangi gateway üzerinde cıkacaksa onu belirteceksin.



  • Tsk Samet bey . Deneyecegim



  • Pfsense de Custom options bölümünü bulamadım ama biraz daha detaylı bilgi verir misiniz ?



  • Squid2 üzerinde Custom Options bölümüne aşağıdaki şekilde bir kayıt girmeniz gerekiyorken, Squid3 'te Integretions alanına aşağıdaki acl kuralını girmek gerekiyor.

    ;acl LAN src 10.10.110.0/24; tcp_outgoing_address 78.67.54.141 LAN;

    Acıklama
    10.10.110.0/24  : Lan Network
    78.67.54.141 : Wan çıkış ip adresi.

    Tabi bu kuralı girebilmeniz için Metro ethernetin size vermiş olduğu ip bloğunu PFSense tanıtmanız ve hangi vlan'ın nerden çıkacağını Outbound Nat tabından belirtmeniz gerekiyor.

    Şunuda deneyebilirsiniz.

    ;tcp_outgoing_address 127.0.0.1;

    İstekleri loopback'e yönlendirip outbound nat'ta tanımlı olan değerler üzerinden çıkabilirsiniz. Tek tek kural girmek zorunda kalmazsınız.

    Not : Uzaktan bağlanıp hallettik, başkalarınında bu konuda arayışı olursa çözüm olsun diye yazıyorum.