Webgui fails to start



  • Has anyone seen this?  I've made no mods to this system but after a few reboots I get this error:

    lighttpd -f lighty-webConfigurator.conf -m /usr/local/lib/lighttpd/

    2007-12-31 14:32:19: (plugin.c.165) dlopen() failed for: /usr/local/lib/lighttpd//mod_fastcgi.so /usr/local/lib/lighttpd//mod_fastcgi.so: Undefined symbol "LI_ltostr"
    2007-12-31 14:32:19: (server.c.594) loading plugins finally failed

    The modules are there:

    locate fastcgi

    /usr/local/lib/lighttpd/mod_fastcgi.a
    /usr/local/lib/lighttpd/mod_fastcgi.la
    /usr/local/lib/lighttpd/mod_fastcgi.so

    I am not opposed to reinstalling if I need to but I'd like to know the root cause if possible.

    nb



  • The usual cause for something like this is either hardware (corrupted storage or bad RAM bits) or something trashed the software (bad spot on CD or bad bits in a CF device, or bad sectors on a hard drive).

    At least that has been my experience… :)

    gm...



  • I had done several reboots prior to the errors.  Oh well, it gave me an excuse to upgrade to RELEND_1

    nb



  • I have the same error on my router, and it occured several times, every time it occurs i do a firmware upgrade to fix it.Tried to transfer those 3 files related to mod_fastcgi from another router but it didn't fix it.



  • Just happen to me when from http port i change from https port 400, never work again the interface, i replace the old config but still i have the problem, i use pfSense 1.2-RC3-pfSense



  • @hemo:

    Just happen to me when from http port i change from https port 400, never work again the interface, i replace the old config but still i have the problem, i use pfSense 1.2-RC3-pfSense

    I have a brand new install that is doing this now.  It's pretty annoying, I'd really like to figure out how to fix it without a reinstall.  Anyone have any insight?



  • Compare lighttpd's library files MD5 with the version you installed looking for differences.  Once we find this perhaps we can isolate why its happening.  I honestly have never seen this happen as of yet.



  • I would hazard a guess that the mod_fastcgi.so  has a function that was renamed and not updated , previously I thought it was called ltostr and not LI_ltostr. I think its the version of fastcgi that contains the old function or one of the modules uses an incompatible lib. Just hazarding a guess.

    "Undefined symbol "LI_ltostr" "

    I know this issue has surfaced in other applications using lighttpd and this lib is the one that dies there also.

    You may be able to fix it with sed it has worked for us in the past with the same issue.

    If anyone hits me i will hit them back.



  • Have you installed the Developers Package?
    In my case i did and after a reboot of pfsense i get the error mentioned above.



  • hi,

    i have this problem twiuce (with a fresh install of 1.2 RC3,theb RC4) , and it's happen in the the same condition ( developper package, and reboot).

    Some one have open a bug report..??



  • seems to be correct. http://cvstrac.pfsense.com/tktview?tn=1655
    No time to test today.
    Some news when i will reinstall (for the third time)


Locked