VPN traffic going through wrong WAN connection



  • Hello,

    I have OpenVPN all set up and running. Road warrior setup.

    I am able to connect to the VPN, access the LAN, and internet.

    Problem is we have 2 WAN connections. The VPN is setup to receive connections from let's call it WAN1. Whenever I connect to the VPN and then access the internet all the traffic is going though WAN2.

    WAN1 is much faster and I would like all traffic to go back out of the same WAN it came in on.

    Anyone know how to accomplish this?

    Thanks in advance



  • Did you change the gateway in a firewall rule on the openvpn tab? If you didn't it should be using the default gw, which I would guess would be WAN, not WAN2.
    Personally, I don't see the point of redirecting internet traffic through the corporate vpn.



  • Thanks for the reply

    We have a bunch of servers and for security we limited access to them to a specific group of ip address. Our WAN ip addresses. They are not located in the same location as our PFSense box so we have to go over the internet to connect to them. So when people need to connect to them from home they have to connect to the VPN first.

    I didn't know that it went through the default gateway so that is good to know.

    I went ahead and added a rule to the openvpn tab as you suggested and I got the desired effect.

    My brain thanks you! You are the man!

    ![Screen Shot 2014-05-07 at 12.37.16 PM.png](/public/imported_attachments/1/Screen Shot 2014-05-07 at 12.37.16 PM.png)
    ![Screen Shot 2014-05-07 at 12.37.16 PM.png_thumb](/public/imported_attachments/1/Screen Shot 2014-05-07 at 12.37.16 PM.png_thumb)