SQUID and SQUIDGUARD problems with auth AD



  • Hello,

    I'm trying to configure SQUID problems (squid3-dev) and squidGuard (SquidGuard-squid3) to perform access control to web sites, based on the authentication groups in AD (Active Directory) and ACLs.

    When I enable the "Enable LDAP Filter" option in SquidGuard, it seems SquidGuard stops running, so the SQUID assumed again, ignoring the settings made ​​in "Client (source)" in "ACL Groups"

    Any idea or tip?

    If anyone has any sample configuration, thank you. I used the defaults, but to no avail.

    Version of pfSense 2.1.3-RELEASE (amd64)

    thank you
    Thiago



  • I have the same issue.  Anyone have any ideas how to get this working?



  • squidGuard-devel uses a different syntax for ldapsearch if u use this version try whithout '(' ')'



  • same issue i have



  • @Naughty:

    same issue i have

    Likewise.
    Running 2.3.1-RELEASE-p5 (amd64)
    Got everything running, then as soon as I enable LDAP it stops filtering.



  • @Naughty:

    same issue i have

    Sorted it!

    Check /var/squid/logs/cache.log

    See if you have something like:
    syntax error in configfile /usr/local/etc/squidGuard/squidGuard.conf line 11

    Have you used your domain administrator credentials for LDAP DN?
    If so, create a new user, doesn't need to be an admin, and use that (I copy the DN from ADSI EDIT)

    So for my user "ldap access" the DN is: CN=LDAP Access,CN=Users,DC=domain,DC=com

    Now all I have to do is get the LDAP queries working for group ACLs, and see if I can find a way to have it show an error page when it blocks HTTPS sites.



  • pfsense version 2.2.6 having squid and squid guard
    pfsense able to see all the containers .However, when i tried to authenticate the users by proxy …each time i enter my credentials in the browser is not verified me and keeps popup the authentication page