Still hear a beep after checking "Disable the startup/shutdown beep"



  • I recently upgraded to pfSense 2.1.3 amd64. In "System: Advanced: Notifications" I checked "Disable the startup/shutdown beep" and clicked Save. Then later from the console I chose to halt the system. After I did I heard the pc beep sound. Is that a bug and should I report it somewhere else? Thanks



  • Whether or not it beeps is about as dead simple as anything can be.

    BEEP=/usr/bin/grep -c disablebeep /conf/config.xml
    if [ $BEEP -gt 0 ]; then
    exit;
    fi

    If disablebeep exists in the config, it exits. Otherwise it beeps. What you're describing isn't possible. Maybe it's not the actual beep sequence, but the beep or two that the OS will normally do when halting?

    Running this from a command prompt will do the shut down beep sequence if it's enabled, otherwise do nothing:
    /usr/local/bin/beep.sh stop



  • @cmb:

    What you're describing isn't possible. Maybe it's not the actual beep sequence, but the beep or two that the OS will normally do when halting?

    Running this from a command prompt will do the shut down beep sequence if it's enabled, otherwise do nothing:
    /usr/local/bin/beep.sh stop

    I ran that command and I don't hear a beep. I do hear a beep when halting, when the system says "System going down IMMEDIATELY". I thought by disabling the startup/shutdown beep I would no longer hear any beep.


  • Rebel Alliance Developer Netgate

    That is the console message beep, not the shutdown sequence beep. You'll hear that any time there is an "emergency" log message.

    AFAIK you can create a new entry on System > Advanced, Tunables tab to set hw.syscons.bell=0 to kill that one.



  • @jimp:

    you can create a new entry on System > Advanced, Tunables tab to set hw.syscons.bell=0 to kill that one.

    Thanks, that worked.


Log in to reply