Ayuda con dos isp con el mismo servidor [ Resuelto ]



  • Hola compañeros. les pido su ayuda para poder aclarar una cuestión que eh estado atacando las ultimas semanas y no eh podido resolver.

    Resulta que tengo dos proveedores de isp (alestra y iusa ). un servidor dedicado a pfsence y una red dividida en vlan's.

    El problema que se me a presentado es querer utilizar mis dos isp's para realizar una segmentación de internet. Por ejemplo utilizar alestra para el nateo y la navegación de usuarios sensibles de mi segmentos de vlan. Por la estabilidad que me ofrecen. y la otra parte de mi segmentos de vlan salga la navegación por iusa. pero todos administrados por el mismo servidor dedicado pfsence.

    Ustedes  que me recomiendan compañeros.

    Gracias por su ayuda.


  • Rebel Alliance

    Reglas de FW - "Policy Routing" y lo tienes resuelto ;)

    https://doc.pfsense.org/index.php/Multi-WAN_2.0  (es referente a la 2.0 pero aplica a la 2.1.3)

    Eventualmente deberás "revisar/tener en cuenta" los cambios relacionados a la creación de reglas automáticas que permiten trafico entre redes locales

    https://doc.pfsense.org/index.php/2.1_New_Features_and_Changes

    Tengo funcionando  "pfSense 2.1.3-RELEASE (amd64)" con VLAN's (6) + Multi-Wan (5) sin problemas ;)



  • Gracias por la ayuda ptt pero aun sigo sin poder hacer funcionar esto. aun no logro indicarle que ciertas vlans salgan por iusa aunque ya eh creado la regra no me lo respeta. =(


  • Rebel Alliance

    Adjunta, por favor captura de pantalla de lo que has creado, ya que sin ver cómo tienes las reglas es imposible decirte que es lo que puede estar mal ;)



  • gracias ptt por la ayuda.

    Estas son las configuraciones que eh realizado.

    ![Captura de pantalla de 2014-05-21 16:19:13.png_thumb](/public/imported_attachments/1/Captura de pantalla de 2014-05-21 16:19:13.png_thumb)
    ![Captura de pantalla de 2014-05-21 16:19:13.png](/public/imported_attachments/1/Captura de pantalla de 2014-05-21 16:19:13.png)
    ![Captura de pantalla de 2014-05-21 16:19:29.png](/public/imported_attachments/1/Captura de pantalla de 2014-05-21 16:19:29.png)
    ![Captura de pantalla de 2014-05-21 16:19:29.png_thumb](/public/imported_attachments/1/Captura de pantalla de 2014-05-21 16:19:29.png_thumb)
    ![Captura de pantalla de 2014-05-21 16:20:37.png](/public/imported_attachments/1/Captura de pantalla de 2014-05-21 16:20:37.png)
    ![Captura de pantalla de 2014-05-21 16:20:37.png_thumb](/public/imported_attachments/1/Captura de pantalla de 2014-05-21 16:20:37.png_thumb)
    ![Captura de pantalla de 2014-05-21 16:21:48.png](/public/imported_attachments/1/Captura de pantalla de 2014-05-21 16:21:48.png)
    ![Captura de pantalla de 2014-05-21 16:21:48.png_thumb](/public/imported_attachments/1/Captura de pantalla de 2014-05-21 16:21:48.png_thumb)
    ![Captura de pantalla de 2014-05-21 16:22:08.png](/public/imported_attachments/1/Captura de pantalla de 2014-05-21 16:22:08.png)
    ![Captura de pantalla de 2014-05-21 16:22:08.png_thumb](/public/imported_attachments/1/Captura de pantalla de 2014-05-21 16:22:08.png_thumb)


  • Rebel Alliance

    Tienes mal la regla….

    En ella dices: trafico de la red VLAN360 con destino Red VLAN360, que salga por el "GW Group" Iusa y como el trafico entre hosts de una misma red/sub-red nunca "toca" el GW, tu regla Nunca se aplicará ;)

    Debes cambiar el "Destino" por "Any"

    Y si quieres permitir trafico de la VLAN360 hacia otra de las VLAN's, debes crear la regla que lo permita ubicándola "por encima" de la que tiene el GW Iusa...

    La regla "Timbrado interno" debes ubicarla por encima de la regla Iusa



  • Hola ptt eh realizado el cambio que me decías no se si así era como me decías que aplicara las reglas.  Por que si es así aun no logro que la vlan 360 salga por iusa  :'( :'(

    Gracias por la ayuda y disculpa las molestias.

    ![Captura de pantalla de 2014-05-21 17:53:19.png](/public/imported_attachments/1/Captura de pantalla de 2014-05-21 17:53:19.png)
    ![Captura de pantalla de 2014-05-21 17:53:19.png_thumb](/public/imported_attachments/1/Captura de pantalla de 2014-05-21 17:53:19.png_thumb)


  • Rebel Alliance

    • La regla "trafico interno" Bórrala, ya que nunca aplicará

    • En la regla "Iusa" estás indicando que el tráfico originado un host de la VLAN360 con "cualquier" destino salga por el Grupo de GW "Iusa"… asi que debería salir por  la WAN2, y cuando esta "cae" saldrá por la WAN1

    Cómo estás probando si funciona o no ?



  • pues aplico las reglas. y la verificación que hago es tener conectado un equipo en esa vlan360 y realizo un speedtest para verificar por que conexion sale. y el resultado del speedtest me sale que esta por alestra (wan1) con sus velocidades que manejan.


  • Rebel Alliance

    Borraste los estados creados por el host, desde el que estás probando, después de crear la regla, y antes de realizar la prueba ?



  • si eh borrado los estados y realice la ambas pruebas. Lo que note es que tengo como default GW la WAN1(alestra) no se si eso tenga algo que influya a que aun con la regla en la vlan360 este forzando a que salga por WAN1.


  • Rebel Alliance

    No, porque la regla de "Policy routing" es la que aplica ;)

    Intenta con "traceroute" en lugar del speedtest

    Si haces un "ping -t" a 159.148.147.196, y ves los estados apuntando a esa IP, que ves ?



  • yo tengo algo parecido, y en cada wan hago nat del segmento de red que quiero que salga por la wan específica.



  • en efecto ptt. cuando hago traceroute me indica que la salida es por iusa.  :D :D :D :D  lo cual quedaría resuelto esto.

    Muchas gracias Ptt por tu ayuda y tu paciencia.


  • Rebel Alliance

    De nada, que Bueno que esté Resuelto el problema :)

    Tendrías que ver si puedes editar el Título de tu primer Post, y agregarle  [ Resuelto ]



  • excelente post, ¡¡ gracias a todos por compartir sus conocimientos. :o


Log in to reply