Watchguard Firebox wont boot on internal CF Card



  • So I just purchased this firebox x1250e off ebay, I followed the tutorials on installing freedos on the cf card, I tried booting and all I hear is the one post beep, what I did was removed the board and soldered a USB header on the board and also followed another users suggestion for cutting the internal pcie port to allow a full graphics card to be plugged in, after that both usb and graphics work. Next I flashed the bios by using an external cf card reader through usb which worked, I went through all bios settings to try and figure out why my cf card wont boot. I keep getting an error either "Missing Operating System" or something like "NO DRIVE FOUND, INSERT A DRIVE AND PRESS ENTER" I cant remember the exact message but I'll post it tomorrow when I get to work. If you have any idea why the internal cf card reader is prompting this message yet external doesnt please let me know. I'm so close to finishing this project. THANKS!


  • Netgate Administrator

    So you booted into FreeDOS by using an external USB-CF adapter? Novel.  ;)

    What sort of CF card(s) are you using? Did it boot the Watchguard OS?

    Steve



  • @stephenw10:

    So you booted into FreeDOS by using an external USB-CF adapter? Novel.  ;)

    What sort of CF card(s) are you using? Did it boot the Watchguard OS?

    Steve

    Yes, I booted using a USB CF Adapter, plugged into my monitor so I could use the single USB port with a Hub. When I bought the Watchguard Firebox it didn't come with a CF card with the Watchguard OS, so I could not check if that works. Is there an IMG file of that up somewhere? I have tried to boot using 4 different CF Cards, 2 of them 128mbs different vendors and 2 of them are 256mb different vendors, One was a Kingston, I can post the other 3 when I get to work soon.

    Thanks

    Lenny



  • Okay here they are,

    128MB DANE-ELEC
    256MB SANDISK
    256MB KINGSTON
    128MB RIDATA

    Well 4 Different brands so I doubt its a card issue. Thanks


  • Netgate Administrator

    Ok. So you're trying to boot a CF card in the on-board slot with FreeDOS on it. You have proved that the card boots by booting it in the USB adapter.
    Some users found that only a very small card would boot, <64MB. No idea why I have booted 128 and 256MB cards with the FreeDOS image.

    Which BIOS version did you flash on there? What settings in the BIOS are you using?

    Why are you trying to boot FreeDOS when you've already flashed the BIOS?

    Steve



  • I'm trying to get the firebox to boot something off CF Card, I did just put pfSense Embedded on a 16GB Kingston CF Card and that won't work either, Here are some pictures.

    This is the error I'm Getting "DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER"

    Pic of My USB Header, I removed it from an Old Dell Optiplex at work going in the Junk Bin.

    Here is how I got the Graphics Card to fit, Cut a little piece out of the Riser Card

    The bios I'm using is pfSense B7, Bios Settings are Hard Drive boots first. I take it the CF Card acts as an IDE Hard Drive correct? The bios recognizes it during the boot process but isn't booting from it for some reason.

    Bios Settings:

    Hard Disk Boot Priority:
    1. CH0 M. : ULTIMATE CF CARD
    2. Bootable Add-in Cards

    First Boot Device : Hard Disk
    2nd Boot / 3rd Boot : Disabled

    Boot Other Device: Enabled

    Not sure if it matters or not but I'll put the OnChip IDE Device settings also

    IDE HDD Block Mode Enabled
    IDE DMA transfer access Disabled - Grayed Out
    On-Chip Primary PCI IDE Enabled
    IDE Primary Master PIO Auto
    … Slave PIO Auto
    ... Master UDMA Auto
    ... Slave UDMA Auto

    On-Chip Serial ATA Auto. Is there a Sata spot somewhere on this board? Possible to solder a header on?

    Other then those I don't see much else, If you want to know something Specific I can look. Thanks

    Lenny



  • FYI, I found a 1gb CF Card by Verbatim and installed pfSense to that, It boots over USB but not Internally, Same System Disk Error.


  • Netgate Administrator

    Ok, so with B7 you need to use the head=2 setting to boot anything larger than 512MB.
    Go into the bios setup and go to the primary master IDE setting (yes the CF is seen as an IDE drive). Allow it to auto detect the CF card, it will show the correct card size. Now change the mode to manual and the type to CHS. Set the heads value to 2. The drive will now show as some small value, like 501MB say. Save and exit and it should boot.

    The B8 or 8.1 is able to boot larger CF cards by default.

    The worrying thing here is that you were not able to boot a much smaller CF card which you should have been even with the original BIOS.

    Steve



  • Okay sounds good, I see Mode 2 but I don't see anywhere where it lists type.

    Here is exactly what I see

    Also could you send me a link to where I can find bios 8 and 8.1? I don't see either on the FreeDos bios folder.

    Thanks again for your help.

    Lenny



  • Okay NM I see what you were saying now,

    This still results in an error on booting. EDIT, I Changed Head = 2 and its workings like a champ now on a 1GB Card, Going to try 16gb next.

    Thanks


  • Netgate Administrator

    Nice.  :)
    The more recent BIOSes are linked to in the x550e thread. I haven't put them in the instructions because they were somewhat experimental, however plenty on people have tried them now.

    https://forum.pfsense.org/index.php?topic=20095.msg410276#msg410276

    Steve



  • Thanks again for the link, I updated the bios to B8 and now I can boot off of the 16GB Hard Drive,  :D

    However it doesn't go far. First thing and Last thing I see is:

    "BTX loaded 1.00 BTX version is 1.02"

    It never moves from there, Occasionally I see the Nic Lights Light up and turn off quickly but other then that it doesn't move.

    I will try to see if I can find a 8GB Card, To your knowledge would there be any reason why a 16GB would not work?

    Thanks for all your help, I am progressing with this so thats really good :D


  • Netgate Administrator

    No reason why it won't from 16GB card although that is unusually large for the age of the hardware.

    If you're running the standard Nano image that's the point where the console switches to the serial port. Are you looking there?

    Steve



  • Looks like I'm able to boot off the 16gb CF Card now but I'm getting READ_DMA Failure. Any Idea? I disabled the DMA Setting in the bios, but Still no luck.

    Let me know what you think. Thanks!


  • Netgate Administrator

    What image did you write to the card?
    The CF slot in the firebox does not have the connections to support DMA (a common 'feature' in CF slots  ::)) so if you try and use DMA it will timeout as you see and fail to boot. Disabling DMA in the BIOS seems to make little difference once past the bootloader. The standard NanoBSD images, with serial console, have DMA disabled for this reason but the Nano+VGA images do not (it was built originally for a box that required DMA).
    If you are running Nano+VGA images you can interrupt the boot loader and disable DMA as described here:
    https://doc.pfsense.org/index.php/Boot_Troubleshooting#NanoBSD_on_Newer_Hardware
    Obviously set thise to 0 to disable it.

    Or just use the standard Nano images.

    Steve



  • Thanks for the reply, a friend of mine was borrowing my CF Card to see if it would work in their box (not a firebox) and I guess he put the VGA image on there to test it out. I reloaded the Serial image and am now seeing it through the console session. Thanks for all your help, I'm super excited to test the rest of this out later and configure pfSense.

    One last question, Any idea if this USB port is live on the firebox?

    I soldered on those connections I ripped off another dead Motherboard and I can't seem to get it to do anything.

    The USB header to the left works fine, Just not CN_USB2.

    Let me know when you get a chance.

    Thanks again.

    Lenny


  • Netgate Administrator

    If you look close to CN_USB2 there are a number of components absent from it's 5V supply (C387, C396, U42 etc). I think the rest of it is connected, it may work with a self powered USB device.
    I have never been able to get hold of a vertical USB socket to attach one on the other connector. I'll have to look out for one on a dead motherboard.

    Steve



  • Hi Again,

    I'm having issues again with this unit, Uncorrectable PCI Express Error keeps coming up when I try to assign an IP to an Interface, Any device connected to that interface doesn't get an ip, just a 169 number. :(

    Any ideas? I seen one guy saying the same thing about his x550e and he said flashing the firmware on the nics solved the issue but I can't seem to find any information about doing this or where the firmware even is. Let me know what you think.

    Thanks


  • Netgate Administrator

    The 'Uncorrectable PCI Express Error' only happens on the msk interfaces, the four furthest from the LCD, and it has seemingly no adverse effect on the operation of the interface.
    In an attempt to stop the other big with those NICs, the watchdog timeout issue, I spent a while trying to get a newer 'firmware' file them. I eventually succeeded in extracting one from a Mac-mini which has the same NIC. After uploading it to the firebox that particular NIC no longer displays 'Uncorrectable PCI Express Error'. However it didn't fix the timeout issue and the error doesn't stop it working so I didn't proceed any further.

    Unless of course you have found a new error due to some unusual setup.  ;)

    Steve



  • Yeah, I eventually got an 8GB card and it boots up but I haven't gone through and configured any settings just yet,

    A co-worker was interested in what I was doing and he purchased a x750e off ebay but is having issues.

    I tried using a 256 mb card to load the image of FreeDos from that download link on the main wiki and I keep getting a missing operating system error.

    I also tried using the older freedos image and I get the same thing, However if I download my own copy of FreeDos or Win98 Boot Disk those work just fine,

    His board doesn't have USB so I'm not able to type anything in like I was on my board. I could solder it on for him but I rather not take the risk on someone else's board.

    I'm guessing with these firebox's there are a few different versions because I was able to boot off some 128mb cards on my watchguard box but his would only boot off a 256mb card.

    Probably cause thats what he had in there when he purchased it, Mine wouldn't boot off 256mb but would boot 128mb. But neither of my boards had any luck in booting the pfsense version of

    FreeDos. Is there anyway to rewrite how it boots? I believe thats the reason why it isn't working. Or if you know of another way for me to write the img to the CF card I can try that as well, I

    tried using PhysDriveWrite, Win32ImageWriter and even plugged it into a Mac using DD. All result in Missing Operating System.

    Any help would be appreciated! Thanks!


  • Netgate Administrator

    There are at least two motherboard variants in the X-e boxes and they look like they're different manufacturers but I assume made to the same spec. They use the same BIOS.
    The failure to boot is due to some problem with the recognised geometry of the card. Since the CF cards are only pretending to be an IDE harddrive they can present almost any geometry. The card I used to create the FreeDOS image was 16MB. It has booted in everything I've tried it in so perhaps try to get a very small card if you can.
    I've just had to disconnect my test box as I'm going away for a few weeks so I can't check right now but from memory the LCD only shows 'Missing Operating System' if it has tried to boot correctly but for some other reason is not able to. If it fails to boot because of a card geometry problem it just says 'Booting OS…' and nothing happens. That implies that either there is no OS on the card or the card isn't showing up at all for some reason. Does it boot the Watchguard OS? I assume you're not hearing the three beeps  when trying to boot the FreeDOS image?

    Steve



  • Hi Steve,

    Sorry I didn't mean Missing Operating System came up on the LCD on the front of the firebox, I meant I plugged in a VGA Graphics Card into the PCI slot and thats whats coming up on the monitor. The box does boot into the Watchguard OS. The card does work for Windows 98 Boot Disk and FreeDOS, When I have a card that doesn't have anything on it then I get a Disk boot error, with your image on the CF Card I get Missing Operating System…

    Would it be difficult to create my own version of FreeDos? I believe my biggest issue is I'm not aware of how to get FreeDOS to allow you to connect over Console. Is that the code inside of AutoExec.bat? And I think a few days ago when I tried it it said I had to press enter at the boot screen? I will check again.

    Thanks again for your help.

    BTW, I just wired up my Firebox and its running great!


  • Netgate Administrator

    Creating the FreeDOS image is relatively easy. I think the hardest part was finding some way of writing it to the disk initially. I forget exactly whay tool I used in the end but there was plenty of info in forums etc. Switching to the serial console is easy, I did it with a line in autoexec.bat as you suggested. Have a look in my image.

    Writing this from the airport so probably won't be able to reply to anything for while. Pretty sure they don 't have mid-atlantic wifi yet (or it's rediculously expensive!).

    Steve



  • Nevermind, I got it all working,  8)

    Turns out I had to use the original CF Card for it to work,

    Every card I wrote to would not boot FreeDOS on the Firebox but would boot it on a real PC.

    I talked to my co worker and he said it would be okay to try, I made a backup of his firebox os and then applied it to a 256MB cf Card I owned which errored out saying not enough sectors

    even though they were the same card, I then tried putting the image on a bigger card 512mb. I couldn't believe it but that actually booted up in the firebox.

    After that I knew I had a good working backup in case anything went wrong so I went ahead and pushed FreeDOS to the original CF Card and the firebox booted it up,

    I was then stuck for an hour with issues of "ERROR READING FROM DEVICE COM1 Write Fault"

    After searching the warehouse for an old Serial Cable I ended up trying 4 different Serial Cables before one actually worked.

    I was having trouble with performing a Backup of the bios so I ended up just typing the code out in the autoexec.bat file and putting pause afterwards.

    I seen the bios got backed up quickly, I then typed out the command for bios 8 in the autoexec.bat file and before you knew it I was running pfSense.

    Thanks again for all your help!


  • Netgate Administrator

    Nice one.  :)
    Having a serial cable that doesn't support hardware flow control can really give you a hard time.

    Steve


Log in to reply