Activar funcionamiento de RAID con 2 DD SCSI 36 Gb



  • Buen dias amigos,

    Alguien por aqui puede ayudarme con este dolor de cabeza.

    necesito activor el RAID para DD SCSI en caso de que el primer disco duro falle, el segundo tiene toda la data integra.

    saludos



  • ¡Hola!

    Haría falta saber si  pfSense (FreeBSD) te está reconociendo la controladora como RAID …

    Tienes que ir a la consola SSH de pfSense y mirar qué tienes en /etc/fstab:

    cat /etc/fstab
    

    Yo tengo:

    /dev/ad2s4a / ufs rw 1 1
    /dev/ad2s4d /cf ufs ro 1 1
    proc /proc procfs rw 0 0
    md /tmp mfs rw,-s16m 1 0
    

    lo que quiere decir que mi disco duro es ad2, o sea el disco 2 del tipo ad.

    Tecleando ad en http://www.freebsd.org/cgi/man.cgi veo que mi disco es un ATA normal y corriente.

    Otro sistema es ver lo que hay en /var/log/dmesg.boot, que contiene la detección de hardware al arrancar:

    cat /var/log/dmesg.boot | grep ad2
    

    lo que da algo como:

    ad2: 488MB <toshiba thncf512mqg="" 3.00=""> at ata1-master PIO4
    Trying to mount root from ufs:/dev/ad2s4a</toshiba>
    

    Si después de esto está claro que el sistema está viendo una controladora RAID tendrás que emplear la BIOS de la controladora para manejar tu RAID-1 (mirror). Pero, ojo, porque hay controladoras RAID que destruyen el contenido del disco cuando se crea el array de discos.

    O sea que, primero de todo, guardar el config.xml de tu pfSense en un ordenador a parte. Porque te puede suceder que después de crear el array de discos te quedes sin pfSense.

    ¡Suerte!

    Josep Pujadas



  • gracias por tu respuesta..

    Acabo de realizar la revision de mis discos y mi controladora, y efectivamente lo reconoce como da (SCSI Direct Access device driver)

    Depues realizé el chequeo del log de booteo y me reconoce los 2 disco duros y la tarjeta como:

    cat /var/log/dmesg.boot | grep da

    FreeBSD is a registered trademark of The FreeBSD Foundation.
    ahc0: <adaptec aic7892="" ultra160="" scsi="" adapter="">port 0x7c00-0x7cff mem 0x80a02000-0x80a02fff irq 11 at device 5.0 on pci2
    da0 at ahc0 bus 0 target 0 lun 0
    da0: <ibm-esxs dtn036w3uwdy10fn="" s25j="">Fixed Direct Access SCSI-3 device
    da0: 160.000MB/s transfers (80.000MHz, offset 127, 16bit), Tagged Queueing Enabled
    da0: 34715MB (71096640 512 byte sectors: 255H 63S/T 4425C)
    da1 at ahc0 bus 0 target 1 lun 0
    da1: <ibm-esxs dtn036w3uwdy10fn="" s25j="">Fixed Direct Access SCSI-3 device
    da1: 160.000MB/s transfers (80.000MHz, offset 127, 16bit), Tagged Queueing Enabled
    da1: 34715MB (71096640 512 byte sectors: 255H 63S/T 4425C)
    Trying to mount root from ufs:/dev/da0s1a
    #  34715MB (71096640 512 byte sectors: 255H 6

    Ahora voy a intentar configurar el mirror, por el bios de la tarjeta (pero segun tu recomendacion haciendo respaldo)

    Gracias por tu ayuda.

    Personas como tu son las que me alientan a seguir indagando en los foros..

    saludos</ibm-esxs></ibm-esxs></adaptec>



  • perfecto.. funciona a la perfeccion..!!

    Acabo de hacer la pruebas…
    1._ Desconecto DD 1 de los DD scsi y arranco (funcionó)
    2._ Desconecto DD 2 de los DD scsi, conecto el DD1 y arranco. (funciono)..
    3._ Vuelvo a conectar todo.. y listo
    Muchas gracias..!!!


Locked