Internet Explorer 11



  • Running 2.1.3 and I have setup a captive portal with hard time out of 30 minutes with everything else using default settings. It works fine using Chrome and Firefox, but for IE 11 it does not. I am redirected to the captive portal and I can click 'Continue' but instead of taking me to my page, it spins it's wheels for a little bit and then goes to "this page cannot be displayed". If I then close the browser and re-open it goes straight to my homepage. So everything is working right except for the redirect back to the originally requested page after authentication.

    I intend to use this in providing public wireless to laptops and need it to work with IE 11 without any customizations. Anyone know the fix for this?



  • hello.

    I just activated a Portal Interface on the LAN, just to test of it works on the LAN (as I know it works on the OPT1 interface).
    https://forum.pfsense.org/index.php?topic=77715.msg424640#msg424640

    I was using IE11 on a clean machine (all settings are "Microsoft Default").

    As other browser work, I understand that DHCP, DNS, IP etc are ok.
    There is no such thing in pfSense that "blocks all IE11 browsers".

    So, I advise you to bring your IE11 settings on that PC to normal. A plugin ?
    User another PC  - an other IE11 to test.

    Btw: what might an explanation: a home made html login page that IE11 doesn't like ….



  • I was using the captive portal on a bridge interface (LAN & WLAN) with a custom page. I have removed the bridge interface and am just using the LAN. Also deleted and re-created captive portal using default page. Still have problems with original computer 100% of the time but am testing with 2 other computers wired in and it seems to only happen 50%. If I use Chrome or Firefox on any of the 3 systems, it works everytime but very slow. I am running pfSense on one of those Netgate ALIX systems. Maybe it is just too much for them to handle. Which could mean that IE just has a shorter timeout than Chrome or Firefox.



  • Ok, I decided to use wireshark to get a little more insight into this issue. I am running a captive portal with hard timeout of 60 minutes and the default portal page (no authentication). 2 windows 7 computers both running IE 11. I was able to get capture on one where it failed and the other is worked.

    After you are re-directed to the portal and you click the 'Continue' button the pfSense box will send an 'HTTP 1.1/ 302 Found' back to the client to send it back to the originally requested page. The PC that worked sent a SYN packet to the site as it should. The system that didn't work sent a PSH,ACK to the web server followed by an ICMP Destination unreachable from the pfsense box. The PC continues to send TCP Retransmissions with the pfsense continuing to send ICMP Destination unreachable.

    Using IE it seems to fail 95% of the time. I don't know if IE just can't seem to close the TCP connection to the website after being redirected to the captive portal but pfSense clears it from it's firewall tables? Again Chrome and Firefox have no problems.

    Anyone have any thoughts on this?



  • Buenos días:  he experimentado este mismo problema, lo único que resuelve temporalmente es resetear la configuración por defecto del ie 11.  Al hacerlo la página de autenticación del portal cautivo carga correctamente y permite el ingreso dar click en continuar.