TAP adapter not getting IP address



  • HI,

    I have a VPN from a "Road Warrior" laptop to my PFSense system. It is functional but there is an annoyance I have been trying to fix for some time now.

    When I connect to the VPN, I get all the expected messages including That I was connected and it lists the IP address that was assigned. but I cannot access my LAN, "ipconfig /all" shows that there is no IP assigned to the tunnel adapter that I was just notified of the IP assignment.

    If I then manually set the network settings…IP, Default Gateway, DNS; I have access to my LAN.

    Any thoughts as how to fix this?

    Another annoyance, which I'm not too worried about right now, is that I run a couple VMs on this laptop, I have to make a separate VPN connection from each VM to get them all on the LAN. Is this a normal procedure, or do I have something set up wrong? I can't seem to the "network bridge" to function with a tunnel adapter for the VMs



  • Well that figures, after dealing with it for weeks and finally asking for help, I seem to have fixed it.

    I ran 'addtap' and it gave me some dialog about how it was installed and updated?  It's working now.


Log in to reply