Pfsense openvpn server <-> openvpn ubuntu 14.04 lts client (undef error)



  • When I connect from computer in local network, open vpn works fine:

    Sat Jun 28 22:51:06 2014 OpenVPN 2.3.4 i686-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [IPv6] built on Jun  5 2014
    Sat Jun 28 22:51:06 2014 library versions: OpenSSL 1.0.1h 5 Jun 2014, LZO 2.05
    Enter Management Password:
    Sat Jun 28 22:51:20 2014 Control Channel Authentication: using 'vpntest-udp-1194-vpntest-tls.key' as a OpenVPN static key file
    Sat Jun 28 22:51:20 2014 UDPv4 link local (bound): [undef]
    Sat Jun 28 22:51:20 2014 UDPv4 link remote: [AF_INET]79.xxx.xxx.69:1194
    Sat Jun 28 22:51:20 2014 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
    Sat Jun 28 22:51:20 2014 [vpntest] Peer Connection Initiated with [AF_INET]79.xxx.xxx.69:1194
    Sat Jun 28 22:51:22 2014 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
    Sat Jun 28 22:51:22 2014 open_tun, tt->ipv6=0
    Sat Jun 28 22:51:22 2014 TAP-WIN32 device [Połączenie lokalne 3] opened: \\.\Global\{0764051D-A3D9-4EAF-A7F3-C67B1BF41965}.tap
    Sat Jun 28 22:51:22 2014 Notified TAP-Windows driver to set a DHCP IP/netmask of 192.168.5.6/255.255.255.252 on interface {0764051D-A3D9-4EAF-A7F3-C67B1BF41965} [DHCP-serv: 192.168.5.5, lease-time: 31536000]
    Sat Jun 28 22:51:22 2014 Successful ARP Flush on interface [16] {0764051D-A3D9-4EAF-A7F3-C67B1BF41965}
    Sat Jun 28 22:51:27 2014 Initialization Sequence Completed
    
    

    but … when I try connect from remote location i get

    Sat Jun 28 22:38:05 2014 UDPv4 link local (bound): [undef]
    Sat Jun 28 22:38:05 2014 UDPv4 link remote: [AF_INET]79.xxx.xxx.69:1194
    

    pfsense version is: 2.1.4-RELEASE (i386)

    got WAN rule
    Proto Source Port Destination Port                  Gateway Queue
    IPv4 UDP *   *     WAN address 1194 (OpenVPN) *         none

    also got openvpn rule
    Proto Source Port Destination Port                  Gateway Queue
    IPv4 UDP *   *   *                 1194 (OpenVPN) *         none

    I have used openvpn client export package to create vpntest-udp-1194-vpntest-config.ovpn file, used at remote machine.
    No matter which remote machine i use (windows, linux) always get undef error.
    Also tried turn on OPT1 interface, adding manual NAT … no progress.


Log in to reply