[RISOLTO] Multi Wan - Mandare un ip diverso sul secondo router



  • Ciao,
    Cerco di spiegarmi e spero che qualcuno mi aiuti.
    Attualmente Pfsense è configurato con due Wan e una lan
    La prima Wan (WAN1) è una adsl tiscali che usiamo per navigare dall'ufficio
    La seconda Wan (WAN2) è una adsl collegata ad un sistema di prenotazione sulla quale ho assegnati una classe di 60 Ip privati della classe 10.189.57.0 e sulla quale devono viaggiare dati nel caso siano diretti a classi 10.193.0.0 e 57.8.0.0
    Gli ip interni alla lan sono della classe 192.168.1.0 (i pc dell'ufficio)
    Ho impostato delle static routes per far in modo che tutto quello diretto a 10.193 e 57.8 vada su WAN 2
    In effetti facendo dei traceroute il tutto funziona.
    Il problema è che mi è stato chiesto di fare in modo che se i miei pc (in particolare uno) escono sulla WAN 2 devono uscire come 10.189.57.0 e non con l'ip della LAN (192.168 ecc ecc).

    Come si fa??? anzi, si puo' fare?  ???

    Grazie a chi mi saprà dare una dritta

    Ema



  • Riesci a fare un schemino un Visio o Simili.
    Così a "naso" ti dico di si … in teoria con una Advanced NAT riesci a fare tutto ... però dovrei capire bene come si muovono le reti all'interno ...

    Matteo



  • @mascaos:

    Riesci a fare un schemino un Visio o Simili.
    Così a "naso" ti dico di si … in teoria con una Advanced NAT riesci a fare tutto ... però dovrei capire bene come si muovono le reti all'interno ...
    Matteo

    OK, lo schemino l'ho fatto ma non mi prende l'allegato. Puo' essere che non permetta di mettere foto jpg?
    la mia versione di pfsense è la 1.01 ma credo basti.
    Ho fatto dei tentativi da solo ma non ho ottenuto molto :(
    Grazie



  • Giramelo via mail … info@mascomputer.net

    Io con la 1.0.1 ho dei problemi sulla Advanced NAT per cui uso o la 1.2 rc3 o rc4 (che mi sembrano anche + stabili e complete).

    Matteo

    PS: non è che mi giri anche delle foto delle static route e della NAT :D

    Ciaoz.-



  • @mascaos:

    Giramelo via mail …
    Io con la 1.0.1 ho dei problemi sulla Advanced NAT per cui uso o la 1.2 rc3 o rc4 (che mi sembrano anche + stabili e complete).
    Matteo
    PS: non è che mi giri anche delle foto delle static route e della NAT :D
    Ciaoz.-

    Ok, prima di girarti il tutto via mail, per non farti fare un lavoro inutile, vedo se funziona cosi' come ho fatto, ovvero:
    ho creato un virtual ip sulla wan2
    ho impostato un nat 1:1 con la macchina che deve avere necessariamente il doppio ip.
    Oggi tento di fare delle prove per vedere se funziona. Dal mio versante della wan2 pare tutto ok, tracert, ping e routing verso internet con la nat1. Devo vedere se di là pingano correttamente.
    Grazie ancora, ti faccio sapere.
    Ema



  • OK, pare funzioni visto che hanno pingato regolarmente.
    Grazie
    Ema



  • Ottimo alla fine hai fatto quello che ti averi detto io.
    Bene son contento .. domanda hai dovuto usare la 1.2 rc3 o rc4 perchè a me con la 1.0.1 non andava mica !

    Matteo



  • @mascaos:

    Ottimo alla fine hai fatto quello che ti averi detto io.
    cut domanda hai dovuto usare la 1.2 rc3 o rc4 perchè a me con la 1.0.1 non andava mica !

    Guarda, io uso la 1.0.1 e funziona per ora.
    Ero interessato a mettere su la nuova, ma essendo in produzione mi sono fermato :)
    In effetti mi interesserebbe soprattutto se fosse migliorata la gestione del traffic shaping
    ma ho il terrore che upgradando qualcosa possa andare storto e poi chi se li sente quelli che devono lavorare ??? :)

    Grazie di tutto comunque


Locked