Can't install open VPN



  • hi guys,
    someone my OpenVPN is gone from the setting,
    tried to reinstall it but i couldnt,
    its keeps showing this error.

    Beginning package installation for OpenVPN Client Export Utility .
    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading OpenVPN Client Export Utility and its dependencies... 
    Checking for package installation... 
     Downloading https://files.pfsense.org/packages/amd64/8/All/zip-3.0-amd64.pbi ...  (extracting)
     pbi_add: Invalid file for usercheck!
    of zip-3.0-amd64.pbi p7zip-9.20.1-amd64 failed!
    
    Installation aborted.Removing package...
    Starting package deletion for zip-3.0-amd64...done.
    Starting package deletion for p7zip-9.20.1-amd64...done.
    Removing OpenVPN Client Export Utility components...
    Tabs items... done.
    Loading package instructions...
    Include file openvpn-client-export.inc could not be found for inclusion.
    Deinstall commands... 
    Not executing custom deinstall hook because an include is missing.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    done.
    Failed to install package.
    
    Installation halted.
    

    found this solution,

    https://doc.pfsense.org/index.php/Pbi_add:_Invalid_file_for_usercheck
    

    but its keeps giving me this error even the log in user is a Admin and has root access to run the shell.

    Must be run as root or a member of the operator group! pfsense
    

  • Rebel Alliance Developer Netgate

    Are you running those commands from the ssh shell, or from Diagnostics > Command? They should be run from the shell (ssh or console)


  • Rebel Alliance Global Moderator

    You do understand that is just the little export wizard thing, its is not openvpn.  When you say openvpn is missing from your settings that seems more involved than the export wizard package having issues.



  • @jimp:

    Are you running those commands from the ssh shell, or from Diagnostics > Command? They should be run from the shell (ssh or console)

    thank you,
    i've logged in using SSH.

    @johnpoz:

    You do understand that is just the little export wizard thing, its is not openvpn.  When you say openvpn is missing from your settings that seems more involved than the export wizard package having issues.

    exactly,
    i mean the openvpn was already installed, after the update my exisiting client just stops working.
    so tried to export it again but it gone. and can't reinstall it