SquidGuard Setup Issue - No Target Rules List under ACL



  • Hello Everyone,

    pfSense Version: 2.1.3-RELEASE (i386)
    Package Installaed: Squidguard 1.4_4 pkg v.1.9.6

    I'm having issue setting up the Squidguard for first time in our pfSense.  So far the things I've done so far is:

    • Download Squidguard package

    • Enable Squidguard

    • Enable Blacklist and enter http://squidguard.mesd.k12.or.us/blacklists.tgz under URL and save

    • Download Blacklist under blacklist tab

    • Clicked Common ACL Tab after successful blacklist download but there is only "Default Access [ALL]" under ACL

    I've tried searching only for similar issue but I'm still struggling to find a resolution.  I would appreciate any kind of advice…  I need to get this running for security concerns.

    Thank you



  • Were you working with the Blacklist tab, or the Blacklist Options under the General tab?



  • I'm sorry, I've meant to say the Blacklist options under the General Tab.



  • Go to the Blacklist tab and pump in your URL and then click Download.  I had to do both to get the list to appear.



  • I've already tried out that step under (4) but should I try it out again for second time?



  • When I went to simulate your problem, I first went to the Blacklist tab and manually updated.  From there, the ACL list was empty, so I went to the Blacklist Options section and filled it in.  Oh, did you go back to the General tab and click Save then Apply?  It's funny like that sometimes.



  • Hello KOM,

    Thank you for your help and I'm sorry about the delay in response.  I've tried going over your steps but I still cannot locate any ACL with exception of Default Access.  I'm not sure what else I'm missing.  I've initially tried following steps shown on h$$p://hubpages.com/hub/URL-Filtering-How-To-Configure-SquidGuard-in-pfSense# but it's not working on my side.  Do I need to download any other package besides squidguard?



  • Sorry for my mistake, I did not know that I needed to download squid package as well.  After download and small configuration on proxy server, I was able to pull up a list of ACL under proxy filer service.  However, It seems like I cannot apply the change for ACL as error shown below:



  • I'm on vacation this week so my responses are spotty too.  Yes, SquidGuard relies on Squid.  You may have a broken install if you installed Squid after SquidGuard.  Perhaps you should uninstall everything and then try again, in the proper sequence.



  • Thank KOM and sorry to interrupt you again.  I've taken backup file before this so I will go ahead and try that out.

    Thanks!



  • @kom i have same issue!help me



  • Start a new thread with the exact details of your problem instead of hijacking an ancient thread.


  • Netgate Administrator

    Locking this.

    If you're still running that pfSense and Squidguard version you have bigger problems but I highly doubt you are. 😉

    Steve


Locked