[Solucionado] whatsapp no funciona (a veces)



  • hola a tod@s! me encuentro que cuando llego a los clientes donde tengo un PfSense instalado y el WiFi configurado en el movil, me quedo sin whatsapp…no siempre... pero si a veces... es desactivar WiFi y funciona, adjunto log, la Ip de mi movil es 192.168.30.110....que puede ser? Gracias.




  • No creo que sea el pfSense, yo tengo un pfSense, y tengo por lo menos 150 clientes que usan WhatsApp y ninguno se ah quejado de eso, yo mismo uso WhatsApp activamente, y nunca eh notado un error de ese tipo, cuando ha habido fallos, no ha sido el pfsense, también usando la compañía telefónica ah fallado.



  • TCP Flags: F - FIN, S - SYN, A or . - ACK, R - RST, P - PSH, U - URG, E - ECE, W - CWR
    

    Tienes muchas A en los estados.

    http://es.wikipedia.org/wiki/ACK

    Parecen cortes. En una WiFi lo más normal es señal deficiente por algún motivo. También puede ser fallo de tu salida a internet.

    En cuanto a pfSense, ¿estás con balanceo saliente (agrupamiento de puertas)? o alguna otra cosa más ¿portal cautivo?, ¿proxy squid?

    No describes suficientemente tu escenario para que podamos ayudarte más.



  • A mi me pasa exactamente lo mismo, sobre todo con los mensajes entrantes. Los salientes sin problema pero los entrantes no hay forma que me lleguen.
    Yo lo achaco a que soy super novato en esto de los firewall y tengo mucho que aprender. Acabo de configurar mi pfsense siguiendo los tutoriales mas básicos y por ahora he detectado este problema, así que si no os importa os pido un poco de ayuda.
    Muchas gracias



  • Las conexiones a WhatsApp las hace siempre el dispositivo. Por tanto, son siempre salientes (aunque sean mensajes entrantes).

    Puertos de DESTINO empleados:

    https://supportforums.cisco.com/discussion/11778171/allow-whatsapp-through-firewall



  • Muchas gracias por la respuesta. Ya he abierto los puertos que comenta el link de Cisko. lo único una pregunta, todavía me lío un poco con eso de abrir puertos en WAN, LAN o mis dos Vlan que tengo. Yo los he abiero en mi Vlan que da servicio WIFI, sólo para mis dispositivos móviles, ahora bien, si los quisiera abrir para toda la red, lo tendría que hacer en la WAN?. Como comenté soy novato en esto de los firewall y me queda muuuuuucho por aprender y siempre me lío en qué interface tengo que aplicar las reglas del cortafuegos. Muchas gracias por la ayuda.



  • En WAN no deben darse permisos a menos que tengas un servicio interno publicado en internet.

    Las reglas de salida a internet deben hacerse en cada una de las LAN que tengas (LAN "normal", VAN, WiFi…)

    Ahí también hay que dar permisos de ida de una red a otra, si se quiere.

    Digo "de ida" porque hay que pensar en el cortafuegos como una casa con varias puertas con llave. Lo que se deja entrar, puede salir (en principio).



  • Muchas gracias por la ayuda, me funciona todo perfectamente. Como he dicho soy totalmente novato en esto de los firewall y me está enganchando cosa mala. Una pregunta, en el foro, hay algún apartado para gente que empieza como yo?, porque tengo varias dudas que solucionar. Gracias por todo.



  • Tal vez echarle un ojo a la documentación: https://forum.pfsense.org/index.php?topic=23409.0



  • @jcmarijuan:

    Una pregunta, en el foro, hay algún apartado para gente que empieza como yo?, porque tengo varias dudas que solucionar. Gracias por todo.

    No, en el foro tiene una única sección, pero no te preocupes por preguntar.

    Recomendaciones, https://forum.pfsense.org/index.php?topic=23265.0

    ¡De nada, para eso estamos!



  • Hola, pues yo empece el hilo…...pero aun sigo con los mismos problemas, son aleatorios y me pasa en todos los clientes donde he instalado un Pfsesne.....
    Adjunto pantallazo de las rules y del Logs.....la IP del movil es 192.168.30.98
    Espero su ayuda....gracias!!






  • adjunto mas logs…..no entiendo porque los bloquea si están explicitamente abiertos.....  :( :( :(




  • mansi

    Qué muestra la ventana emergente cuando clickeás en la cruz roja de la columna Act?

    Saludos



  • @rocaembole:

    mansi

    Qué muestra la ventana emergente cuando clickeás en la cruz roja de la columna Act?

    Saludos

    Hola, en la imagen del ultimo post se ve, pone… block/1000000103
    Gracias!!



  • Por lo que tengo entendido, default deny rule ipv4 se refiere a que la petición no matcheó con ninguna de las reglas declaradas

    https://doc.pfsense.org/index.php/Firewall_Rule_Troubleshooting#Check_the_Logs.21

    Además, hay algunos archivos que podrías mirar además de las logs, para depurar las reglas de firewall.

    https://forum.pfsense.org/index.php?topic=82319.0

    Mi humilde observación:

    Intercalaría las posiciones de las dos reglas del firewall en la interfaz LAN

    El segmento de red de la interfaz LAN es 192.168.30.0? Si es otro segmento, estás metiendo la regla en la interfaz equivocada.

    Abrazo



  • "It is also possible that the rules are not being loaded properly. Typically this would result in a notification in the GUI, however some manual tests can be performed to check what is happening.

    From the GUI, visit Status > Filter Reload. Press the Reload Filter button and wait to see if the process returns to say "Done." or if it stops. If it stops, for example in a particular package, then there may be a problem with that package.

    The ruleset can also be verified from the console or Diagnostics > Command in the Shell Execute box by running:

    pfctl -f /tmp/rules.debug

    If an error is displayed, it may have an obvious fix, or search for that error to find possible resolutions."

    https://doc.pfsense.org/index.php/Firewall_Rule_Troubleshooting#Ruleset_Loading



  • Raro…

    Igual es esto...

    Ajuste del MTU de las placas de red
    Necesario en algunos casos (por ejemplo, para correo Outlook con adjuntos)
    https://forum.pfsense.org/index.php/topic,21812.msg113545.html#msg113545



  • Gracias por la ayuda, la semana que viene lo probaré.



  • @bellera:

    Raro…

    Igual es esto...

    Ajuste del MTU de las placas de red
    Necesario en algunos casos (por ejemplo, para correo Outlook con adjuntos)
    https://forum.pfsense.org/index.php/topic,21812.msg113545.html#msg113545

    Hola necesito su ayuda, fijese que yo trabajo en una universidad de nicaragua y estoy impartiendo una clase que se llama Sistema Operativo de Redes y queria instalar el pfsense en virtual box y montar el portal cautivo.

    primero en virtual box habilite el primer adaptador como adaptador puente,  para usarlo como WAN y poder acceder desde fuera del VBox
    luego el segundo adaptador de red como red interna. para usarla como cliente Lan.

    pero al querer conectarme desde afuera con la direccion por dhcp que le asigna el adaptador a mi wan, no puedo y no me da internet al cliente LAN.

    Porfavor ayudeme!.


Log in to reply