CP VERY slow



  • I am not an IT guy, just an unfortunate soul that gets suckered into doing favors for family and their business.  Please forgive my (lack of) jargon.  I literally have to look up about every other acronym I come across on here.

    I have TWO systems experiencing the same problems.  One is in a hotel, the other goes into convention halls during trade shows.  Both are experiencing identical symptoms, and these symptoms were not present in 2.1.

    When I updated from 2.1 to 2.1.3 I noticed that webpage load times were obnoxious.  Not slow, stupidly slow.  The hotel has 150Mbps connection over cable and the convention center has an OCx (not sure on speed, but the portion I get maxes out my 100Mbps card.)  It took me a while to narrow down what was causing the problem, but I finally found it.  After removing every filter, rule, block, and package that I thought could possibly be the culprit, I finally decided to disable CP.  Like magic, speeds were up to the hardware limit and webpages are loading like they should.  I HAD per user bandwidth limiting enabled, but my MAC was in the passthrough list.  I thought maybe it was a glitch, so I removed the per user bandwidth limit.  Still runs slow.  Turn off CP, runs fast again.

    Updated the machines to 2.1.4.  Same results.  If I turn on CP, webpages run dog slow.  ALSO, I noticed that ping times are significantly greater, which makes no sense to me.  I went from 6ms when CP was off to 100-3000ms ping times when CP was on.  They're all over the place when the CP is on.

    Am I doing something wrong? Is there anything I can do to fix this?



  • Okay…  that was quick.  I have a temporary fix.

    I can ENABLE captive portal, DISABLE per user bandwidth limitation, and it will limit ALL users to what is in the boxes.  So the check box does not appear to be doing anything.  If I put 0s in the download and upload speed boxes, I get full speed even with CP enabled.

    IF the checkbox was the only thing that didn't work, that would be fine, but apparently leaving the limiter boxes empty on the pass through MAC no longer defaults to unlimited.  It used to!  If I leave the box empty, it limits the pass through MAC's to the same speed as the CP users.  By putting a large enough number in the limiter, I can effectively remove the limit from the pass through MAC devices.  However, if I delete this number, that pass through MAC device goes right back to being limited by the CP limit (regardless of the limit checkbox).



  • Hi,

    I use "Enable per-user bandwidth restriction" (checked) - using these settings: 2500 (Kbits upload) and 700 (Kbits download).
    It works pretty well for me, when I test speed limits with my iDevice.

    Slow portal behavior seems more a DNS issue to me.

    I remember seeing that when add MAC on the "pass-through-MAC" page, the speed settings over there aren't taken in account (bug ?!).