IPSec mit IPFire (Strongswan)



  • Hallo Beieinander,

    ich möchte meine pfsense 2.14 mit der IPFire  2.15 (79) über ipsec verbinden.

    IpFire nutzt jedoch Strongswan. Ich habe bereits herausgefunden, dass der Negotiation mode auf Main stehen muss, damit Strongswan funktionieren kann. Das geht ja auf beiden Firewalls ohne Probleme.

    Weiterhin benötigt die IPFire noch Left-ID und Right-ID in der Form @BlaBlub
    Ist es richtig, dass ich das bei der pfSense in My identifier und Peer identifier eintragen muss? Welchen Wert muß ich hier nehmen? Wird hier das “@” Zeichen auch führend benötigt?

    Fragen über Fragen…

    Kennt ihr vielleicht eine funktionierende Anleitung für diese Anforderung? Die Anleitungen, die sic auf die IPCop beziehen funktionieren bei mir nämlich nicht mehr.

    Any hints?

    Guido



  • Hmm,

    ich habe jetzt 3 Tage geggogelt und Anleitungen gewälzt, alle möglichen Oprioen durchprobiert.
    Es funktioniert nicht.

    pfSene ist nicht in der Lage per IPSec und PSK einen Tunnel aufzubauen.

    Guido


  • Moderator

    Hallo Guido,

    pfSene ist nicht in der Lage per IPSec und PSK einen Tunnel aufzubauen.

    Den Satz so wie er da steht wage ich zu bezweifeln. In deinem speziellen Fall scheint es eher an der Abstimmung der Konfiguration an beiden Enden zu liegen. pFsense selbst hat bislang meiner Erfahrung nach keine Probleme mit SWAN Gegenstellen, noch mit anderen kommerziellen Lösungen (Juniper, Cisco, Watchguard, Sophos o.ä.), so dass es sich hier fast sicher um ein Verständigungsproblem handelt.

    Da ich persönlich IPfire nicht kenne, bräuchte man hier schon mehr Input, um da weiterzuhelfen. Scheitert die Kommunikation bspw. in Phase 1 oder 2, wird überhaupt eine Verbindung aufgebaut etc. etc.

    Grüße
    Jens



  • Sorry…. aber ich muss diesen Thread ausgraben… da auch ich seit unzähligen Stunden versuche, eine IPSec PSK VPN Verbindung zwischen PFsense und IPFire hinzubekommen.

    Wäre schön, wenn sich hier jemand finden würde, der so etwas hinbekommen hat.



  • Hi,

    dann poste doch mal was unter dem logoutput von ipset steht.  (VPN -> IPSec und dann oben “related logs” Icon anklicken)
    Falls da nichts drin steht kannst du unter VPN -> IPSec -> advanced settings  in den ersten drei Dropdowns das Logginglevel ändern für tiefere einblicke.

    Gruß blex


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy