İp Telefon Sip Sorunu



  • Merhaba arkadaşlar kurmuş olduğumuz ip santrale pfsense bağlı ip telefonlar sunucuya bağlanıp register oluyor telefonlar bir birini arıyor fakat konuşma esnasında ses gidip gelmiyor 5060 portı ile ilgili bi sıkıntı var sanırım yardımcı olabilieseniz sevinirm..

    Yaptığım nat işlerimleri bu şekilde ama yine değişen birşey yok



  • aliases üzerine gel, port aliases oluştur mesela "voipport" adını ver
    içine
    5060:5079
    10000:30000
    3478
    7070:7079
    4569

    portlarını ekle ve voip-sip sunucu ipne voipport u yönlendir. sorunsuz kullanırsın.

    ![2014-07-14 11-49-35 pfsense.mgl.cc - Firewall Aliases - Google Chrome.png](/public/imported_attachments/1/2014-07-14 11-49-35 pfsense.mgl.cc - Firewall Aliases - Google Chrome.png)
    ![2014-07-14 11-49-35 pfsense.mgl.cc - Firewall Aliases - Google Chrome.png_thumb](/public/imported_attachments/1/2014-07-14 11-49-35 pfsense.mgl.cc - Firewall Aliases - Google Chrome.png_thumb)



  • Cevabın için çok teşekkürler fakat söylediklerini aynı şekilde yaptım ama yine bi sonuç alamadım başka bir yöntemi varmı acaba ?



  • 10.34.210.157 iç bacakta mıdır?
    eğer içerde ise gw den voipport aliases nat yapman gerekli.
    Ben bu şekilde elastix santralimi kullanıyorum 2-3 senedir sorun yok.



  • Yapıyı anlatayım ben size..

    10.34.210.0 local ağımda kullanılan bir vlan voip sunucum bu vlanda 10.34.210.157'ye kurlu pfsense makinamın wan bacağı ise bu vlanda 10.34.210.150'ye tanımlı pfsense LAN tarafı ise kablosuz internet için kullanıyorumm..
    şu an kablosuz internet tarafında voip telefon kullanamıyorum.. :(

    LAN - 10.34.210.0
    VoipSunucu - 10.34.210.157
    PfsenseWAN - 10.34.210.150
    PfsenseLAN - 10.10.0.0

    Umarım anlatabilmişimdir alians nat dediğin olay ise pfsense üzerinde ise onuda yaptım sanırım



  • arkadaşlar nat yaptıgınız portların udp olması yeterli tcp portlarıda yonlendirmeniz güvenlik acıgına yol acar



  • Selam,

    5060 sadece handshake(registration) içindir, asterisk kullanıyorsan sip.conf dosyandaki RDP port aralığına bakıp ona göre port (UDP) açman yeterlidir. Ses akışı RDP üzerinden yürür.



  • Nat'ta dogru ayarları yapman yetmiyor. Asterisk veya Elastix kullanıyorsan. Bazı ayarlar yapman gerekiyor. Sip settings bölümünden NAT ayarlaman lazım IP Santralde bazende codec sorunu olabiliyor.

    ![SIP NAT.png](/public/imported_attachments/1/SIP NAT.png)
    ![SIP NAT.png_thumb](/public/imported_attachments/1/SIP NAT.png_thumb)