"Вешается" обновление пакетов после обно&



  • Здравствуйте все.

    Не так давно обновил pfSense с 2.1.3 до 2.1.4 (возможно проблема, которая описана ниже, с этим никак не связана)

    В списке установленных пакетов появились 2 обновленных пакета asterisk и bind (может они, конечно, и раньше появились, просто не заметил), ну да не в этом дело.
    Решил их обновить…

    Вот на этом шаге как раз и получился грандиозный облом.

    При переустановке пакета из Package Manager, процесс останавливается на сообщении:

    Downloading https://files.pfsense.org/packages/8/All/bind-9.9.5_10-i386.pbi
    (extracting)

    При переключении в закладку "installed packages", в списке установленных пакетов он появляется НО, в web-интерфейсе его нет. Делал несколько попыток с разными вариантами установки-удаления пакета, с ручным вычищением установленного, всё то же самое, в списке есть, в web-интерфейсе нет.

    Может есть какое-нибудь решение такой проблемы?

    Остался последний вариант, вручную скачать недостающие в web-интерфейсе php-скрипты (благо в xml урлы указаны).



  • Выгрузите настройки без пакетов - есть такая возможность. После восстановления из этого бэкапа ставьте необходимые вам пакеты.

    И да, а чем вас необновленные не устраивают. Меня, например, это особо не беспокоит, потому как и старые отлично и беспроблемно работают.



  • @werter:

    И да, а чем вас необновленные не устраивают. Меня, например, это особо не беспокоит, потому как и старые отлично и беспроблемно работают.

    Ну, если беспроблемно то конечно да, смысла никакого…

    Да, честно говоря, что-то в мозгу моём "покосилось" после долгой и напряженной работы...  :-[ Дай, думаю, обновлюсь...
    Мало ли чего, может в обновлении какие косяки пофиксили...  :)

    Обновился, блин... Сам не рад...

    Да, собственно почему не рад... На очередные грабли наступил, проверил, так сказать, механизм обновления пакетов...  :D

    Практика показала - механизм работает криво...  ;D

    Хорошо хоть механизм обновления ядра работает как надо... А то, блин обновляемый шлюз в 5000 км от меня, и на той стороне нет никого кто мог бы хоть как-то помочь... :)



  • @werter:

    Выгрузите настройки без пакетов - есть такая возможность. После восстановления из этого бэкапа ставьте необходимые вам пакеты.

    Как я понимаю, все установленные пакеты, из списка установленных, радостно исчезнут?… :)
    Хоть по факту они и будут присутствовать, в списке их не будет?



  • Не будет. Поставите заново. Перед этим можете слить их конфиги руками, если это squid, lightsquid, openvpn etc. Еще можете сделать скрины разделов тех пакетов ,к-ые вам необходимы.

    P.s. Еще раз убеждаюсь, что лучшее - враг хорошего.



  • @werter:

    Не будет. Поставите заново. Перед этим можете слить их конфиги руками, если это squid, lightsquid, openvpn etc. Еще можете сделать скрины разделов тех пакетов ,к-ые вам необходимы.

    P.s. Еще раз убеждаюсь, что лучшее - враг хорошего.

    Ну, собственно почти всё получилось… :)

    Остается только пакет Asterisk'а... С ним всё то же что и было... ничего не поменялось... :(



  • Diagnostics-> Backup/restore->Package Functions->Reinstall Packages.
    Пробовали?

    Можно, в принципе, откатиться до 2.1.3…

    Хотя если все работает, а до шлюза 5000 км - оставьте, как есть.



  • @pigbrother:

    Diagnostics-> Backup/restore->Package Functions->Reinstall Packages.
    Пробовали?

    Можно, в принципе, откатиться до 2.1.3…

    Хотя если все работает, а до шлюза 5000 км - оставьте, как есть.

    Не, не успел попробовать, людям работать нуна… :)

    Сделал проще, сам pfSense на флешке, под моим чутким руководством, юзер развернул "стартовую" копию на флешку и всё... :)
    Юзеру, который на расстоянии в 5000 км., проще флешку поменять... :)

    Там, правда, ядро 2.1.3 но, это не страшно... Обновлю ядро...

    А вот с пакетами... Ну, старые ну и фиг с ними... Второй раз, на те же грабли.... Не охота чего-то... :)