WebGUI says user is non-local, even if it's local



  • Hi,

    I encountered this issue with User Manager. I created a test user test1 and assigned to it the User Manager: Password Manager permission. Then I tried to login with that account to the webGUI and I was given the following message: Sorry, you cannot change the password for a non-local user.

    Am I mistaken in assuming that users created using the User Manager page are local users?

    I tried to print the local users that were being tested in the code inside usr/local/www/system_usermanager_passwordmg.php that is used to check if a user is local or not. And I got this as a result: admin,admin. Note that currently there are only two users in the system, the admin account, and the test user test1 account.

    What do you think is happening here? Thanks!

    
    /* determine if user is not local to system */
    $islocal = false;
    foreach($config['system']['user'] as $user)
            print_r($user['name']); // print name of user
    	if($user['name'] == $_SESSION['Username'])
    		$islocal = true;
    ```![user add pfsense.png](/public/_imported_attachments_/1/user add pfsense.png)
    ![user add pfsense.png_thumb](/public/_imported_attachments_/1/user add pfsense.png_thumb)
    ![error message.png](/public/_imported_attachments_/1/error message.png)
    ![error message.png_thumb](/public/_imported_attachments_/1/error message.png_thumb)


  • For now, I have managed to fix the problem by replacing the code above with this one:

    $islocal = false;
    $cur_user = &getUserEntry($_SESSION['Username']);
    if ($cur_user)
            $islocal = true;
    
    


  • Hi !

    If have about 40 users in my User manager, an "admin" with at least "WebCfg - All pages" Privileges, and normal "PortalUsers" group users with "User - Services - Captive portal login" Privileges.

    When I declare a new group calls 'password', with this Privilege "WebCfg - System: User Password Manager page" and I make an user member of this group, the I'm capable of login in to the GUI and the only thing that's possible is: having the user changing its password ….

    So, it works for me.
    I can change the password for this user, when I login - its actually the only thing I can do with this user, and logout.

    Are you using the last version, 2.1.4-RELEASE (xx)  ?