Captive Portal + Proxy Port 8080



  • Hello, my english is not  very good but i'll try to explain the problem.

    I'm having a training course in my college, and i need to set up a Captive Portal on the Servers' room. First I've tried to make it right on my working station, but i'm having some trouble. Our internet proxy is running on the port 8080.
    When i try to open a local page ( i mean it does not use the proxy ) i'm redirected on a authenfication page, but when i try to access on google for example, the CP does not work anymore because pfsense doesn't capture the port 8080, since the proxy's port is 8080.

    So, is there a way to tell pfsense capture the port 8080 and so enable the CP on my college ?

    Thanks, Antoine



  • can you read my mind???  i have exactly the same issue, this is why i just registered :-)

    so can anyone help?

    my issue:
    my clients are configured to use a proxy: proxy.doesnotexist.org:8080 - they are convigured that way
    and can not change it, so they never get to the captive portal because they are looking for the proxy.

    so what i did is i called my pfsense proxy.doesnotexit.org and installd squid on port 8080 - works fine,
    the only issue is now that they can just browse the internet with out auth :-(
    squid authentication is not a option because this clients don't need internet they need to use there
    vpn clients - so they need more access then simply http.
    also this network has wlan-ap's connected and this is why i need captive portal and not just a "open network"

    please help,



  • Hey, i guess i'm not the only one with this problem

    Is  there a way to tell pfsense capture the port 8080, on a config file please ?

    Pls we need help or just advices



  • Helo :

    I have the same problem like you …

    if i enable the client pc internet proxy ( squid proxy that is not builded in pfsense, port 8080)
        then can't display CP auth page ...

    i have search this answer for a long time , do anybody know it ?? ....

    ps :  1) if client pc with no proxy setting , it work good
                2) if set up squid proxy port with 80, then CP work good, but it is not i need it



  • The captive portal is not compatible with proxies. I don't think there is an easy solution for this.



  • Workaround:

    you can edit file /etc/inc/captiveportal.inc
    Just find string
    'add 19902 set 1 fwd 127.0.0.1,8000 tcp from any to any 80 in'
    and append the next one
    'add 19902 set 1 fwd 127.0.0.1,8000 tcp from any to any 8080 in'



  • Hi ALL
    anyone confirm that

    Workaround:

    you can edit file /etc/inc/captiveportal.inc
    Just find string
    'add 19902 set 1 fwd 127.0.0.1,8000 tcp from any to any 80 in'
    and append the next one
    'add 19902 set 1 fwd 127.0.0.1,8000 tcp from any to any 8080 in'

    worked properly
    Thanks



  • Hi All :

    I am very happy to see someone can solve this problem, but 
      I am wonder why i have edit the /etc/inc/captiveportal.inc file and it don't work

    ???
      below is my captiveportal.inc …..
      -----
      $cprules .= << <eod<br># ... 10000-19899: rules per authenticated client go here...

    redirect non-authenticated clients to captive portal

    add 19902 set 1 fwd 127.0.0.1,8000 tcp from any to any 80 in
    add 19902 set 1 fwd 127.0.0.1,8000 tcp from any to any 8080 in

    ------

    hope you can give me some advice ...

    ps: 1. my english is poor
        2. the captive portal port is 8001, it is right ?</eod<br>


Locked