Captive portal wont start Address already in use



  • Hi I run pfsense 2.1.3-RELEASE on FreeBSD 8.3-RELEASE-p16

    I use multiple captive portals with https. One of them is using vouchers to connect guest users. That captive portal seems to have stoped working. In the services list the service has the status "not running" and this error message is in the general system log.

    php: /status_services.php: The command '/usr/local/sbin/lighttpd -f /var/etc/lighty-<name of="" captive="" portal="" here="">-SSL.conf' returned exit code '255', the output was '2014-08-04 11:02:45: (network.c.415) can't bind to port: 0.0.0.0 8003 Address already in use'

    Has anyone encounterd this error before? Any help is appreciated and id be happy to provide more information if needed.</name>



  • Ok I think I solved it by simply disabeling all captive portals, restarting and enable them one by one so that the ports wouldnt overlap as they restarted. I also got a feeling that the problem itself could have been an issue where the non-encrypted site took the port and that it kept it while I enabled https so that when using https the port was already taken by the same captive portal site but the non-encrypted version so to speak.

    Anyway, I noticed another problem that I seem to have in this version and that is that every time I rebbot the firewall I have to readd the .html sites for the captive portals. The files get deleted on a reboot. Anyway thats another problem for another day.