2.0.3 webGUI not responding to reset password done in the console. HELP!



  • Hi,

    currently am using 2.0.3 in one of by pfbox. For no reason my username/password no longer recongnized. Being able to connect console form putty, I was able to reset the password through the webconfiguration password reset, then rebooted it but the problem is the default is also not recognize?

    I didn't stop there, I shut down the whole system and rebooted it. Connected via putty and reset webconfigurator password. It prompted me that I successfully reset the password and that the defauls username/password is not in use. When I accessed my webGUI and typed in the default it really wont work. It says wrong username or password.

    Please help. What do I missed?

    Thanks!



  • Hi,

    A coupe of things to test/try:
    Is the data actually written to disk ?  (Goto ssh access, check the main config file in /cf/conf/config/xml)
    No disk problems ?? (space, error ?)
    Use another browser …

    Btw: Nobody knows nothing about 2.0.3 anymore, its far to deep in the past - we are 1000+ bug (resolved) further on ... So, What about updating ?



  • Yeah actually I was about to update it but how can i update it i can't even log to the webGUI? I tried logging in using another browser and another PC and laptops, still admin/pfsense is not working.

    I'm not that techie with regard to this. Perhaps you might want to throw me some backdoor resetting commands or force reset or whatever you call that. Please.



  • This option:

    1. Reset webConfigurator password
      should reset that password.

    2. should restart the web interface and you should even consider using 4) Reset to default. If after 4) your LAN interface isn't working the issue isn't software …
      Btw: your accessing pfSEnse on the LAN, right, not WAN, OPTx or whatever .. ?

    I even need it to get into the SSH ... (I'm not using non authenticated telnet access, only SSH with password, the same password)

    Anyway ... don't worry.
    I'll advice you to use option 8) Shell (SSH access) and save (USB key !) the /cf/conf/config.xml file.
    Better yet, use an FTP program that supports the protocol SFTP (NOT FTP, SFTP on port '22' - NOT '21') - use 'root' (not admin) and the password, to get in and save this file.

    Now, download a fresh recent copy of pfSense, and upgrade - overwrite everything.
    Afterwards, import your config.xml (Diagnostics => Import/Export) and your ok.

    Except, if this all boils down to a hardware problem.



  • @Gertjan:

    This option:

    1. Reset webConfigurator password
      should reset that password.

    I've done that. Consoles shows the username and password was reset to default. Restarted the box, accessed my webGUI, typed the default credentials and nothing happens. It say wrong credentials.

    I also did the option 11) restart webconfiguration, and same result. Still wrong log-in credential although it was already set to default. And yes, I am accessing the webGUI from LAN 192.168.51.1 not WAN of OPTx etc.

    I think I can  try the SSH option so how do I do it? Can you post the step by steps commands? thanks!

    I already have the most recent copy ready to upgrade. I can always overwrite everything but I was thinking not to waste the printed vouchers. I already printed and cut-out into card type so I was saving resources. That is the reason why I'm dying to gain access again via webGUI.

    I will be able to save config.xml one I gained access to it.



  • @onlineph:

    This option:

    1. Reset webConfigurator password
      should reset that password.

    I've done that.
    I will be able to save config.xml one I gained access to it.

    As soon as you see

    1. Reset webConfigurator password
      you should see also
      8 ) Shell
      so you have access to everything, also the config file.

    I start to think something is really wrong with your setup. It might a software issue (boot disk read only, so no settings are written) or even a hardware issue.
    You should format + reinstall and note every message that looks to an error to you.

    Don't keep yourself lock out for saving some printed vouchers  :-\



  • I had this issue when I had PFSense installed on a USB flash drive.

    Logging was on, and I shot past the write limit of the USB drive and it went read only.  Nothing I did stuck, and then it refused to boot.

    Any chance this is a similar setup?



  • Okay, I will explore 8}Shell

    I wish to download the system backup of the config.xml

    is there a specific commands that i need to employ?

    Help is much appreciated.



  • The command is not working it says "Not Permitted"