Squidguard 1.4_4 pkg v.1.9.6 group acl not working



  • I am running on pfsense 2.1.4-RELEASE (amd64)

    I can't seem to get the problem resolved in squidguard 3 from https://forum.pfsense.org/index.php?topic=78484.msg434367#msg434367 I switched to Squid 2.7.9 pkg v.4.3.4 and SquidGuard 1.4_4 pkg v.1.9.6.

    At first it gives me a good start but soon I am hitting the similar problem.  My setup is simple,

    Grourp
    GWL -> nWL_Urls and nWL_IPs (allow)
    GBL ->  nBL_IPs and nBL_Urls (block)
    GBLyoutube -> nBL_test (block)

    I noticed that the moment you got more than 2 groups it stop function, in this case GBLyoutube is not blocked.  If i shifted the GBLyoutube to the top and GBL to the bottom, the GBL won't work.  Is this a bug?

    Anyone know who is the one compiling this package or is there a place to file a bug for squidGuard?

    Thanks

    ![Screen Shot 08-14-14 at 03.41 PM 001.PNG](/public/imported_attachments/1/Screen Shot 08-14-14 at 03.41 PM 001.PNG)
    ![Screen Shot 08-14-14 at 03.41 PM 001.PNG_thumb](/public/imported_attachments/1/Screen Shot 08-14-14 at 03.41 PM 001.PNG_thumb)
    ![Screen Shot 08-14-14 at 03.41 PM.PNG](/public/imported_attachments/1/Screen Shot 08-14-14 at 03.41 PM.PNG)
    ![Screen Shot 08-14-14 at 03.41 PM.PNG_thumb](/public/imported_attachments/1/Screen Shot 08-14-14 at 03.41 PM.PNG_thumb)



  • I am using 2.2 and I am also facing the same issue. only Common ACL is working not Group ACL.

    If anyone had any luck with it.

    Thanks in advance.



  • Hi,

    I have had same problem on pfsense 2.2.4, squidGuard 1.9.14.
    I figured out, that once you have more groups
    a) just disable one of them -> save, under general settings save and apply
    b) enable the disabled one -> save, under general settings save and apply

    This trick works for me.

    Regards
    Jed



  • Hello.
    I have done 2 target categories (social sites & job sites)
    User(A)  group will get only social access, user(B)  group will get only job access.
    In user(A)  group one ip will get both sites access. So i create that ip in another group & allows both categories.
    But its no working.
    Please help me about this issue.
    (SORRY 🙏 FOR MY BAD ENGLISH)