[Gelöst] pfSense 2.1.4 OpenVPN Problem



  • Hallo.

    Ich habe pfSense 2.14 auf einem USB Stick installiert und nutze es auf einem kleinen Rechner.
    Wenn ich versuche eine Konfiguration im OpenVPN Client abzuspeichern, dann bekomme ich folgende Meldung:

    The following input errors were detected:
    An IPv4 protocol was selected, but the selected interface has no IPv4 adress.

    Ohne die Einstellungen, bekomme ich beim abspeichern die gleiche Meldung.

    Kennt jemand das Problem?
    Oder gib es schon eine Lösung dafür?



  • Ja, das passiert wenn das eingetragene WAN-Interface keine IP Adresse hat. Du musst entweder bei bestehender Internetverbindung das VPN einrichten, oder dem WAN Interface eine statische IP-Adresse eintragen. Dann sollte es funktionieren.



  • Danke für eine schnelle Antwort.

    Bei bestehender Internetverbindung hat es geklappt, aber mal so eine Frage. Wie gibt man dem WAN Interface eine statische IP-Adresse?



  • Interfaces -> WAN-Interface -> IPv4 Configuration Type "Static IPV4"

    • Static IPv4 configuration -> "IP-Adresse"

    Du kannst aber auch temporär das LAN-Interface zum Einrichten des VPN-Servers nutzen. Dann musst du aber, wenn der Server produktiv geht, das Interface wieder umswitchen (Was eine aktive Internetverbindung voraussetzt)

    Diese Restriktion ist etwas unglücklich gewählt, da es das Anlegen eines VPN-Dienstes bei einer nicht produktiven Pfsense verkompliziert wird. Aber vielleicht gibt es einen Grund warum das gemacht wurde.