Ath0: stuck beacon; resetting (bmiss count 4)



  • Hello everybody,

    I have just installed pfSense 2.1.5 on my new APU + the Compex WLE200NX WiFi Card. pfSense works with the cabled network, but the WiFi does work. The console on the machine prints this error continuously;

    ath0: stuck beacon; resetting (bmiss count 4)

    The error stops when I disable ath0 in the WebConfigurator

    I have looked around, but most of the topics regarding this subject is really old, and I can't find any solution.

    Any tips?

    Thanks!



  • Got same problem after upgrade to 2.1.5.

    hw.ath.bstuck = 8
    hw.ath.longcal = 30

    not worked for me



  • Hi All,
    I have also currently the same problem.
    Same Wifi card (Compex WLE200NX) + 2.1.5 Image.
    Any idea what could be the problem please ?
    I tried already different configurations of the card, also the trick with adding these settings in loader.conf, all of these not helping.
    Thanks !!



  • I found out that Upgrading to 2.2.Alpha will help.



  • Hi All,
    it seems the following changes are helping. I did it 4 hours ago, till now it seems to work in the right way.

    hw.ath.bstuck = 8
    hw.ath.longcal = 30

    BUT it works only when you add those settings in System -> Advanced -> System Tunables
    Have a look on what it looks like for me.

    However, I have a second issue :
    The miniPCI card Complex WLE200NX has two connectors for Antennas. But for my purposes, I bought only one Antenna. I'm getting a very very poor signal an I guess it's the because is trying to use  the diversity property, enabling the use of two anntennas. TX & RX must be changed to the one port (on the card shown as "1" - I have port "0" and "1").

    So how to change those settings please and let them permanent ? Thanks !




  • Hi all,

    I have also this random issue with my pcEngine machine and Atheros Wifi card.

    Everything works fine for few days and then it fails.
    The only way to make it works again is to reboot the pfSense.

    I will try your fix.

    Are you all using Atheros adapters ?



  • ok let  us know if this helped. THanks :)



  • Try to change cannel. This happens in noisy environments and is caused by a bug in the driver that flushes the TX queue when a ath reset occurs. Its fixed in FreeBSD 10 I believe.



  • I also have the WLE200NX  and am haveing the same issue I did the tuning but still noting.  I am using both antennias


Log in to reply