Associated but not connected



  • Hello dear friends!

    First time in the forum and first time with wireless on pfSense.

    I need to connect to an access point WIFI_SSID, with static IP config network 20.0.0.0 (I know it is wrong, it's not my fault and I don't have power over this) and using fixed MAC address M4:Ca:dd:re:ss.

    I was using pfSense 2.2-ALPHA with no success. I always got "no carrier" status.

    Back to the 2.1.3-RELEASE, I get "associated", but I can't do anything.
    I try ping my gateway (20.0.0.1) or other host, and get "host down".

    I'm writing right now using this same set on Kali Linux.

    My wireless card chipset is a Ralink.

    Do I missed something or did wrong?

    Any response is appreciated.

    Cheers! o/



  • I have some news:

    Installed the 2.1.5-RELEASE, and test it clean (minimal config).

    Associated with WIFI_SSID, but no ping or IP (since DHCP server is not available).
    Set static IP address (20.0.0.100) and gateway (20.0.0.1) and tried ping. Ping to others common hosts (20.0.0.50, 20.0.0.150, 20.0.0.200, …) works fine. Ping to gateway fail, because the gateway does not respond ping from unknown hosts, so it's ok.

    Now, the moment of truth!
    With the same sets, I changed the MAC address, and so... nothing works anymore.  :(
    Tried others IPs and MACs address, but nothing.
    Setting the MAC address to the real interface MAC address, the things come back to work.

    I searched here about MAC spoof/clone, but didn't find nothing related.
    Should this be a bug? May I report it? There is something else I can do to confirm "this bug"?

    Cheers! o/