MULTIWAN FAILOVER NO FUNCIONA CORRECTAMENTE



  • Buen día, estoy presentando un problema, tengo lo siguiente:

    LAN
    WAN1
    WAN2

    Cree un grupo de Gateway en System-> Routing-> Groups en donde WAN 1 tiene Tier 1 y WAN 2 Tier 2. Lo llamé MultiWAN, también cree mi regla en el Firewall para redireccionar el tráfico de la LAN a MultiWAN. En cuanto quiero hacer la prueba y desconectar a WAN 1, se pierde por completo la conexión a internet, en vez de pasar a WAN 2, para que recién me brinde internet sin WAN 1, tengo que ir a System -> Routing -> Gateways y pasar WAN 2 a default en vez de que sea automático.

    Necesitan algún dato adicional para poder ayudarme? No se como colocar imágenes…

    Uso PfSense 2.1.4


  • Rebel Alliance

    Cómo tienes configurados los DNS's, adjunta capturas de pantalla de "System –> General Setup"

    https://forum.pfsense.org/index.php/topic,72077.0.html



  • No se adjuntar imagen, así que la estoy colgando en este enlace.

    https://www.dropbox.com/s/4idtqoz2279zhns/1.png?dl=0



  • Uso estos paquetes también… Solo los menciono por si llegan a ser necesarios.

    https://www.dropbox.com/s/4idtqoz2279zhns/1.png?dl=0


  • Rebel Alliance

    Las Imágenes (y otros tipos de archivo) las/los adjuntas mediante la opción "+ Attachments and other options" (puedes adjuntas varias)

    Lo primero que tenias que haber mencionado era que utilizas Squid ! ;)

    Utiliza el buscador del foro, y encuentras varios hilos que hablan de "Squid y Multi Wan"




  • Tienes el link específico? O me podrías ayudar por aca? Por favor, no encuentro y estoy algo desesperado, lo necesito terminar lo más pronto posible!! Muchas Gracias!


  • Rebel Alliance

    No utilizo/manejo Squid, por lo que "hasta aquí llego"

    Respecto a los links, como Squid no es tema de mi interés, no los he guardado, por lo que tendrás que dedicarle un rato al Buscador :(



  • Muchas gracias. Ya encontre unos árticulos, voy a ver que tal va.



  • Con el siguiente video de youtube, tenes todo lo que necesitas porque te falta controlar realmente el failover.

    DUAL WAN ON PFSENSE 2



  • Anexo como lo tengo y me funciona.

    Recuerda que primero debes balancear la salida de internet, es decir que se navegue en los 2 proveedores (enlaces) de servicios que tengas y luego el failover.  por si se cae enlace A siga trabajando enlace B y a lo contario. Resumen 3 reglas que debes aplicar en la LAN

    Te anexo las imagenes.





  • Rebel Alliance

    Y con "eso" te funciona el "Failover + Squid" ?

    La única regla que aplica es la regla "Salida LAN con Balanceo"  las 2 ultimas no aplicarán nunca, ya que en la primera tienes como origen "Any" y como destino "Any"

    @Bellera, creo que habría que editar el Título del Tema/hilo, y agregar/aclarar que se trata de "Failover + Squid"



  • @ptt

    Si

    Antes de realizar el balanceo, toda la salida de internet se me iba por wan….  y wan1 no tenia nada de trafico.

    Apenas aplique el balanceo, se empezo a ver actividad en wan1

    Adicional, probe descargando archivos, por ej. isos de 1GB. Antes de los cambios, si apagada 1 enlance la descarga se cortaba.

    Despues de aplicar el failover, al apagar 1 de los 2 enlaces (el que sea) la descarga continua.

    PD: uso squid modo transparente con squidguard, lo antes mencionado no tubo nada que ver con mi proxy.


  • Rebel Alliance

    Pues te diré que no tienen mucho sentido tus reglas  :-\

    Pero, bueno, si te funciona…. en hora buena.



  • Buenas, ayer justamente probe esa configuracion y a mi no me anduvo ni a palos y esta tal cual, los mismos pasos del video, nada mas que yo tengo proxy no transparante, al sacar un enlace quedaba muerto y por mas que lo volvia a conectar no arrancaba mas y el proxy me quedaba tirando error de cache…



  • Esta algo confuso. Según he visto para que me funcione mi failover + squid, debo:

    • Crear una regla floating
    • Agregar una esta linea "tcp_outgoing_address 127.0.0.1;" en Custom Settings dentro de Proxy Server

    Pero veo que hay varias formas de hacerlo, cual sería entonces la correcta para hacer un Multiwan, que sea "Failover", no "Balanceo de Carga" o si se podrían hacer los 2 mejor.



  • ¿Te tomaste la molestia de ver el video que te puse?

    De esa forma lo he implementado en producción y funciona.



  • Para hacer hacer un failover deberas de configurar tu grupo de interfaces como se ha explicado muchas veces en el foro. Configurar tus servicios como siempre  e intenta usar la opcion

    Load Balancing
    Allow default gateway switching

    Que se encuentra en Advanced->Miscelaneus .

    Checa y comenta como te va



  • Buenas, yo he seguido el video y lo que esta en el foro pero no funciona, bajo la wan1 y chau dejo de navegar, aclaro que tengo proxy no transparente squid3, puede ser por eso? si es asi como lo soluciono porque esa parte no encuentro en ningun lado o es que no se puede hacer?
    lo quiero lograr es balanceo, en el caso de falla de algun enlace fail over, y proxy no trasparente. es muy loco lo que quiero realizar


Log in to reply