Eine Adresse kann nicht erreicht werden



  • Ich habe seit ein paar Tagen ein lästiges Problem. Wahrscheinlich hat es mit dem Update auf 2.1.5 zu tun, kann das aber nicht verifizieren. Ich habe eine ganz bestimmte IP-Adresse, bzw. FQDN, die oder den ich nicht erreichen kann. Erst dachte ich, das Problem läge an diesem Server. Das konnte ich aber durch Testen von anderen Netzen und anderen Routern ausschliessen. Seltsam ist auch, dass Traceroute den Server findet. Es macht den Anschein, dass nur diese Adresse von meiner pfSense nicht erreicht werden will.```
    ping 9653.140475.sip.pbxww.com
    PING [domain.com] (1.2.3.4): 56 data bytes
    92 bytes from 1.2.3.4: Destination Port Unreachable
    Vr HL TOS  Len  ID Flg  off TTL Pro  cks      Src      Dst
    4  5  00 5400 ebde  0 0000  39  01 8bb5 2.3.4.5  1.2.3.4

    Request timeout for icmp_seq 0
    92 bytes from 1.2.3.4: Destination Port Unreachable
    Vr HL TOS  Len  ID Flg  off TTL Pro  cks      Src      Dst
    4  5  00 5400 d29f  0 0000  39  01 a4f4 2.3.4.5  1.2.3.4

    Ich habe schon alle Einstellungen mit einer anderen pfSense (2.1.4) verglichen und nichts bemerkt, was sich unterscheiden würde.
    Was kann ich noch tun, bzw. ausprobieren?
    
    Habe zwar noch keine Lösung, aber das Problem scheint doch auf der Gegenseite zu liegen. Meine IP ist dort (SIP-Provider) wohl auf eine Blacklist gekommen.


  • So, in der Zwischenzeit bin ich einen weiteren Schritt weiter. Nachdem meine IP-Adresse entsperrt worden ist, ist die Adresse wieder erreichbar.
    Jetzt kommt aber das eigentliche Problem:

    Ich kann über den Asterisk, der hinter der pfSense steht keine Anrufe über diesen Provider führen (andere Provider funktionieren problemlos). Eingehende Gespräche kommen an. Wenn ich anstatt über den Asterisk über ein Softphone telefonieren will, geht das auch.

    Auf der Asterisk-Konsole hingegen erhalte ich immer folgende Meldung:```
    chan_sip.c:4174 retrans_pkt: Retransmission timeout reached on transmission 2fd07b462e70d25878b99b0d0f569947@provider.com for seqno 103 (Critical Request)

    
    Ich finde leider keine helfenden Hinweise dazu im Internet. Wer kennt sich damit aus? Soweit ich herausfinden konnte, ist das ein NAT-Problem. Aber was ist dagegen zu tun?