IPTV и Интернет на разных VLAN



  • Имеется маршрутизатор на платформе ALIX.2D13. установлен pfSense 2.1.5 От провайдера (Ростелеком) предоставлены VLAN 1423 - Интернет(PPPоE) VLAN 550 - IPTV(Трансляция идет с Нижнего Новгорода).Настраивал по документации:ru.doc.pfsense.org и по ветке форума forum.pfsense.org  До этого стоял Zyxell Keeenetik все работало. Бьюсь три дня интернет работает IPTV не в какую.
              Что делалось, были подняты VLAN 1423 и VLAN 550 c родительским интерфейсом vr0 на WAN поднят pppoe с vlan 1423 на интерфейсе IPTV VLAN 550 был поднят IGMP прокси upstream IPTV(networks 233.99.61.0/24) downstream LAN (networks 192.168.0.0/24) были прописаны разрешающие правила для UDP и IGMP на 224.0.0.0/4. Ниже приведена схема моего подключения.
    Жду помощи в настройке.За дельное предложение денежное вознаграждение.




  • Выкладываю логи pfsense




  • После четырех дней мучений все таки настроил позже выложу настройки.



  • @klimvoroshilov13
    Столкнулся с той же проблемой. У вас не сохранилась эта информация?
    Понимаю, что дело давнее, но может быть...



  • Тоже столкнулся с этой проблемой. В итоге собрав инфу c форумов, решил проблему без igmp proxy.
    Добавил Vlan 688 (тег iptv в моем случае) и через отдельный интерфейс подключил тв приставку ростелекома.
    В итоге, в pfsense получилось 2 интерфейса: OPT1 (vlan 688) и OPT2 (тв приставка).
    Дальше назначил им статическое ip через консоль (у меня 192.168.20.1/28 - OPT1 и 192.168.20.4/28 OPT2). DHCP для них включать не нужно.
    Далее через веб интерфейс pfsense сделал мост (вкладка Interfaces - Bridges), объединив OPT1 и OPT2.
    После сгруппировал интерфейсы OPT1 и OPT2 (вкладка Interfaces - Interface Groups) и назвал IPTV_group.
    Следующим шагом настроил файрволл (вкладка Firewall - Rules). Тут должны появиться вкладки с созданными интерфейсами OPT1 и OPT2, а также группа IPTV_group. Добавил этим интерфейсам разрешающее правило. Обязательно надо ставить галочку Allow IP options - Allow packets with IP options to pass. Otherwise they are blocked by default. This is usually only seen with multicast traffic.


Log in to reply