Cannot disable WebGUI redirect. Checkbox appears to do nothing.



  • Hello again everybody!

    I am running a fresh reinstall as of yesterday of pfSense 2.1.5 embedded on my NetGate APU 4. I have set the WebGUI port to 4483, and am trying to serve a wpad.dat file on port 80 via the vhosts package. When the checkbox under System->Advanced->"Disable webConfigurator redirect rule". Without that box checked, vhosts is unable to bind to port 80. When it is checked, it can bind successfully, but attempts to download autoconfig scripts timeout. Additionally, when I open my web browser and go to http://wpad.[mydomain.tld]/wpad.dat redirects me to https://wpad.[mydomain.tld]:8443/wpad.dat . I have the correct domain name setup in both System->General Setup , as well as in the wpad hostname setup in DNS Forwarder settings.

    How do I /actually/ disable the redirection settings?

    For troubleshooting, I have tried removing the custom port number for the https Web GUI. I do not want to leave the WebGUI set to http. I will try it temporarily to test if this works, just for the sake of trying it.

    Help!!



  • Ok, an Update:

    I have cleared out the "port" override box, and set the WebGUI to use http, instead of https.

    When I do this, the WebGUI appears to function normally. Attempts to go to http://wpad.[mydomain.tld]/wpad.dat are STILL being redirected to https on port 4483! Something seems to be sticking in the settings. I highly suspect a BUG in the WebGUI!

    What can I do about it?



  • I got this working. Had to wipe my install, however, and reinstall from scratch. Seems to have been a glitch on the one install.

    Problem solved.



  • It happens - I usually like a reinstall when something odd is being glitchy - People usually rather fight it for a few weeks first. (-;


Log in to reply