[solved] Error every time I try to post to the forum



  • Every time I create a post, add a reply, or edit an existing post, when I click the Post/Save button, I get the following error message.  If I use my browser's back button and immediately click Post/Save again, it usually works without error.  Sometimes it takes 2-3 tries for the Save to actually work.  What's up?  I haven't tried clearing my cookies but this problem has been happening for weeks/months.

    Error 403
    
    We're sorry, but we could not fulfill your request for /index.php?action=post2;start=0;msg=445070;b4efec6cbc=b265d031496746953612291f92c61818;board=57 on this server.
    
    You do not have permission to access this server. Before trying again, close your browser, run anti-virus and anti-spyware software and remove any viruses and spyware from your computer.
    
    Your technical support key is: 6c21-a40a-b40c-8ddc
    
    You can use this key to fix this problem yourself.
    
    If you are unable to fix the problem yourself, please contact the WEBMA5TER and be sure to provide the technical support key shown above.
    


  • having the same issue with waterfox (a 64bit firefox port). not sure if its the browser or some plugins,etc. Using ie11 now for this forum.



  • Others have come to the conclusion that it seems to be a Firefox-specific issue.  I'm a Chrome user and I've never had any such issues.

    Hilarious.  Just as I typed this and clicked Post, I got the error myself.

    Nevermind me.



  • Not just limited to FF. I'm a Chrome user too and it hits me when I try to search the forums, which is rather inconvenient too.

    (AND hit the Post button…apparently!)



  • Whew, after 1-2 days with no responses, I was beginning to think I was the only one!  I use Chrome too, btw.  Thanks for your replies.

    Now we need the forum admin to join in and investigate.



  • Shot in the dark - You guys using proxies or squid or anything?



  • @kejianshi:

    Shot in the dark - You guys using proxies or squid or anything?

    Yep:
    squi3-dev 3.3.10 pkg 2.2.2
    dansguardian 2.12.0.3_2 pkg v.0.1.8 (fixed using one of Marcello's binaries)

    And at first I thought it was related to a dansguardian bug, but I ran into that early on and corrected it. Don't think that's it.
    Besides, the forum is HTTPS, not HTTP, and I don't have squid configured to intercept HTTPS. So in my case at least, that rules out proxies.



  • I'll wait to see what the others having the problem say before I mark proxy off as a culprit.



  • Yes, Squid3.



  • Apparently not the whole pfsense page is https, according to my security check just now.
    Another shot in the dark….  Thats the part having proxy issues.

    All just guesses.


  • Netgate Administrator

    That looks like the output from 'Bad Behaviour'. Have any of you tried following up the given error code to see why it was rejected?

    Looks like:
    @http://ioerror.us/bb2-support-key?key=b40c8ddc:

    Technical Support

    Your web browser's request contained old or corrupted cookies.

    To resolve this problem, first clean your computer of viruses and other malware. Then clear your cookies for the site you were visiting.

    Steve



  • Stale cache?


  • LAYER 8 Netgate

    Just got this.  Clicked on the link and it detailed "stale" cookies.  Deleted cookies for forum.pfsense.org and…..

    Guess it worked.



  • And do you use squid?


  • LAYER 8 Netgate

    No squid (I thought I said that but that was in the post before that also bombed out before I fixed it.)



  • I guess I was wrong then - I blame squid for lots of things (-:



  • I do not use snort or a proxy.

    I made several "test" replies to this thread and they all worked without error this morning.  I then tried replying to several other people's threads, and sometimes it worked, and other times it gave me the usual error.  I then cleared all my cookies/cache and made some more replies and even a new thread.  I didn't see the error anymore.  It might be fixed by clearing the cookies/cache.

    I'll post back here if the problem happens again.  I wonder if it has something to do with the login page where it asks how many minutes to stay logged in, and also allows the user to check the box that says "always stay logged in".


  • Rebel Alliance Moderator

    I had that error many times now when working from home or being at work as my browser syncs settings. Sometimes it hit me at work, sometimes it's at home. Every time I have to completely wipe out any pfsense cookies, close all tabs related and login "fresh" again. Defeats the purpose of staying logged in if the cookie gets "bad" after a few days/weeks.

    No, not using Proxies, Squid or whatever. Clean connection. And as I'm running very different OSes (Linux, Mac, Windows) at different locations, it's nothing related to the OS underneath (or like the error says "clean your computer" chuckle).

    Also have no forum on my list, where this happens (and a few of them are SMF 2.x).

    Greets


  • Netgate Administrator

    Any of those other forums running bad behaviour?
    Perhaps your browser syncing across several machines is giving trouble. Have you tried other browsers?

    Steve


  • Rebel Alliance Moderator

    @Steve You were referring me? If so, yes I also used other browsers (firefox in that case, as I mainly use Chrome synced across Win/Lin/Android) and even a stay-logged-in-Firefox had the same problem once in a while that I had to remove the cookie from its cache.

    Last time was a few weeks ago, since then I'm good. Hasn't happen again and I'm hoping it is fixed.

    Greets Jens


Log in to reply