PFsense consumindo muitra RAM



  • Deixei o pf sense instalado em uma maquina virtual  aqui no servidor da empresa e deixei 2 gb de ram dedicado para ele e 50gb de hd, mas a memória ram ta enchendo direto e está dando erro…

    como faço pra resolver esse problema?



  • aumenta memoria…



  • @Lucas:

    aumenta memoria…

    A solução simples é essa mesmo.

    Se tem proxy pode ser que o valor de uso de memória atributo esta alto.



  • @Tomas:

    @Lucas:

    aumenta memoria…

    A solução simples é essa mesmo.

    Se tem proxy pode ser que o valor de uso de memória atributo esta alto.

    O detalhe é que no momento não tenho mais memória para liberar para ele, tenho no servidor só 4 gb 2 ja estão pro servidor de windows… ele está consumindo 2 gb, tem alguma outra forma de eu diminuir a quantidade de memoria a ser usada pelo PFsense sem ele travar?



  • Conheço este do anexo. Diminua ele.




  • @Maicon:

    Conheço este do anexo. Diminua ele.

    eu mudei aqui a configuração da  cache para o servidor do Squid, vou monitorar aqui na empresa até amanha pra ver se da algum erro, mas parece que vvai dar certo, obrigado



  • Tive o mesmo problema hoje. Pode me confirmar a versão do seu pfsense ? Utilizo a 2.1.5, achei estranho pois não me tinha ocorrido isto antes de atualizar para essa versão.



  • Não funcionou, ele continua consumindo  os 2 Gb de ram e travando o servidor… qual seria a solução para esse problema, configurei o squid para consumir somente 1gb para cach mas mesmo assim ele consome os 2 gb, o que mais  consome tanta memoria ram no pfsense?



  • foda, agora eu aumentei a memória dele para 3gb e ainda sim ele está enchendo ela e travando… nussa  ele consome tanta memória assim?



  • Pode postar as configurações do cache?



  • @Tomas:

    Pode postar as configurações do cache?

    ![cach 1.jpg](/public/imported_attachments/1/cach 1.jpg)
    ![cach 1.jpg_thumb](/public/imported_attachments/1/cach 1.jpg_thumb)



  • segue

    ![cach 2.jpg](/public/imported_attachments/1/cach 2.jpg)
    ![cach 2.jpg_thumb](/public/imported_attachments/1/cach 2.jpg_thumb)



  • segue

    ![cach 3.jpg](/public/imported_attachments/1/cach 3.jpg)
    ![cach 3.jpg_thumb](/public/imported_attachments/1/cach 3.jpg_thumb)



  • segue

    ![cach 4.jpg](/public/imported_attachments/1/cach 4.jpg)
    ![cach 4.jpg_thumb](/public/imported_attachments/1/cach 4.jpg_thumb)



  • Acho que uma boa ideia seria colocar os valores padrões e ir testando e ajustando:

    Maximum object size : 4

    Maximum object size in RAM : 32



  • ja estava no padrão quando  começou a ter esse problema…



  • Ja verificou via shell qual o processo que está consumindo mais memoria ?



  • @calijurio:

    segue

    não coloca o valor da memória quebrado …

    segue o padrão dos octetos !

    8 ~ 16~ 32 ~ 64 ~ 128 ~ 256 ~ 512 ~ 1024 ~ 2048



  • @holiveira:

    Ja verificou via shell qual o processo que está consumindo mais memoria ?

    sou um usuário de baixo nivel Linux, vc poderia me falar quais são os comandos que eu devo colocar?



  • @JuniorAndrade:

    @calijurio:

    segue

    não coloca o valor da memória quebrado …

    segue o padrão dos octetos !

    8 ~ 16~ 32 ~ 64 ~ 128 ~ 256 ~ 512 ~ 1024 ~ 2048

    Olha, eu configurei 1024, mas quando olho no painel do VMware o sistema ta consumindo 2,24 Gb de RAM, o que será que está consumindo o 1,24GB?



  • @calijurio:

    sou um usuário de baixo nivel Linux, vc poderia me falar quais são os comandos que eu devo colocar?

    Tente: ps aux | sort -k 4 -r | head -n 2



  • @calijurio:

    @JuniorAndrade:

    @calijurio:

    segue

    não coloca o valor da memória quebrado …

    segue o padrão dos octetos !

    8 ~ 16~ 32 ~ 64 ~ 128 ~ 256 ~ 512 ~ 1024 ~ 2048

    Olha, eu configurei 1024, mas quando olho no painel do VMware o sistema ta consumindo 2,24 Gb de RAM, o que será que está consumindo o 1,24GB?

    Você está com 1024 agora ? se estiver diminua, eu uso isto mas minha maquina tem 4GB e não é uma maquina virtual, e mesmo assim já tive problemas com consumo de ram.



  • Olha, eu configurei 1024, mas quando olho no painel do VMware o sistema ta consumindo 2,24 Gb de RAM, o que será que está consumindo o 1,24GB?

    a visualizacao do painel do virtualizador nao vai te mostrar o consumo em tempo real, ele vai te mostra o que foi configurado para uso, no maximo uma estimativa do consumo real.. ou seja, não é base para verificar o consumo do equipamento..



  • eu reinstalei ele, eu tinha instalado a versão 64bits agora instalei a 32bits e configurei mais espaço no HD o que tinha configurado automaticamente 6 gb agora configurei 100 gb…
    parece que ta ficando mais estabilizado o consumo da memória ram.... mas percebi mesmo antes de instalar o Squid3 so o sistema tava acusando um consumo de 1,26gb de ram...


Log in to reply