Squid3-dev and SquidGuard-squid3 - reset configuration when restart/shutdown



  • hello there, Im a new Member and New user of PFsense
    I'm having trouble on saving the configuration of the said package.

    my current PFsense version is: 2.1.5-RELEASE (i386)
    and package installed is Squid3-dev and Squidguard-squid3

    this is the procedure done on my installing pfsense.

    1. Installing 2.1.4 Pfsense
    2. Upgrading to 2.1.5
    3. Installing package Squid3-dev
    4. Installing package Squidguard-squid3
    5. Setting up the Squid3-dev while Squidguard-squid3 is still disable

    after saving everything. all the settings is successful and Download caching is ok, i was able to download files at its max in 2nd downloading of the same files which mean the files is caching in server proxy.
    now my problem is when im shutting down the pfsense unit or restarting all the save and configuration is not active until im going to access again the PFsense configuration and goto "Server Proxy" and save again without resetting the configuration, I only need to click the save button below in order to work again.

    My Router and PFsense is not 24/7 online since im saving electricity consumption.  so that is a major problem to me everytime im going to use an internet.

    is anyone had experience this and how to solve the problem..



  • –bump--

    any help? still my problem today



  • Anything in your System log around bootup time?  Shooting in the dark here.  What is the symptom of the actual problem that makes you click Save to make it work again?  Are you unable to browse anywhere, or are policies not being followed?



  • I just follow this procedure from youtube http://www.youtube.com/watch?v=czU56xmJAmE using the latest pfsense firmware and squids version.
    my only problem is when im restarting or shutting down the pfsense unit the Squid3-dev and Squidguard-squid3 is not working, I had to access the pfsense gui configuration and going to Services:Proxy Server and click again the Save Button below and it works until restarting or shutting down the server. but on my setup squidguard is currently disable.

    still this was my problem today.

    thanks for the response.



  • You keep telling me what you have to do to fix the problem without telling me the actual problem.  What is the symptom of the actual problem that makes you click Save to make it work again?  Are you unable to browse anywhere, or are policies not being followed?  Also, I asked about your System log?…



  • sorry for misunderstanding, I'm using the PFsense for server cache like downloading windows updates,  documents, files and etc. and hoping it works too in youtube caching. now after I'm setting the squid3 for server cache and click the save button below it works by first download the download speed was about 600kbps speed then for the second download with the same file it increases up to 12+mbps.

    now my problem is when I'm shutting down the pfsense unit and turning it on. squid3 package is not working it will not cache my downloads I had to access again the pfsense configuration and goto "Services: Proxy Server" and click again the Save button below to make it work again without resetting the squid3 (just plainly click the save button). which mean every time I shutting down the unit I had to access the Pfsense GUI configuration.



  • OK, now we're getting somewhere.  You have to click Save for Squid to start caching.  How do you know that Squid isn't caching your downloads?  Dynamic content can be very tricky to cache for long.



  • till now the squid3 proxy server is not working everytime I Restart the unit.

    Im downloading the Nvidia Driver from here just to confirm if working or not. http://www.geforce.com/drivers/results/77224
    after I Click the Save button below from Pfsense: Service;Proxy Server. the Downloding of Nvidia Driver is significantly downloading at 12mbps at 2nd download from about 600kbps at 1st download
    but when I shut down the Pfsense Unit and turning it on again it suppose to download at about 12mbps but not (the same file from http://www.geforce.com/drivers/results/77224),
    its only about 600kbps +/- speed.
    I need to go again at Pfsense configuration just to click the save button from Services;Proxy Server to work again. (if i will not do this procedure even how many times I download this same files the download speed is just about 600kbps and I will never reach the 12mbps download speed which mean server caching is not working.)

    but if I turning it on the pfsense from Off status and fully operational, I directly goto pfsense:Services;Proxy Server and click the save button. My first download at same file as this http://www.geforce.com/drivers/results/77224, the speed is at 10-12mbps which mean the server cache is working correctly.

    that procedure confirms that my settings on PFsense Server Cache is not saving properly upon shutting down.

    if this squid package issue won't solve, I might try to use lusca at stated at other reviews that this method is tested and working properly but sadly pfsense didn't support this package.



  • Interesting.  I haven't noticed this behaviour myself as I never turn it off.  When this happens, SSH in and take a look at your access.log in /var/squid/logs.  What does it say about the file you're trying to download?  IF you want to use some static files for your testing just to rule out if it is dynamic content issues, then use a static test file from cachefly:

    http://cachefly.cachefly.net/10mb.test

    http://cachefly.cachefly.net/100mb.test



  • thanks for your response, I will look and review what you say, I'm hoping to solve this problem, otherwise im gonna give a shot with lusca.


Log in to reply