FTP Passive Mode Probleme - debug.pfftpproxy



  • Hallo zusammen

    Ich hätte nochmals eine Frage und zwar geht es um die Option "debug.pfftpproxy". Solange diese auf "default" ist funktioniern alle FTP Verbindungen ohne passive Mode normal. Jene mit passive Mode brechen nach einer gewissen Zeit ab. Wird der Wert auf "1" gesetzt, funktionieren zwar Verbindungen mit passive Mode, ohne jedoch nicht mehr.

    Leider ist es für mich unumgänglich Verbindungen mit und ohne passive Mode zu unterstützen.

    Kennt von euch jemand das Problem und kann mir weiter helfen?

    Vielen Dank und liebe Grüsse

    Lars



  • Hi,

    ich habe debug.pfftpproxy auch auf 1 stehen und somit deaktiviert.
    Damit ich von extern auf den FTP Server komme habe ich noch zusätzliche Ports in den Firewall Regeln auf dem WAN Interfaces zum FTP Port (21) aufgemacht (55536 - 55555).
    Die Ports habe ich dann noch am FTP Server als PassivePort Range angegeben.

    Damit hat es bei mir funktioniert.



  • Hi BeNe

    Vielen Dank für deine Antwort. Ich selbst betriebe keinen FTP Server. Das Problem ist, dass ich nicht mit meinem Client auf einen fremden FTP Server laden kann. Respektive der Upload startet immer und es kann auch immer eine unterschiedliche Anzahl an Dateien hochgeladen werden. Nach einer gewissen Zeit kommt dann aber die Meldung:

    PHP Warning:  ftp_put(): Idle timeout (50 seconds): closing control connection in

    Ich nutze für den Upload ein PHP Skript mit der Funktion ftp_put, damit beliefere ich verschiedene FTP Server mit Daten. Das Problem ist, dass die einen den aktiven und die anderen nur den passiv Modus unterstützen. Alle Ports von meinem Client nach aussen sind offen, sprich dieser kommt auf jeden Fall raus.
    Merkwüridgerweise geht es immer unterschiedlich lang, bis der Upload abbricht.

    Kann mir jemand weiterhelfen?

    Herzlichen Dank und liebe Grüsse

    Lars


Log in to reply