Virtual pfSense, Windows software AP, LAN+WLAN bridge - driving me nuts



  • Hello.

    I have a little tricky setup:

    Win7 SP1 x64 machine + VMWare Workstation runing pfSense 2.1.5.
    The machine has 2 ethernet cards + Wifi adapter.

    The main goal is to turn this machine into home router. Internet comes to Ethernet 1.

    Wifi is supposed to be software access point (using hosted network feature of Win7). This adds one more interface.

    LAN computers will be connected to both Ethernet2 and SoftAP.

    So what I did so far was:
    Setup VMWare so pfSense VM sees all the 4 windows network adapters, so this looks like this for pfSense:

    le0 - Ethernet 1 (internet)
    le1 - Ethernet 2 (local)
    le3 - Wifi itself
    em0 - Virtual access point interface provided by Windows

    I created a 'bridge0' to combine Ethernet 2 and SoftAP.

    Fo interface config in pfSense is like this:

    WAN: static 192.168.37.1 (Ethernet1)
    LAN: static 192.168.41.0/24 (Bridge0)
    OPT1 none (Ethernet2)
    OPT2: none (Wifi itself)
    OPT3: none (SoftAP)

    DHCP server is configured for LAN (Bridge0) to give out IPs in range 192.168.43.100-250.

    So far everything is ok. pfSense VM sees internet, DHCP server works. I can connect clients to SoftAP and Ethernet2, they get IPs, they see pfSense, the can open configurator.
    Wired clients connected to Ethernet2 even see Internet.

    And here is a problem driving me nuts second day: Wifi clients do not see anything else but the local network.

    For example, when I connect a laptop to Ethernet2 port, in gets IP 192.168.43.104, it can ping 192.168.43.1 which in Bridge0, it can ping 192.168.37.5 which is Ethernet1, it can ping 192.168.37.1 which is internet gateway. Internet works, everything is fine.

    If I connect the same laptop to SoftAP by Wifi, it gets IP 192.168.43.106, can ping 192.168.43.1, can open pfSense configurator from 192.168.43.1. But it cannot ping anything else.

    I don't understand what the difference between Ethernet1 and SoftAP is. They are bridged, so starting from the bridge everything should be the same for packets coming from both of these nets. But SoftAP is getting somehow filtered. Do I miss something obvious?

    I tried to add firewall rules to allow everything everywhere, no luck. There are no blocked packets I could blame.

    Any suggestions on how I can fix this are appreciated! Thanks



  • did you find any solution for your problem?
    i have the same problem wifi client dont see internet …

    EDIT : this may help some other people

    Solved using Microsoft loopback adapter and then disabling tcp/ip v4 and v6 over the wan

    more details http://timita.org/wordpress/2011/07/29/protect-your-windows-laptop-with-pfsense-and-virtualbox-part-1-preamble/

    thx for him.


Log in to reply