Pagine Web in Tedesco



  • Ciao a tutti ho installato pfsense a maggio 2014 in NAT con Squid in Trasparent Proxy.

    Generalmente va molto bene ( circa 25 Utenti ) a parte il fatto che
    durante la navigazione degli utenti, alcuni siti vengono rigirati sulla pagina in tedesco.

    es:
    www.yahoo.con -> https://de.yahoo.com/?p=us
    www.msn.com ->  http://de.msn.com/?rd=1&ucc=DE&dcc=DE&opt=0

    alcuni siti meteo mi danno la situazione e previsione per una città della Germania
    Browser differenti in lingua Italiana, winxp win7 win8, il risultato non cambia.
    I siti in domain.it si aprono regolarmente ( es www.google.it è ok )

    Il Problema al momento non è grave ma non voglio aspettare  che lo diventi,
    ho controllato diversi parametri per il proxy Squid ma non ho trovato niente di significativo che mi riconducesse alla soluzione.

    Ho appena messo il flag "Disable X-Forward" info che avevo visto in forum, al momento non è cambiato nulla,
    proverò a riavviare più tardi qdo non ci sarà nessun utente collegato.

    Versione Pfsense 2.1.5 aggiornata
      Non uso DNS-Forwarder
      Ho disabilitato NTPserver
      Ho aggiunto  "DNS alternativo for the proxy server: 8.8.8.8" , ma nessun miglioramento

    Bypassando il PFsense fisicamente, collegando un portatile direttamente al router di Fastweb
    non ho più questo problema, le pagine si aprono correttamente in inglese al più mi compare la richiesta di girare la pagina nella lingua del Browser ( Italiano )
    Può centrare in qualche modo la Geo-location ?

    Chiedo Aiuto !
    Grazie

    Saluti
    Fabio G.