WebGui slow when WAN down



  • I've noticed this problem for a number of releases, when the WAN is unplugged the webGUI is extremely slow when connecting from the LAN side.  What causes this? Is there a fix?



  • I've seen a very slow WebGUI when there is a DNS problem.  In my case, I had the Services - DNS Forwarder - Interfaces set to something other than localhost.



  • I do have DNS forwarders on and the setting is set to All interfaces.  Will 'localhost' still respond to multiple interface's dns requests?



  • Yes, or at least it does for me.



  • I was having the same problem.  In my case, it seamed to manifest after importing CA and user certs for OpenVPN client, although I'm not sure if its related.  While tunnel and other networking functions all were fast, the GUI loading was very slow.  There seamed to be time out if the GUI was left for about 30 seconds without a page refresh.

    I experimented with DNS forwarder by enabling and disabling interfaces, but that seamed to have no affect.  Thanks for posting, it did point me in a direction..

    These systems where upgraded from 2.1.2 –> 2.1.3 --> 2.1.4 --> 2.1.5 and are running on APU hardware. (Netgate)

    I found the delay was actually coming from the browser, not the pfSense box.  By removing the exceptions for the self signed certificates in the browser, and re-accepting them, all is good now and pfSense GUI is back to running fast.  I'll keep an eye on it and post if anything comes up.



  • I found the delay was actually coming from the browser, not the pfSense box.  By removing the exceptions for the self signed certificates in the browser, and re-accepting them, all is good now and pfSense GUI is back to running fast.  I'll keep an eye on it and post if anything comes up.

    This is an issue from Firefox 31 (I guess you were using Firefox). There are other threads about this also. In Options, Security you have to View Certificates and delete all the ones listed under "Company Name" - those are the "unknown" ones that you have previously added as exceptions in the past. Then things speed up again.


Log in to reply