Netflix being filtered..



  • Ok so Im running pfsense 2.1.5, Squid 3.1.20, and Squidguard 1.4_4.  I have created a target category with the following domains: netflix.com nflximg.com roku.com nflximg.net 108.175.38.174
    And I checked Log to enable logging for this ACL.  Under both Common and Groups ACL I created entries whitelisting that category and enabled logging again.

    When I hot my Roku device, open a movie in Netflix it will play.. for about 50% then it 'loses connection'.  Trying to restart that movie results in connection lost issues.  I check the Squid and Squidgaurd logs and nothing it logged about either of those two ACL's so I'm a bit lost right now.

    Can anyone point me in the right direction?

    Thanks



  • I have no experience wirh Netflix, but Squid appears to have issues with streaming providers. You might try to nypass netflix in Squid, not in SquidGuard.



  • In SquidGuard \ Common ACL do you have 'Do not allow IP-Addresses in URL' enabled?



  • Nope.. do not allow ip addresses in URLs is NOT enabled.

    Klaws, can you give me a pointer on that?  I thought I did have Squid (not squid guard) whitelisting netflix.

    I added those same domains to the ACL under proxy server whitelist, and under the General tab for Bypass proxy for these destination IPs.



  • It's been a while.. I know.  I don;t watch Netflix so I had to wait for the kids to give it another try and the changes I made apparently resolved it. Woot.



  • @roccor

    The netflix player uses IP address to pull content, so your ACL's by domain name may not work once the player gets going.

    See my reply in a similar thread about Netflix streaming and how to find the CIDR range to bypass in squid:

    https://forum.pfsense.org/index.php?topic=94812.0


Log in to reply