Bittorrent



  • If I enable the firewall even on the lowest setting this still causes my bit torrent uploads to slow down.  The states don't increase beyond the max and the CPU usage is v low.  No traffice shapping is enabled.  This is with PF b2.  Any sugestions to fix this.



  • What do you mean by "enable on the lowest setting" ? Did you portforward the Port(s) your client needs for incoming connections?



  • on the firewall setting I have set it to conservative but the problem is still there.  I have disenabled the traffic shaping as will incase that is the problem but the problem starts again if I goto the advanced tab and enable the firewall again.



  • And the answer to my second question?



  • I opened the firewall with
    TCP/UDP  *  *  10.0.0.2  2568  *

    And put this in the port forward
    WAN  TCP/UDP  2568  10.0.0.2  2568
                                  (ext.: any)

    All my bit torrent stuff goes through port  2568



  • this setup will give you 1 download and 1 upload not more
    normal you have 10 poorts open voor bittorrend
    so that you can upload and download 10 files add a time
    6881 tiil 6889 is the normal bittorrend range

    try opening 2568 till 2578 on you firewall
    tiss will give you more up and download speed



  • I am using azereus so that only needs oneport for everything.

    At the moment the way I have this setup is through VMware and I donwloaded the live CD.  The internet is comming from a router that I have switch off the firewalling of but left the NAT on (other wise no connection) and put the pfsense ip in the DMZ.  I then opened up the pfsense firewall with a rule from any port to any port any ip any state allow but this still makes the downloads go slowly to lossing the connection.  The only way to stop this from happening is to switch off the firewall in pfsense.



  • @Jonb:

    I am using azereus so that only needs oneport for everything.

    Im using it to and i have no problem at all with pfSense to get it work.
    In Azereus i have this for it to work correctly:
    under: Tools / options / connection
    there is a box named: incomming tcp/udp listen port: 49152

    and under tools / options / plugin distributed db
    i have checked theses boxes:
    enabled distributed db
    use the default port

    my pfsense have this in nat:
    WAN  TCP/UDP  49152  192.168.0.210  49152  Torrent

    and this is in rules wan:
    TCP/UDP  *  *  192.168.0.210  49152  *  NAT Torrent

    and i have speed upto 10mbit in with out and problem (i dont have bigger line in)



  • all I can think of is the double NATing



  • Found the problem!!! It was were azureus was changing the upnp on the modem to go stright to the pc nic instead of through pfsense and then pfsense was loosing track of the ports and traffic as all out going traffice was going throug pfsense but incoming wasn't


Locked