WAN Wifi client setup clarification



  • Hi, I'm seeing lots of posts on the forum with people struggling to set up a wifi nic as the WAN interface by connecting it as a wifi client to an external wifi Access Point (e.g. a wifi router modem that is connected to the Internet).

    There appear to be no good answers in the documentation or in the forum on how to do this.

    The confusion appears to arise regarding the config section:
    Interfaces >> WAN >> Network-specific wireless configuration
    where many of the items appear to be related to setting up a wifi interface as an Access Point rather than a client. So perhaps none of it is related to setting up a wifi nic as a wifi client at all?

    The obvious first step is to assign the wifi nic as your WAN interface. It is after that when it all becomes unclear.

    The actual setup that I have in mind is:
    Internet > Wifi router modem > internal wifi nic as WAN interface > pfsense on a laptop > internal ethernet NIC as LAN interface

    Would be grateful for advice. If you have never setup a Wifi client WAN interface then please don't make assumptions about how to do it - I'm seeing this confuse things in other posts.

    Cheers,

    Mark



  • i don´t get it too
    too complicated :D



  • I did that setup once and worked perfectly.

    to "bridge" a wan connection over a wifi link, you need to use two devices using the same wireless chipset and you have to use the WDS system in order to transport correctly mac adress.

    my setup was the following

    DSL modem in bridge mode > DIR-825 LAN port, (wifi configured as WDS-AP) >wireless link>  DIR-825 LAN port (wifi configured as WDS-Station) > PfSense Wan Nic.

    set the dhcp off on both wireless devices and assing them a different ip adress. when you need to configure the wifi bridge, simply connect a cable to one of the two wireless box and manually configure the computer ip adress under the same subnet as the routers are.

    In order to be able to use wds APs and wds stations, routers must be flashed with a third party firmware such as DD-WRT. thoses features are not factory available but hardware capable.

    Wan wireless bridge is not really fast over 2.4 ghz band. you'r better use 5 ghz devices capable of giving a output of 300 Mbps (theorical) through MIMO.

    But for test purposes only, you can figure out a working setup with two old wrt-54g flashed with dd-wrt and following procedures to build a wds bridge with broadcomm based wireless ic's.

    Hope that helps.

    Zikmen



  • markp, I was looking for the same solution but documentation is very limited on the subject for setting up pfsense with a WIFI WAN interface as a client. But after testing I finally have it working. Some additional tests need to be made but I figured I'd at least post the initial setup that is working;

    My hardware;

    I'm using an old Acer Aspire One D250 for pfsense. This has an Atheros 9285 WIFI and AR8132 LAN.

    ath0: <atheros 9285="">mem 0x57100000-0x5710ffff irq 16 at device 0.0 on pci1
    ath0: [ITHREAD]
    ath0: AR9285 mac 192.2 RF5133 phy 14.0

    alc0: <atheros ar8132="" pcie="" fast="" ethernet="">port 0x2000-0x207f mem 0x55000000-0x5503ffff irq 18 at device 0.0 on pci3
    alc0: 15872 Tx FIFO, 15360 Rx FIFO
    alc0: Using 1 MSI message(s).

    I'm running pfsense 2.1.5-RELEASE.

    I made a lot of changes to the settings during testing but I believe the main setting that helped was setting the vm.kmem_size and vm.kmem_size_max in /boot/loader.conf. This netbook has 1G of ram. I found some forums suggesting to set these to half of the available RAM. My previous settings were

    vm.kmem_size="435544320"
    vm.kmem_size_max="535544320"

    I changed them to

    vm.kmem_size="536870912"
    vm.kmem_size_max="536870912"

    I rebooted after making that change. Once the system booted back up, the link was established. But that might not be the only setting I made that affected this. Like I said before, I still have some testing to do to verify which settings were necessary for getting this working.

    With all that said, here is my current setup;

    On my access point, I changed the channel from auto to 11. I did this because the ath0_wlan0 interface kept changing channels and I set the interface to use 11 as well. I intend on setting the AP and setting the WAN channel to auto to verify that I can still make a link. I also set my AP to WPA2-PSK(AES) and set the WAN to use specifically as well. I also changed the AP and WAN to use only 802.11g. Again, I intend on changing these settings to verify if this is necessary for my environment or not.

    In the Interfaces / WAN GUI page, these are the following settings that I changed from the default settings;

    General Configuration
    IPv6 Configuration Type: None

    Common wireless configuration - Settings apply to all wireless networks on ath0.
    Standard: 802.11g
    Channel: 11b/g - 11 (2462 MHz @ 30.0 / 30)
    Distance setting: 1
    Regulatory settings:
    Coutnry: United States – (US,FCC)
    Location: Indoor

    Network-specific wireless configuration
    Mode: Infrastructure (BSS)
    SSID: <my ssid="">802.11g only: checked
    WPA: Enabled WPA checked
    PSK: <my psk="">WPA Mode: WPA2
    WPA Pairwise: AES

    Hope this helps.</my></my></atheros></atheros>



  • I've reinstalled pfsense to ensure I had a base install with no modifications and did more testing.

    In order for my WIFI WAN link to make the association and get an IP address from the AP, I had to configure my AP to use a specific channel and use WPA2 only. The WAN interface on pfsense is set to use the same channel, 802.11g, and WPA2. I do not need to set the regulatory or distance settings.

    I don't know the reason for having to set the specific channel, WPA mode, and wireless mode but that's what I had to do to get the Atheros 9285 connected to the ATT uverse AP.


Log in to reply