radclient: no response from server for ID socket 3



  • Buenas, tengo un problema al tratar de hacer un radtest al server radius cuando pongo la siguiente linea

    radtest "user" "password" 172.16.5.1:1812 0 "secret"

    Ya habilite los puertos en el firewall pero no entiendo porque no puedo conectarme a mi server radius y sin tener este acceso, menos lo voy a tener al portal cautivo

    Alguna solución? Muchas gracias



  • El test al localhost funciona? 127.0.0.1
    El radius quiero pensar que esta en el pfsense, correcto?





  • No me funciona con 127.0.0.1 y le doy un radiusd -X y me sale failed binding to authentication address port 1812 address already in use como se muestran en las imágenes

    Muchas gracias por su colaboración






  • Si no hay respuesta el servicio no debe estar funcionando.

    Status: Services en el configurador web.

    ps aux | grep rad en consola

    Verificar logs…



  • mmm segun la traduccion dice que ya esta usandose ese puerto…

    Pero muy facil, ya que andas en la consola, mata todo lo relacionado a radius:

    ps -ax | grep radius

    Checa su PID y matalo:

    kill -KILL PID

    Cuantos saldran, desconozco eso tu lo vas a saber.

    Cuando termines repite el paso 1 y si ya no sale ninguno pruebas de nuevo, saludos.



  • Muchas gracias, pero sigue sin funcionar, noc que mas hacer me sigue apareciendo radclient: no response from server for ID socket 3, ya desinstale el radius y volví hacer todo pero nada.

    Muchas gracias por la ayuda



  • Google radclient: no response from server for ID socket 3

    https://www.packtpub.com/books/content/getting-started-freeradius

    Common errors

    If the server is down or the packets from radtest cannot reach the server because of a firewall between them, radtest will try three times and then give up with the following message:

    radclient: no response from server for ID 133 socket 3

    If you run radtest as a normal user it may complain about not having access to the FreeRADIUS dictionary file. This is required for normal operations. The way to solve this is either to change the permissions on the reported file or to run radtest as root.



  • @bellera:

    Si no hay respuesta el servicio no debe estar funcionando.

    Status: Services en el configurador web.

    ps aux | grep rad en consola

    Verificar logs…

    ¿Está el servicio funcionando? ¿Qué procesos hay en marcha, relacionados con radius? ¿Qué dicen los logs?



  • Muchisimas gracias por tu respuesta pero encontré el error aunque noc como solucionarlo, te explico al parecer es un problema del dominio porque lo volví a montar sin dominio ni nombre del host, solo el portal el dhcp el radius y ya, e hize pruebas de radtest y me funciono todo, pero cuando lo agrego a un dominio creado en pfsense se cuelga todo, hasta deja de darle ping a la propia maquina y aparece el error del radtest a la propia maquina mira






  • @Tux_AF:

    cuando lo agrego a un dominio creado en pfsense se cuelga todo, hasta deja de darle ping a la propia maquina y aparece el error del radtest a la propia maquina mira

    ¿ Qué quiere decir para tí "un dominio creado en pfsense" ?



  • Supongo,que se debe de crear un dominio local,  no se si estoy en lo correcto

    Me puedes corregir? soy nuevo en pfsense, saludos



  • @Tux_AF:

    Supongo,que se debe de crear un dominio local,  no se si estoy en lo correcto

    Es opcional. No todas las redes tienen un servicio DNS.

    ¿ Cómo creaste tu dominio local ?



  • No tengo un dominio local, porque como te dije empece de nuevo pero, ¿Es necesario tener un dominio para evitar copiar http://ip:8000 y poder ver el portal? quiero que mis usuarios cuando se conecten automáticamente en el navegador los redireccione al portal

    Muchas gracias, saludos



  • En el portal cautivo normalmente aparece la IP de pfSense. Algunos usuarios de este foro manifestaron hace tiempo que esto no les gustaba y les dí la solución:

    https://forum.pfsense.org/index.php?topic=62436.msg395421#msg395421

    Creo que nos estamos desviando del tema. La cuestión era si tu radius funciona, pienso…



  • Si exactamente, y gracias por la información

    Retomando el tema de radius, este solo funciona cuando no se le configura un dominio, hasta da ping a la propia maquina, hasta ahi bien, pero si lo agrego a un dominio este deja de funcionar y el ping se cae ¿Cual seria la causa de esto?

    Saludos



  • @bellera:

    @Tux_AF:

    cuando lo agrego a un dominio creado en pfsense se cuelga todo, hasta deja de darle ping a la propia maquina y aparece el error del radtest a la propia maquina mira

    ¿ Qué quiere decir para tí "un dominio creado en pfsense" ?

    Sigo sin comprender qué haces con el tema del dominio.