IPSec/L2TP with pfSense 2.2



  • I see in the developers' notes that L2TP over IPsec has been implemented for version 2.2, but I cannot figure out how to configure it. I have both Windows 7 and iOS clients and would like to use the OSs' native VPN support. Do I just enable both L2TP and IPsec in pfSense? If so, how do I get them to work together (choosing the same subnets for both, PSKs, etc.)? Thanks.


  • Rebel Alliance Developer Netgate

    Some of this has probably changed since the last time I tried it, but here is how I had it working before:

    • Create mobile IPsec P1 as usual, but use Mutual PSK, no xauth – MAIN mode, not aggressive, disable mobile options for IP assignment and network supply

    • Add P2 for transport mode, aes 128+sha1, etc.

    • On Pre-Shared Keys tab, add "allusers" PSK with the desired secret.

    • Setup L2TP, add L2TP users

    • Setup client, server IP = WAN IP, account = L2TP user, password =
      L2TP password, Secret = IPsec allusers PSK

    • Add a system tunable net.inet.ipsec.filtertunnel=1 (this may not be required any longer)

    • Put the rules on the WAN interface and the IPsec tab (ditto, may not be required now, might just be IPsec tab)



  • It's connecting, but I'm having no success passing traffic. As the connection is established I am getting the following log entry:

    charon: 09[KNL] can't install route for (device WAN IP)/32|/0[udp/([i]random port)] === (pfSense WAN IP)/32|/0[udp/l2f] in, conflicts with IKE traffic

    Not sure if that is related, or if it is a separate config issue. I have IPsec and L2TP rules to pass all traffic, and WAN rules to pass UDP 1701, 500, and 4500. Right now I am troubleshooting with iOS 8.1 but I am in the process of setting up a Windows 7 laptop to continue troubleshooting.



  • Normally your phase2 should be only for port of L2TP traffic.



  • @jimp:

    Some of this has probably changed since the last time I tried it, but here is how I had it working before:

    • Create mobile IPsec P1 as usual, but use Mutual PSK, no xauth – MAIN mode, not aggressive, disable mobile options for IP assignment and network supply

    • Add P2 for transport mode, aes 128+sha1, etc.

    • On Pre-Shared Keys tab, add "allusers" PSK with the desired secret.

    • Setup L2TP, add L2TP users

    • Setup client, server IP = WAN IP, account = L2TP user, password =
      L2TP password, Secret = IPsec allusers PSK

    • Add a system tunable net.inet.ipsec.filtertunnel=1 (this may not be required any longer)

    • Put the rules on the WAN interface and the IPsec tab (ditto, may not be required now, might just be IPsec tab)

    Jimp, On your first point, please define "as usual".
    Also, in phase1 setup, it asks for a PSK. what is supposed to go here, the same as the "allusers" PSK?

    I have done all of this. Unable to connect from my iPhone 5s, running iOS 8.1. Error message on the phone is: The L2TP-VPN server did not respond.



  • Excerpt from General System Log:

    Oct 28 12:27:08	ipsec_starter[76515]: configuration 'con1' unrouted
    Oct 28 12:27:08	ipsec_starter[76515]:
    Oct 28 12:27:08	ipsec_starter[76515]: notifying watcher failed: Bad file descriptor
    Oct 28 12:27:08	ipsec_starter[76515]: notifying watcher failed: Bad file descriptor
    Oct 28 12:27:08	ipsec_starter[76515]: notifying watcher failed: Bad file descriptor
    Oct 28 12:27:08	ipsec_starter[76515]: 'con1' routed
    Oct 28 12:27:08	ipsec_starter[76515]:
    Oct 28 12:27:08	ipsec_starter[76515]: notifying watcher failed: Bad file descriptor
    Oct 28 12:27:08	check_reload_status: Reloading filter
    
    

    Again, but from ipsec log:

    Oct 28 12:27:08	charon: 02[CFG] added configuration 'con1'
    Oct 28 12:27:08	charon: 02[CFG] received stroke: route 'con1'
    Oct 28 12:27:19	charon: 13[NET] received packet: from [i]remote ip[/i][22966] to [i]pfsense ip[/i][500] (500 bytes)
    Oct 28 12:27:19	charon: 13[ENC] parsed ID_PROT request 0 [ SA V V V V V V V V V V V V ]
    Oct 28 12:27:19	charon: 13[IKE] <21> no IKE config found for [i]pfsense ip[/i]...[i]remote ip[/i], sending NO_PROPOSAL_CHOSEN
    Oct 28 12:27:19	charon: 13[IKE] no IKE config found for [i]pfsense ip[/i]...[i]remote ip[/i], sending NO_PROPOSAL_CHOSEN
    Oct 28 12:27:19	charon: 13[ENC] generating INFORMATIONAL_V1 request 1726922153 [ N(NO_PROP) ]
    Oct 28 12:27:19	charon: 13[NET] sending packet: from [i]pfsense ip[/i][500] to [i]remote ip[/i][22966] (40 bytes)
    Oct 28 12:27:22	charon: 13[NET] received packet: from [i]remote ip[/i][22966] to [i]pfsense ip[/i][500] (500 bytes)
    Oct 28 12:27:22	charon: 13[ENC] parsed ID_PROT request 0 [ SA V V V V V V V V V V V V ]
    Oct 28 12:27:22	charon: 13[IKE] <22> no IKE config found for [i]pfsense ip[/i]...[i]remote ip[/i], sending NO_PROPOSAL_CHOSEN
    Oct 28 12:27:22	charon: 13[IKE] no IKE config found for [i]pfsense ip[/i]...[i]remote ip[/i], sending NO_PROPOSAL_CHOSEN
    Oct 28 12:27:22	charon: 13[ENC] generating INFORMATIONAL_V1 request 3340988032 [ N(NO_PROP) ]
    Oct 28 12:27:22	charon: 13[NET] sending packet: from [i]pfsense ip[/i][500] to [i]remote ip[/i][22966] (40 bytes)
    Oct 28 12:27:26	charon: 13[NET] received packet: from [i]remote ip[/i][22966] to [i]pfsense ip[/i][500] (500 bytes)
    Oct 28 12:27:26	charon: 13[ENC] parsed ID_PROT request 0 [ SA V V V V V V V V V V V V ]
    Oct 28 12:27:26	charon: 13[IKE] <23> no IKE config found for [i]pfsense ip[/i]...[i]remote ip[/i], sending NO_PROPOSAL_CHOSEN
    Oct 28 12:27:26	charon: 13[IKE] no IKE config found for [i]pfsense ip[/i]...[i]remote ip[/i], sending NO_PROPOSAL_CHOSEN
    Oct 28 12:27:26	charon: 13[ENC] generating INFORMATIONAL_V1 request 2734004407 [ N(NO_PROP) ]
    Oct 28 12:27:26	charon: 13[NET] sending packet: from [i]pfsense ip[/i][500] to [i]remote ip[/i][22966] (40 bytes)
    Oct 28 12:27:29	charon: 13[NET] received packet: from [i]remote ip[/i][22966] to [i]pfsense ip[/i][500] (500 bytes)
    Oct 28 12:27:29	charon: 13[ENC] parsed ID_PROT request 0 [ SA V V V V V V V V V V V V ]
    Oct 28 12:27:29	charon: 13[IKE] <24> no IKE config found for [i]pfsense ip[/i]...[i]remote ip[/i], sending NO_PROPOSAL_CHOSEN
    Oct 28 12:27:29	charon: 13[IKE] no IKE config found for [i]pfsense ip[/i]...[i]remote ip[/i], sending NO_PROPOSAL_CHOSEN
    Oct 28 12:27:29	charon: 13[ENC] generating INFORMATIONAL_V1 request 318914860 [ N(NO_PROP) ]
    Oct 28 12:27:29	charon: 13[NET] sending packet: from [i]pfsense ip[/i][500] to [i]remote ip[/i][22966] (40 bytes)
    Oct 28 12:34:15	charon: 13[NET] received packet: from [i]remote ip[/i][22966] to [i]pfsense ip[/i][500] (500 bytes)
    Oct 28 12:34:15	charon: 13[ENC] parsed ID_PROT request 0 [ SA V V V V V V V V V V V V ]
    Oct 28 12:34:15	charon: 13[IKE] <25> no IKE config found for [i]pfsense ip[/i]...[i]remote ip[/i], sending NO_PROPOSAL_CHOSEN
    Oct 28 12:34:15	charon: 13[IKE] no IKE config found for [i]pfsense ip[/i]...[i]remote ip[/i], sending NO_PROPOSAL_CHOSEN
    Oct 28 12:34:15	charon: 13[ENC] generating INFORMATIONAL_V1 request 2414807965 [ N(NO_PROP) ]
    Oct 28 12:34:15	charon: 13[NET] sending packet: from [i]pfsense ip[/i][500] to [i]remote ip[/i][22966] (40 bytes)
    Oct 28 12:34:18	charon: 13[NET] received packet: from [i]remote ip[/i][22966] to [i]pfsense ip[/i][500] (500 bytes)
    Oct 28 12:34:18	charon: 13[ENC] parsed ID_PROT request 0 [ SA V V V V V V V V V V V V ]
    Oct 28 12:34:18	charon: 13[IKE] <26> no IKE config found for [i]pfsense ip[/i]...[i]remote ip[/i], sending NO_PROPOSAL_CHOSEN
    Oct 28 12:34:18	charon: 13[IKE] no IKE config found for [i]pfsense ip[/i]...[i]remote ip[/i], sending NO_PROPOSAL_CHOSEN
    Oct 28 12:34:18	charon: 13[ENC] generating INFORMATIONAL_V1 request 639189084 [ N(NO_PROP) ]
    Oct 28 12:34:18	charon: 13[NET] sending packet: from [i]pfsense ip[/i][500] to [i]remote ip[/i][22966] (40 bytes)
    Oct 28 12:34:21	charon: 13[NET] received packet: from [i]remote ip[/i][22966] to [i]pfsense ip[/i][500] (500 bytes)
    Oct 28 12:34:21	charon: 13[ENC] parsed ID_PROT request 0 [ SA V V V V V V V V V V V V ]
    Oct 28 12:34:21	charon: 13[IKE] <27> no IKE config found for [i]pfsense ip[/i]...[i]remote ip[/i], sending NO_PROPOSAL_CHOSEN
    Oct 28 12:34:21	charon: 13[IKE] no IKE config found for [i]pfsense ip[/i]...[i]remote ip[/i], sending NO_PROPOSAL_CHOSEN
    Oct 28 12:34:21	charon: 13[ENC] generating INFORMATIONAL_V1 request 3137640312 [ N(NO_PROP) ]
    Oct 28 12:34:21	charon: 13[NET] sending packet: from [i]pfsense ip[/i][500] to [i]remote ip[/i][22966] (40 bytes)
    Oct 28 12:34:25	charon: 13[NET] received packet: from [i]remote ip[/i][22966] to [i]pfsense ip[/i][500] (500 bytes)
    Oct 28 12:34:25	charon: 13[ENC] parsed ID_PROT request 0 [ SA V V V V V V V V V V V V ]
    Oct 28 12:34:25	charon: 13[IKE] <28> no IKE config found for [i]pfsense ip[/i]...[i]remote ip[/i], sending NO_PROPOSAL_CHOSEN
    Oct 28 12:34:25	charon: 13[IKE] no IKE config found for [i]pfsense ip[/i]...[i]remote ip[/i], sending NO_PROPOSAL_CHOSEN
    Oct 28 12:34:25	charon: 13[ENC] generating INFORMATIONAL_V1 request 270404347 [ N(NO_PROP) ]
    Oct 28 12:34:25	charon: 13[NET] sending packet: from [i]pfsense ip[/i][500] to [i]remote ip[/i][22966] (40 bytes)
    
    


  • @tcw:

    It's connecting, but I'm having no success passing traffic. As the connection is established I am getting the following log entry:

    charon: 09[KNL] can't install route for (device WAN IP)/32|/0[udp/([i]random port)] === (pfSense WAN IP)/32|/0[udp/l2f] in, conflicts with IKE traffic

    Not sure if that is related, or if it is a separate config issue. I have IPsec and L2TP rules to pass all traffic, and WAN rules to pass UDP 1701, 500, and 4500. Right now I am troubleshooting with iOS 8.1 but I am in the process of setting up a Windows 7 laptop to continue troubleshooting.

    I was getting these messages in my log file, until I realized that after creating the initial section in VPN->IPSec, there appears as sub-section. Click the Plus (+) sign, next to "Show 0 Phase-2 entries", then, create a Phase-2 entry.


  • Rebel Alliance Developer Netgate

    @aaronouthier:

    Jimp, On your first point, please define "as usual".

    Usual is: https://doc.pfsense.org/index.php/Mobile_IPsec_on_2.0



  • I think I almost have it!

    Getting no proposal found in my pfsense logs for IPSec. Would this cause an issue?

    Specifics are:

    charon: 11[CFG] received proposals: IKE:AES_CBC_256/HMAC_SHA1_96/PRF_HMAC_SHA1/MODP_1024, IKE:AES_CBC_256/HMAC_MD5_96/PRF_HMAC_MD5/MODP_1024, IKE:AES_CBC_128/HMAC_SHA1_96/PRF_HMAC_SHA1/MODP_1024, IKE:AES_CBC_128/HMAC_MD5_96/PRF_HMAC_MD5/MODP_1024, IKE:3DES_CBC/HMAC_SHA1_96/PRF_HMAC_SHA1/MODP_1024, IKE:3DES_CBC/HMAC_MD5_96/PRF_HMAC_MD5/MODP_1024
    
    charon: 11[CFG] configured proposals: IKE:AES_GCM_16_128/HMAC_SHA1_96/PRF_HMAC_SHA1/MODP_1024
    
    charon: 11[IKE] <111> no proposal found
    
    charon: 11[IKE] no proposal found
    
    charon: 11[ENC] generating INFORMATIONAL_V1 request 1347464895 [ N(NO_PROP) ]
    

  • Rebel Alliance Developer Netgate

    If you look, your configured settings for encryption and hash do not line up with what the client is requesting. Change your settings to match any one of the received proposals and it may work.



  • Thanks to this thread, I've gotten IPsec/L2TP working to the point that clients connect and can talk to devices on the LAN.  The only thing I haven't figured out is that clients can't connect to the internet.  I have allow all rules set for IPsec and L2TP VPN.  I have OpenVPN setup and working just fine, but I just can't figure this last bit out for IPsec/L2TP.  Any help would be awesome and appreciated!


  • Rebel Alliance Developer Netgate

    Check your outbound NAT settings. If the L2TP subnet is not listed in the automatic NAT list, switch to hybrid mode and add a rule to do outbound NAT for the L2TP subnet.



  • That was it!  I had it set to manual, and forgot about making the rule for that subnet.  Thanks jimp!



  • @mrhanman - could you post some screen shots of your working config?  It would be MUCH appreciated.  Or even a description of the setup in detail?  I'm banging my head on the wall.  Thanks!



  • Ok. I got passed that, now I'm getting this repeatedly:

    charon: 08[IKE] <con1|1> received retransmit of request with ID 0, retransmitting response
    charon: 08[IKE] received retransmit of request with ID 0, retransmitting response</con1|1>
    

    Could some wise Guru point me in the direction I need to travel to obtain enlightenment on this subject.


  • Rebel Alliance Developer Netgate

    Make sure you're connecting from a remote test location and not inside the LAN.
    Also make sure your IPsec rules are set correctly to allow the L2TP traffic.



  • Is there an easy way to config an opt interface as an external (i.e. remote) connection so I can test without having to drive to Starbucks?  Since you can't test from inside the LAN this is a PITA to test.


  • Rebel Alliance Developer Netgate

    No. It must be tested from something outside completely separate from the firewall. If you have a second IP address on one of your WANs and another firewall/router you could connect from that so long as it's not on any other segment but WAN.

    Connecting from a cell phone over 3G/4G is typically the easiest way to test, most phones have an L2TP+IPsec client.



  • This works, however, it doesn't work using L2TP/IPsec + Dou Security 2Fa…

    Something about the authentication mechanism that Ldap sends to the radius proxy.
    You get error
    Missing or improperly-formatted password

    If you point it at a regular Radius server however, it works just fine.

    One thing I found that has to be very specific is the IPsec PSK.
    This Identifier has to be set specifically to "allusers" then the psk of your choosing. If you set the identifier to some random word it doesn't work.



  • Sp far I have no luck, but I got some clues:

    The page in pfsense where you add the Pre-Shared keys says that the alluser account is named any/ANY - that's wrong. It is "allusers".

    When creating the Phase 1 from the mobile users page it makes an agressive mode config - you can change that to main mode, but you can't change it back (you can select it, but it gets ignored) - never mind, as you want to use main mode…

    On android, DO NOT USE AN IPSEC IDENTIFIER. Why capital? Because if you do it uses aggressive mode, if you leave it empty it uses main mode

    On the shell you don't see any traffic on enc0. That's because the sysctl variables net.enc.in.ipsec_bpf_mask and net.enc.in.ipsec_bpf_mask might not be as desired... I could not figure, if they are wrong, but at least when changing them I see traffic on enc0 and getting pf to log the traffic on the right interface.

    My problem is, I see L2TP requests on the enc0 interface, but no answers. the l2tp logging is also empty in this regard. I belive somehow the traffic does not make it from the interface to the daemon....

    I also noted, that I have to unset the "Provide virtual ip address" - it is a transport mode ipsec... and it causes "no child SA" errors during the connection (and fails)

    Any hints are welcome....



  • I try the same with android as client… the ciphers and hashes are different, but appart from that it is the same, see here: https://forum.pfsense.org/index.php?topic=83321.15

    I belive I hit the exact same thing as this guy: http://lists.freebsd.org/pipermail/freebsd-questions/2013-December/254770.html

    Unfortunately he never got a reply on how to fix it...



  • I've been playing with this all day, and have it working with both Windows 7 and OS X (Yosemite) clients.

    My settings are as follows:

    IPSec is enabled  ;)

    PHASE 1 SETTINGS

    Phase 1 proposal (Authentication):
    Authentication method: Mutual PSK
    Negotiation mode: Main
    My Identifier: My IP address

    Phase 1 proposal (Algorithms):
    Encryption algorithm: 3DES
    Hash algroithm: SHA1
    Dh key group: 2 (1024 bit)
    Lifetime: 28800 seconds

    NOTE: there are other p1 algorithm combinations that will work, but this is the only combination that works for both win7 and OS X
    for example: AES256, SHA1, and DH 14 (2048 bit) also work for windows 7, but not os x

    Advanced options:
    Disable rekey is off
    Disable reauth is off
    NAT Traversal is Auto (this should only matter if your VPN SERVER itself is behind another nat)
    Dead Peer Detection is enabled (but both win 7 and OS X don't seem to support DPD0)

    PHASE 2 SETTINGS

    Phase 2 settings are all the defaults except MODE which should be transport so:

    MODE: Transport (this one f'd me up for a while, I kept setting it to tunnel)
    Protocol: ESP
    Encryption algrithms:AES (auto), blowfish (auto), 3DES, CAST128 all checked, (these are the defaults for p2)
    Hash algorithems: MD5, SHA1 both checked (again this is the default)
    PFS key group: off
    Lifetime: 3600 seconds

    On the mobile clients tab:

    Enable IPsec mobile client support is checked
    Everything else on this tab is unchecked
    User Authentication is set to "Local Database" (which isn't actually used because Xauth isn't on in P1)
    Group Authentication is set to none

    On the Pre-Shared Keys tabs:
    Add a single PSK with the identifier "allusers", set this to something strong

    Firewall NAT:

    • No special NAT rules added, outbound NAT is automatic

    Firewall rules:

    • No special WAN rules added
    • No IPSec rules added
    • L2TP VPN, add a rule for the VPN traffic you want to allow.  I have a "pass-everything" rule here.  Note that if you add a rule, by default you get a pass all TCP rule, not a pass everything rule.

    L2TP VPN setup: (These are my settings, tweak to meet your needs:)
    L2TP server is Enabled
    Interface: LAN
    Remote address range: a range that is a subset of the LAN subnet, that starts on a /29 boundary.  I picked 192.168.x.208
    Subnet mask: /29
    Number of l2tp users: 8
    Secret: (blank)
    Authentication type: CHAP
    Server address: is the next ip outside the remote address range, 192.168.x.216 in my case.

    The "secret" specified here is not the pre-shared key needed by the L2TP/IPSec clients.  I'm not even sure this is used at all I don't see this value being passed on to the mpd config file in any way.

    The subnet mask and number of users, seems redundant to me… L2TP is a PPP protocol so I'm not sure why there's a subnet mask at all.  In my case I've picked /29 which corresponds to exactly 8 hosts matching my number of users, and made sure to start my range on a /29 boundary.  The UI complains if put the server address in the remote address range / subnet mask.  But the mpd.conf file that's generated only cares about the number of L2TP users, it doesn't seem to matter what you put in the subnet.



  • I've spent the whole day digging into this as well and had reached essentially the same configuration options as you, however, I still can't connect.

    The IPsec piece seems to be working alright but nothing ever appears in the L2TP logs and the connection fails with "Error 809".



  • I get the same error code. I tried a number of different configurations and would get different error codes such as "789". There are some inconsistencies in terms of how L2TP / IPSEC should be configured. Some have set interface to LAN for L2TP while others say they set it to WAN.

    Hopefully there will be a recommended / working configuration shortly.

    Maybe some more context on LAN configuration e.g. IP subnet and such so we get a better idea how to configure L2TP? One of the configurations I tried did spawn child SA entry on IPSEC status page however I see out being zero. I already set the rule for L2TP VPN to allow any to any. I suspect it may have to do with IP / subnet we set for L2TP.



  • I have tried for several weeks off and on to get a stable working configuration for iOS devices to VPN back in using the built-in VPN client on iOS 8.1.2.  At one point I could connect and browse LAN resources but never have I been able to pass traffic out to the Internet.

    I would REALLY love it if someone could share a good, secure working config for iOS clients that passes all traffic, and allows access to local LAN resources as well as traffic out to the Internet.

    Cheers!



  • I decided to try connecting via OSX and the configuration themaninblack describes worked fine.  No luck with Windows 7, Windows 8.1 or Windows Phone 8.1, though.  I did some research that implies this might be caused by Windows having poor NAT-T tolerance for L2TP+IPsec connections.

    Hopefully the necessary IKEv2 components get integrated sooner rather than later as that would be a better solution for Windows clients than L2TP+IPsec anyway.



  • @themaninblack:

    I've been playing with this all day, and have it working with both Windows 7 and OS X (Yosemite) clients.

    My settings are as follows:

    IPSec is enabled  ;)

    PHASE 1 SETTINGS

    Phase 1 proposal (Authentication):
    Authentication method: Mutual PSK
    Negotiation mode: Main
    My Identifier: My IP address

    Does this mean that you had to enter your external client's IP as the Phase 1 Peer IP?  Or did you put your external WAN IP as this identifier?
    ~~I feel like this is a stupid question I just asked; but I am trying to figure out how PfSense can operate identically as to say a Cisco ASA or Windows server based VPN for Windows native clients.  Having to enter in the IP of the connecting client is not feasible when dealing with external users; as they could be anywhere.

    So with v2.2, how do I set it up so that I can have a client connect from anywhere using their native clients on their devices?~~

    I received my answer to this.  The identifier is the firewall's IP address.



  • It seems I have IPSec part working but something is still wrong with L2TP part :(
    The VPN client (iPad) gets the IP but cannot access resources on LAN.
    Can someone share the working L2TP server config together with L2TP firewall rules?
    I suspect something is wrong with LAN subnet, server address and VPN subnet combination.
    Thanks!

    EDIT
    Some details about my setup:
    local LAN 192.168.5.0/24
    L2TP server interface is WAN as shown in https://doc.pfsense.org/index.php/L2TP/IPsec_on_Android
    L2TP server ip 192.168.155.254
    L2TP client subnet 192.168.155.0/24

    in the log:

    Jan 13 13:14:33 	l2tps: [l2tp0] no interface to proxy arp on for 192.168.155.0
    Jan 13 13:14:33 	l2tps: [l2tp0] IFACE: Up event
    Jan 13 13:14:33 	l2tps: 192.168.155.254 -> 192.168.155.0
    Jan 13 13:14:33 	l2tps: [l2tp0] IPCP: LayerUp
    Jan 13 13:14:33 	l2tps: [l2tp0] IPCP: state change Ack-Rcvd --> Opened
    Jan 13 13:14:33 	l2tps: PRIDNS 192.168.5.1
    Jan 13 13:14:33 	l2tps: IPADDR 192.168.155.0
    Jan 13 13:14:33 	l2tps: [l2tp0] IPCP: SendConfigAck #3
    Jan 13 13:14:33 	l2tps: PRIDNS 192.168.5.1
    Jan 13 13:14:33 	l2tps: 192.168.155.0 is OK
    Jan 13 13:14:33 	l2tps: IPADDR 192.168.155.0
    
    


  • You probably have wrongly setup your l2tp seeing that .0 ip assigned.



  • Changed client subnet, similar result:

    Jan 14 03:10:06 	l2tps: [l2tp0] no interface to proxy arp on for 192.168.155.16
    Jan 14 03:10:06 	l2tps: [l2tp0] IFACE: Up event
    Jan 14 03:10:06 	l2tps: 192.168.155.254 -> 192.168.155.16
    Jan 14 03:10:06 	l2tps: [l2tp0] IPCP: LayerUp
    Jan 14 03:10:06 	l2tps: [l2tp0] IPCP: state change Ack-Rcvd --> Opened
    
    


  • Same (or similar) issue as Andrew…

    I followed themaninblack's config (except for IPSec phase 1 proposal, adjusted for my device)... The connection is being made without any problems. After connecting, I can ping, both LAN hosts and external hosts, DNS works as well (since it's from my pfSense box), but anything else seems to get lost, even webconfig access. I created an "allow all" firewall rule for L2TP, but the logs still show things being blocked... is there another rule I need to add somewhere?

    Could it be blocking all TCP? If I set the DNS client on my phone to force TCP, nothing is able to resolve anymore.

    EDIT: I noticed in themaninblack's post that he mentions...

    • L2TP VPN, add a rule for the VPN traffic you want to allow.  I have a "pass-everything" rule here.  Note that if you add a rule, by default you get a pass all TCP rule, not a pass everything rule.

    It seems like it's block all TCP, not pass all TCP. And it doesn't appear to be something I can remove as it doesn't show in the rules.




  • Probably you have to enable MSS clamping on your tunnel.



  • No change. TCP still being blocked, while UDP and ICMP go just fine.



  • virgiliomi,
    you're still more lucky than me :)
    I do not even see l2tp in the firewall log. Could you please share your working config not hiding the private addresses you use.
    Thanks!



  • Basically, I followed themaninblack's config from earlier in this thread. The only changes I made are…

    Phase 1 Algorithms:
    Encryption: AES 256
    Hash: SHA1
    DH key group: 2 (1024 bit)

    Phase 2 Proposal:
    Encryption: Only AES checked, 256 bit selected
    Hash: Only SHA1 checked

    The IP Addresses I used in L2TP settings are a subset of my LAN subnet, just as mentioned by themaninblack. My LAN is 192.168.1.1/24, my L2TP is 192.168.1.208/29 and my server address is 192.168.1.216. If I use addresses outside of my LAN subnet (i.e. 192.168.51.208/29 and 192.168.51.216) then I get ping responses, but no TCP or UDP traffic (so no DNS).


  • Rebel Alliance Developer Netgate

    Looks like the rules are somehow not matching as expected. Maybe inbound L2TP traffic is actually bypassing pf and not receiving a state?

    If you add a Floating rule (quick=checked, dir=out, interface=l2tp, source=any, destination=any, TCP Flags=Any Flags, State Type=Sloppy State) it works.



  • Yep, that rule definitely fixed it for me. Works much better now!


  • Rebel Alliance Developer Netgate

    For those having trouble getting it going, I started from scratch and got this to work, pfSense 2.2 vs Windows 8.1 client:

    https://doc.pfsense.org/index.php/L2TP/IPsec



  • OK, I've deleted my previous config and followed the guide. Result is the same:
    IPSec:

    Jan 21 01:57:26 	charon: 08[KNL] 192.168.32.1 appeared on l2tp0
    Jan 21 01:57:26 	charon: 08[KNL] interface l2tp0 activated
    
    

    L2TP:

    Jan 21 01:57:26 	l2tps: [l2tp0] rec'd unexpected protocol IP
    Jan 21 01:57:26 	l2tps: [l2tp0] no interface to proxy arp on for 192.168.32.128
    Jan 21 01:57:26 	l2tps: [l2tp0] IFACE: Up event
    Jan 21 01:57:26 	l2tps: 192.168.32.1 -> 192.168.32.128
    Jan 21 01:57:26 	l2tps: [l2tp0] IPCP: LayerUp
    Jan 21 01:57:26 	l2tps: [l2tp0] IPCP: state change Ack-Rcvd --> Opened
    Jan 21 01:57:26 	l2tps: PRIDNS 192.168.5.1
    Jan 21 01:57:26 	l2tps: IPADDR 192.168.32.128
    Jan 21 01:57:26 	l2tps: [l2tp0] IPCP: SendConfigAck #3
    Jan 21 01:57:26 	l2tps: PRIDNS 192.168.5.1
    Jan 21 01:57:26 	l2tps: 192.168.32.128 is OK
    Jan 21 01:57:26 	l2tps: IPADDR 192.168.32.128
    
    

    Nothing in firewall log, cannot access LAN. Tested from iPad. pfsense on nanobsd.



  • I managed to get a connection and I'm able to browse LAN and internet from my iPhone (iOS 8.1.2) by following that guide, but I had to make the following modifications:

    IPsec Phase 1:

    • DH key group: 2 (1024)

    ~~Firewall - Rules, WAN tab

    • see attached pic~~
      (works without these rules)

    Services - DNS Resolver - Access Lists

    • allow 192.168.32.128/25

    ![Screenshot 2015-01-21 12.32.19.png](/public/imported_attachments/1/Screenshot 2015-01-21 12.32.19.png)
    ![Screenshot 2015-01-21 12.32.19.png_thumb](/public/imported_attachments/1/Screenshot 2015-01-21 12.32.19.png_thumb)


Log in to reply