2.2BETA: Atheros ar9227 extremely unstable wifi, plus N mode does not work.



  • I recently bought an atheros PCI (not PCI express) wireless NIC (the TP-Link TL-WN751ND) and after overcoming some problems initially with setup, fixed the setup of the card.

    Now the card works, but the wifi is extremely unstable. The most recent messages are:

    Oct 27 21:08:35 kernel: ath0_wlan0: ieee80211_new_state_locked: pending RUN -> SCAN transition lost
    Oct 27 21:08:35 kernel: ath0: ath_reset_grablock: didn't finish after 10 iterations
    Oct 27 21:08:35 kernel: ath0: ath_reset_grablock: warning, recursive reset path!
    Oct 27 21:08:35 kernel: ath0: ath_chan_set: concurrent reset! Danger!

    This results in sparse dropped connections. In addition, I cannot set the cards to n-mode or else I get a kernel panic (will post details if asked, unfortunately I don't have them right now). Any ideas? If you'd like me to help with fixing this problem code-wise, I have C experience and would love to help fix this annoying issue. Thanks!



  • What settings do you have configured on its interfaces page?

    I'm testing various things on an APU with this wireless kit.

    ath0: <atheros 9280="">ath0: AR9280 mac 128.2 RF5133 phy 13.0</atheros> 
    

    Seems it gets stuck at "no carrier" with any mode including 11n set on interfaces.php. Set it to 11g and it works fine, and actually shows up as 11b/g/n.

    I need to do some more testing to narrow down what's happening.

    Your experiences and what you have configured (and other options tried) in the GUI would be appreciated. You can check "ifconfig ath0" and "ifconfig ath0_wlan0" to see what's actually configured in the underlying OS.



  • I've now tried three pci-e cards under 2.2 with poor luck all the way around… Intel does not work in hostap mode and atheros seems to only work in 'g' mode. Even if the interface comes up and says b/g/n, it only functions at 'g' speed.

    The cards I've tried:
    Atheros 9287 - Only works in 'g' mode as you described. Must manually pick a channel.
    Atheros 9285 - Same as above
    Intel 5110 - Does not work in hostap mode.



  • That Intel card doesn't support hostap mode in the hardware, that's nothing to do with software.

    The Atheros n cards, yeah something going on there with n.



  • @cmb:

    That Intel card doesn't support hostap mode in the hardware, that's nothing to do with software.

    The Atheros n cards, yeah something going on there with n.

    Any idea what the ath_chan_set warnings are? I'm having some issues there as well. Here's my "ifconfig ath0_wlan0" output:

    ath0_wlan0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    ether e8🇩🇪27:7b:7a:f4
    inet6 fe80::eade:27ff:fe7b:7af4%ath0_wlan0 prefixlen 64 scopeid 0x8
    inet 192.168.2.1 netmask 0xffffff00 broadcast 192.168.2.255
    nd6 options=21 <performnud,auto_linklocal>media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: running
    ssid ****** channel 7 (2442 MHz 11g) bssid e8🇩🇪27:7b:7a:f4
    regdomain FCC country US ecm authmode WPA2/802.11i privacy MIXED
    deftxkey 2 AES-CCM 2:128-bit AES-CCM 3:128-bit txpower 30 scanvalid 60
    pureg protmode OFF burst -apbridge dtimperiod 1 -dfs

    Also, a kernel panic caused by changing to N mode (also caused by changing channels):
    <118>Bootup complete
    ath0_wlan0: ieee80211_new_state_locked: pending RUN -> SCAN transition lost
    ath0: ath_reset_grablock: didn't finish after 10 iterations
    ath0: ath_reset_grablock: warning, recursive reset path!
    ath0: ath_chan_set: concurrent reset! Danger!
    ath0_wlan0: ieee80211_new_state_locked: pending RUN -> SCAN transition lost
    ath0_wlan0: ieee80211_new_state_locked: pending RUN -> SCAN transition lost
    ath0: ath_reset_grablock: didn't finish after 10 iterations
    ath0: ath_reset_grablock: warning, recursive reset path!
    ath0: ath_chan_set: concurrent reset! Danger!
    ath0_wlan0: ieee80211_new_state_locked: pending RUN -> SCAN transition lost
    ath0_wlan0: ieee80211_new_state_locked: pending RUN -> SCAN transition lost
    ath0: ath_reset_grablock: didn't finish after 10 iterations
    ath0: ath_reset_grablock: warning, recursive reset path!
    ath0: ath_chan_set: concurrent reset! Danger!
    ath0_wlan0: ieee80211_new_state_locked: pending RUN -> SCAN transition lost
    ath0_wlan0: ieee80211_new_state_locked: pending RUN -> SCAN transition lost
    ath0: ath_reset_grablock: didn't finish after 10 iterations
    ath0: ath_reset_grablock: warning, recursive reset path!
    ath0: ath_chan_set: concurrent reset! Danger!
    ath0: ath_reset_grablock: didn't finish after 10 iterations
    ath0: ath_reset_grablock: warning, recursive reset path!
    ath0: ath_chan_set: concurrent reset! Danger!
    ath0: ath_reset_grablock: didn't finish after 10 iterations
    ath0: ath_reset_grablock: warning, recursive reset path!
    ath0: ath_reset: concurrent reset! Danger!
    ath0: ath_reset_grablock: didn't finish after 10 iterations
    ath0: ath_reset_grablock: warning, recursive reset path!
    ath0: ath_chan_set: concurrent reset! Danger!

    Fatal trap 12: page fault while in kernel mode
    cpuid = 3; apic id = 03
    fault virtual address = 0x378
    fault code = supervisor read data, page not present
    instruction pointer = 0x20:0xffffffff80a68541
    stack pointer         = 0x28:0xfffffe022ec318a0
    frame pointer         = 0x28:0xfffffe022ec31920
    code segment = base 0x0, limit 0xfffff, type 0x1b
    = DPL 0, pres 1, long 1, def32 0, gran 1
    processor eflags = interrupt enabled, resume, IOPL = 0
    current process = 0 (ath0 net80211 taskq)
    version.txt06000023412423767414  7624 ustarrootwheelFreeBSD 10.1-RC3 #41 e0dae58(releng/10.1)-dirty: Mon Oct 27 15:38:29 CDT 2014
        root@pf22-amd64-snap:/usr/obj.amd64/usr/pfSensesrc/src/sys/pfSense_SMP.10</hostap></performnud,auto_linklocal></up,broadcast,running,simplex,multicast>



  • Try setting the regulatory settings. Mine was defaulting to DEBUG and when I connected it was showing g speeds. I set it to FCC, USA. indoor and the connection now shows 135.
    Technical details for those not following the other thread:
    APU with 9285/AR5B95 running 2.2B
    Interface is configured as an AP, WPA2, AES, standard set to ng, nonly.
    Note this is a test box, not connected to the Internet. I am basing connection speeds on what a Windows laptop tells me when I connect to the AP. No throughput tests were done.



  • @dotdash:

    Try setting the regulatory settings. Mine was defaulting to DEBUG and when I connected it was showing g speeds. I set it to FCC, USA. indoor and the connection now shows 135.
    Technical details for those not following the other thread:
    APU with 9285/AR5B95 running 2.2B
    Interface is configured as an AP, WPA2, AES, standard set to ng, nonly.
    Note this is a test box, not connected to the Internet. I am basing connection speeds on what a Windows laptop tells me when I connect to the AP. No throughput tests were done.

    My regulatory settings are on FCC without a difference. I tried your other settings and it still isn't working. Would you mind posting your configuration? Thanks!
    If there's any more information you'd like me to provide, just mention it.



  • @dotdash:

    Try setting the regulatory settings. Mine was defaulting to DEBUG and when I connected it was showing g speeds. I set it to FCC, USA. indoor and the connection now shows 135.

    Sure enough. Exact same thing here after further testing. Now set the same as yours, and I was associated at 135. Though now it's having issues in general, and I'm short on time for now. Will have to revisit later.

    Experiences of others would be appreciated.



  • @darkphantom934:

    The most recent messages are:

    Oct 27 21:08:35 kernel: ath0_wlan0: ieee80211_new_state_locked: pending RUN -> SCAN transition lost
    Oct 27 21:08:35 kernel: ath0: ath_reset_grablock: didn't finish after 10 iterations
    Oct 27 21:08:35 kernel: ath0: ath_reset_grablock: warning, recursive reset path!
    Oct 27 21:08:35 kernel: ath0: ath_chan_set: concurrent reset! Danger!

    I haven't seen that in particular, though Googling it finds people with the same on FreeBSD. I only briefly reviewed the results, didn't see an answer anywhere, but it's worth searching on to see what you can find.

    My best guess, from experiences in earlier releases (though current wifi is vastly diff) is maybe try setting the channel differently. Don't put it on auto, try setting something specific. If it's already set to something specific, try a diff channel.



  • Here is my card:
    ath0: <atheros 9285="">at device 0.0 on pci4
    [ath] AR9285 Main LNA config: LNA2
    [ath] AR9285 Alt LNA config: LNA1
    [ath] LNA diversity enabled, Diversity enabled
    [ath] Enabling diversity for Kite
    ath0: [HT] enabling HT modes
    ath0: [HT] 1 stream STBC receive enabled
    ath0: [HT] 1 RX streams; 1 TX streams
    ath0: AR9285 mac 192.2 RF5133 phy 14.0
    ath0: 2GHz radio: 0x0000; 5GHz radio: 0x00c0</atheros>

    ifconfig ath0_wlan0 list caps
    drivercaps=4f85ed01 <sta,ibss,hostap,ahdemo,txpmgt,shslot,shpreamble,monitor,mbss,wpa1,wpa2,burst,wme,wds,txfrag>cryptocaps=1f <wep,tkip,aes,aes_ccm,tkipmic>htcaps=7014e<chwidth40,shortgi40></chwidth40,shortgi40></wep,tkip,aes,aes_ccm,tkipmic></sta,ibss,hostap,ahdemo,txpmgt,shslot,shpreamble,monitor,mbss,wpa1,wpa2,burst,wme,wds,txfrag>

    ifconfig ath0_wlan0
    ath0_wlan0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            ether 0c:60:76:66:66:66
            inet6 fe80::e60:7666:6666:2485%ath0_wlan0 prefixlen 64 scopeid 0x9
            inet 172.22.144.1 netmask 0xffffff00 broadcast 172.22.144.255
            nd6 options=21 <performnud,auto_linklocal>media: IEEE 802.11 Wireless Ethernet autoselect mode 11ng <hostap>status: running
            ssid Tigerbomb channel 1 (2412 MHz 11g ht/40+) bssid 0c:60:76:66:66:66
            regdomain FCC country US indoor ecm authmode WPA2/802.11i
            privacy MIXED deftxkey 3 AES-CCM 2:128-bit AES-CCM 3:128-bit
            txpower 30 scanvalid 60 protmode OFF ampdulimit 64k ampdudensity 8
            shortgi puren burst -apbridge dtimperiod 1 -dfs</hostap></performnud,auto_linklocal></up,broadcast,running,simplex,multicast>

    When booting I get this error. Also seems to happen every time I change settings on the interface:
    Configuring OPT2 interface…ath0: ath_reset_grablock: didn't finish after 10 iterations
    ath0: ath_reset_grablock: warning, recursive reset path!
    ath0: ath_reset: concurrent reset! Danger!
    done.



  • Does anyone here think that it might have something to do with the 5GHz band of these cards? This issue is becoming really annoying as it's preventing me from using n wifi…



  • They have no 5Ghz band. 9287/9227 is 2.4 only. The message where it returns values for 2GHz and 5GHz radios is confusing.
    ath0: 2GHz radio: 0x0000; 5GHz radio: 0x00c0



  • @cmb:

    Experiences of others would be appreciated.

    I'm not using AR9227 but a card with AR9380 and I cant get N to work either. Tried to set Regdomain to FCC, USA and indoors but still only 54M.
    Currently running the latest snap as well( built on Thu Oct 30 08:02:16 CDT 2014 ).

    ifconfig ath0_wlan2

    
    ath0_wlan2: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            ether e8:de:27:0c:54:96
            inet6 fe80::ecde:27ff:fe0c:5497%ath0_wlan2 prefixlen 64 scopeid 0x9
            inet 192.168.0.1 netmask 0xffffff00 broadcast 192.168.0.255
            nd6 options=21 <performnud,auto_linklocal>media: IEEE 802.11 Wireless Ethernet autoselect mode 11ng <hostap>status: running
            ssid Gratis_Internet channel 6 (2437 MHz 11g ht/40+) bssid ee:de:27:0c:54:97
            regdomain FCC country US indoor ecm authmode WPA2/802.11i
            privacy MIXED deftxkey 2 AES-CCM 2:128-bit txpower 30 scanvalid 60
            protmode OFF ampdulimit 64k ampdudensity 8 shortgi burst -apbridge
            dtimperiod 1 -dfs</hostap></performnud,auto_linklocal></up,broadcast,running,simplex,multicast> 
    

    dmesg | grep ath

    ath0: ath_edma_recv_tasklet: sc_inreset_cnt > 0; skipping
    ath0: ath_reset_grablock: didn't finish after 10 iterations
    ath0: ath_reset_grablock: warning, recursive reset path!
    ath0: ath_reset: concurrent reset! Danger!
    ath0: ath_reset_grablock: didn't finish after 10 iterations
    ath0: ath_reset_grablock: warning, recursive reset path!
    ath0: ath_chan_set: concurrent reset! Danger!
    ath0: stuck beacon; resetting (bmiss count 0)
    ath0: <atheros ar938x="">mem 0xfeae0000-0xfeafffff irq 16 at device 0.0 on pci3
    ath0: RX status length: 48
    ath0: RX buffer size: 4096
    ath0: TX descriptor length: 128
    ath0: TX status length: 36
    ath0: TX buffers per descriptor: 4
    ath0: ath_edma_setup_rxfifo: type=0, FIFO depth = 16 entries
    ath0: ath_edma_setup_rxfifo: type=1, FIFO depth = 128 entries
    ath0: [HT] enabling HT modes
    ath0: [HT] enabling short-GI in 20MHz mode
    ath0: [HT] 1 stream STBC receive enabled
    ath0: [HT] 1 stream STBC transmit enabled
    ath0: [HT] 3 RX streams; 3 TX streams
    ath0: AR9380 mac 448.3 RF5110 phy 0.0
    ath0: 2GHz radio: 0x0000; 5GHz radio: 0x0000</atheros> 
    


  • Same here… can't seem to get "N" speed on any settings...



  • @Pertan:

    I'm not using AR9227 but a card with AR9380 and I cant get N to work either. Tried to set Regdomain to FCC, USA and indoors but still only 54M.

    How do you have the channel configured? Seems for at least one person I talked to, it did that until they changed the channel from auto to something specific.



  • @cmb:

    @Pertan:

    I'm not using AR9227 but a card with AR9380 and I cant get N to work either. Tried to set Regdomain to FCC, USA and indoors but still only 54M.

    How do you have the channel configured? Seems for at least one person I talked to, it did that until they changed the channel from auto to something specific.

    Manually setting the channel gets "G" working… but haven't found anything that solves the problem of getting to "N" speed...

    Internal chuckle... reminds me of a quote from spaceballs, surely this must be the issue... "we are approaching ludicrous speed".



  • @cmb:

    How do you have the channel configured? Seems for at least one person I talked to, it did that until they changed the channel from auto to something specific.

    I have tried both NG and NA with channels 6 and 60. Auto does not work at all, interface is down if I choose auto.

    I get the same as "rjcrowder", setting channels manually gets G speeds working, but no N speeds.

    On a side note: Spaceballs is awesome!



  • Is there any chances to get working Ralink rt3072 on 2.2? I have USB edup ep-ms1532 with this chipset, but I have no luck with pfsense. It's shown and can be configured as interface once untill I apply settings… pfsense beginning to reboot itself with kernel panic.
    Other question is... DO you have any plans to get a new interface for wifi settings, where we can see N mode also and other settings related to new wifi standarts?  ???



  • @Pertan:

    On a side note: Spaceballs is awesome!

    Time for a ME TOO post…

    I have a AR 9280 mini PCIe card in an APU.  Its detected at boot and shows up in the web GUI once I create the interface.

    [2.2-BETA][root@pfSense.criggie.org.nz]/root: dmesg | grep -i ath
    ath0: <atheros 9280="">at device 0.0 on pci4
    [ath] enabling AN_TOP2_FIXUP
    ath0: [HT] enabling HT modes
    ath0: [HT] 1 stream STBC receive enabled
    ath0: [HT] 1 stream STBC transmit enabled
    ath0: [HT] 2 RX streams; 2 TX streams
    ath0: AR9280 mac 128.2 RF5133 phy 13.0
    ath0: 2GHz radio: 0x0000; 5GHz radio: 0x00c0
    wlan0: changing name to 'ath0_wlan0'
    wlan0: changing name to 'ath0_wlan0'
    ath0_wlan0: promiscuous mode enabled
    ath0_wlan0: promiscuous mode disabled
    ath0_wlan0: promiscuous mode enabled
    ath0_wlan0: promiscuous mode disabled
    ath0: stuck beacon; resetting (bmiss count 4)
    ath0: stuck beacon; resetting (bmiss count 4)

    I set up an SSID and it doesn't appear visible to any client.  Even when I tell the client the name of the SSID, as though it was a hidden broadcast then its still not found.

    In GUI -> Interfaces -> "Wireless" -> "Common wireless configuration - Settings apply to all wireless networks on ath0."  I set the Standard  to 802.11g and it works fine.

    I can set the Standard to 802.11a and it also works, but I only have one A mode radio device.

    ath0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 2290
            ether 04:f0:21:10:c6:b7
            nd6 options=21 <performnud,auto_linklocal>media: IEEE 802.11 Wireless Ethernet autoselect mode 11ng <hostap>status: running

    ath0_wlan0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            ether 04:f0:21:10:c6:b7
            inet6 fe80::1:1%ath0_wlan0 prefixlen 64 scopeid 0xa
            inet 10.28.97.1 netmask 0xffffff00 broadcast 10.28.97.255
            nd6 options=21 <performnud,auto_linklocal>media: IEEE 802.11 Wireless Ethernet autoselect mode 11ng <hostap>status: running
            ssid APU channel 6 (2437 MHz 11g ht/40+) bssid 04:f0:21:10:c6:b7
            regdomain APAC country NZ ecm authmode WPA1+WPA2/802.11i
            privacy MIXED deftxkey 2 TKIP 2:128-bit TKIP 3:128-bit txpower 30
            scanvalid 60 protmode OFF ampdulimit 64k ampdudensity 8 shortgi burst
            dtimperiod 1 -dfs

    Also, I found multiple SSIDs… that's done in the Interfaces --> Assign area, once the wireless card is enabled as an interface.

    This is a total test box,  running 2.2-BETA (amd64) built on Mon Oct 27 15:31:41 CDT 2014
    FreeBSD 10.1-RC3</hostap></performnud,auto_linklocal></up,broadcast,running,simplex,multicast></hostap></performnud,auto_linklocal></up,broadcast,running,simplex,multicast></atheros>



  • @Criggie:

    I set up an SSID and it doesn't appear visible to any client.  Even when I tell the client the name of the SSID, as though it was a hidden broadcast then its still not found.

    Can you double check if the interface comes up when you set it to "N" mode (on the interface status page - or just look at interfaces on the dashboard). For both Atheros devices I've tried, the interface will not start if I put it in "N" mode - hence no SSID showing…



  • I was testing quite extensively the Atheros 9280 using the same HW as CMB.

    Whatever the settings, I have many "ath0: stuck beacon; resetting (bmiss count 8)". I have updated the hw tunable settings with no luck.
    It is more stable using G but quality is all in all very bad and unstable.

    When you start using bridge mode, It become close from unusable, whatever the settings.

    I have ping with time ranging from 10ms up to 1600ms… when It can ping.

    –- 8.8.8.8 ping statistics ---
    100 packets transmitted, 98 packets received, 2.0% packet loss
    round-trip min/avg/max/stddev = 9.051/100.789/411.100/80.820 ms



  • I have been playing a bit with the beta.
    My impression is, that it's a lot less stable than the alpha builds i tested.
    However i havent had the time to dig in to debug.
    Regarding getting n to work:
    What probably most people are missing, is that n requires QoS.
    Ticking the WME checkbox will maybe help.



  • Nothing's really changed in the wifi-related OS portions in months in 2.2 (maybe through tracking 10-STABLE). Seems there are several combinations of things that can be unstable. Not really a priority for us at the moment, but post-release, it is something we're going to investigate further and report upstream in hopes of getting fixes. If others can gather data on what works and what doesn't, that'd be helpful.



  • Has something changed? Cause I get Associated @ 135M now while using a iPhone 6 (got 25Mb/s download and 94 Mb/s upload).
    I am also using latest 2.2 RC with a TP-LINK TL-WDN4800 (AR9380 chip).

    ath0_wlan2: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
            ether **:de:**:0c:**:97
            inet6 fe80::eade:27ff:fe0c:4797%ath0_wlan2 prefixlen 64 scopeid 0x8
            nd6 options=21 <performnud,auto_linklocal>media: IEEE 802.11 Wireless Ethernet autoselect mode 11na <hostap>
            status: running
            ssid Eriksson5Ghz channel 56 (5280 MHz 11a ht/40-) bssid **:de:**:0c:**:97
            regdomain NONE country BO indoor ecm authmode WPA2/802.11i
            privacy MIXED deftxkey 3 AES-CCM 2:128-bit AES-CCM 3:128-bit
            txpower 24 mcastrate 6 mgmtrate 6 scanvalid 60 ampdulimit 64k
            ampdudensity 8 shortgi burst -apbridge dtimperiod 1 -dfs</hostap></performnud,auto_linklocal></up,broadcast,running,promisc,simplex,multicast>
    


    [Clickable]


    [Clickable]



  • Im having the same issue as yesterdays snapshot.  I have an Atheros AR9280, when in N or A mode on the 5GHz side im able to push about 1GB of data through the card…then the connection drops.



  • I got my WiFi issue fixed.  I did some reading about key rotation and several message boards indicate that the key rotation should be set to 0 (which pfSense doesnt support) for straming A/V. When the keys rotate the connection will temporarily drop when in the process of rotating which is unacceptable for streaming A/V.  If it is set to something above 0 then it needs to bet set to at interval of at least 5 minutes because when the keys rotate devices are able to negotiate the new keys once per minute up to 4 attempts, which means no less than 5 minutes.  Changing the default value of key rotation from 60 to 300 solved the issue. Unless my research is wrong then Id suggest the default value in pfSense be changed from 60 to 300.


Log in to reply