Problema con HTTPS y CERTIFICADOS



  • Buenas, después de haber renunciado a intentar filtrar HTTPS mediante proxy no transparente, intenté mediante squid3-dev + squidguard3
    siguiendo este tutorial al pie de la letra http://www.youtube.com/watch?v=neXcYtFDRLA me topé con el siguiente problema.

    Me bloquea todo lo HTTPS todo.

    Resumen:
    Cree el certificado e instalé en el cliente.
    Filtra HTTP
    Si pongo la IP del cliente en los Bypassing del proxy, navego HTTP y HTTPS sin problemas, cone sto quiero decir que el equipo está usando PFSENSE

    ALGUNA IDEA?



  • La opción bypassing es para el modo transparente y dices:

    después de haber renunciado a intentar filtrar HTTPS mediante proxy no transparente

    Entiendo que estás en modo TRANSPARENTE.

    Tenemos un tutorial en castellano donde dice qué hacer, en Documentación, https://forum.pfsense.org/index.php?topic=23409.0

    Donde pone… squid3-dev (paquete para filtrado https en modo transparente).



  • Estimado Bellera, hice todo siguiendo ese tutorial paso a paso, pero los resultados son los de la captura de pantalla.

    Lo único que me llama la atención es que en el tutorial dice "pfSense 2.1 (not upgraded to 2.1.1)" y yo estoy usando 2.1.5-RELEASE (i386) puede ser este el problema?

    otra duda:

    01. IPv6 activado. squid3 está compilado en este paquete con IPv6 activado y lo precisa, aunque no lo emplee.

    02. Las librerías que faltan, https://forum.pfsense.org/index.php?topic=66633.msg371602#msg371602

    03. Instalación de squid3-devel

    Es necesario squid3 + squid3-devel ?

    Gracias por el tiempo.



  • Si instalas dos paquetes squid (squid3 y squi3-devel) problemas…

    Por favor, una vez más, seguir el tutorial. Probado con 2.1.4, en 32 y 64 bit.

    El problema no son las versiones de pfSense. Son las versiones del paquete, que es el encargado de generar squid.conf y este, a veces, no queda correcto.

    Es un paquete versión "devel" (en desarrollo) y puedes tener un bug.

    Postea tu squid.conf para decirte si es correcto o no.

    En consola o Diagnostics: Command Prompt salida de:

    cat /usr/pbi/squid-i386/etc/squid/squid.conf
    

    o de

    cat /usr/pbi/squid-amd64/etc/squid/squid.conf
    


  • Hola

    Bellera.. el problema radica que al usar squid-dev con filtrado HTTPS, al usar google chrome genera un problema con el certificado que brinda el fw, en mozilla y internet explorer se puede forzar a que use el certificado pero google chrome no deja de arrojar ese error, y no encuentro como validar y forzar a que use el certificado del squid, has probado algo al respecto



  • Tienes que usar el certificado raíz en formato DER, no PEM:

    https://forum.pfsense.org/index.php?topic=74007.msg405526#msg405526



  • Gracias.. Voy a probar



  • Hola, disculpen las molestias, se que pasaron muchos años, pero como soy nuevo en esto me esta pasando lo mismo en las computadoras que usan Chrome y queria saber como solucionarlo.
    Espero que alguien me pueda ayudar.
    desde ya muchas gracias.
    saludoooos.



  • @cubag y has intentado lo que puso @bellera hace 4 años y dos post, sobre el formato del certificado ??


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy