[Gelöst] Problem mit OpenVPN Site-to-Site



  • Hallo Leute,

    Habe zwei pfSensen am laufen.

    Netzwerk 1: 10.11.77.0/24 - Server Netzwerk - 1 Windows 1 Debian 5 Ubuntu Server (DHCP)
    Netzwerk 2: 192.168.1.0/25 - zu Hause (DHCP)

    Der Tunnel steht soweit und funktioniert…Allerdings nur halb.

    Von einem Client aus Netzwerk 2 kann ich die pfSense in Netzwerk 1 unter 10.11.77.10 erreichen.
    Selbiges gilt für einen Client aus Netzwerk 2 für den Windowsserver (10.11.77.20) und den Debianserver (10.11.77.30).
    Allerdings erreiche ich von dem Client die Ubuntuserver nicht.

    Bin langsam mit meinem Latein am Ende.
    Habe beide Router neugestartet um eventuelle Routingfehler auszuschließen. Komisch ist, das eben nur die Ubuntuserver nicht erreichbar sind.
    Hat jemand eine Idee an was das liegen könnte?

    Gruß



  • Moin!
    Hast du mal das default Gateway an den Ubuntu Servern überprüft? Zeigt dieses auf die pfSense?



  • Hallo Mikle,

    Die Defaultgateways sind sowohl bei dem Ubuntuservern und dem Debianservern identisch.

    Allerdings ist mir heute was sehr komisches aufgefallen. Und zwar habe ich zwei OpenVPN Server laufen. Einer für die Site-to-Site (Tunnelnetz: 10.1.1.0/24 (mittlerweile umgestellt)) und eins für Clients zum einwählen (Tunnelnetz 10.66.88.0/24)

    Jetzt hab ich mir den Spaß gemacht und von der pfSense von den Servern zu mir nach Hause Pings gemacht und zu Hause in der pfSense die Pakete gecaptured. Bei der Serverseitigen pfSense habe ich als Source das LAN Netz eingestellt. Sprich von 10.11.77.1 -> 192.168.1.1. Einmal klappt der Ping und da sieht auch der Capture richtig aus also 10.11.77.1 -> 192.168.1.1. Beim zweiten Versuch allerdings steht als Source bei mir zu Hause 10.66.88.1 -> 192.168.1.1 das diese Route nicht funktionieren kann ist mir klar aber wie kommt das zustande?

    Das ganze passiert immer abwechselnd.

    Gruß



  • So hab das Problem gelöst.

    Anscheinend brauchen die Ubuntuserver manuelle Outbound NAT Rules damit die von meinem privaten Netz erreichbar sind (Windows und Debian funktionieren mit den Automatischen Regeln…). Hab jetzt für meine zwei privaten Netze 192.168.1.0/24 (LAN) und 192.168.10.0/24 (WLAN Router an OPT1 zu Hause an der pfSense) die Regeln eingerichtet und schon sind alle Kisten von zu Hause aus erreichbar.

    Vielleicht weiß jemand was bei den Ubuntuserver anders läuft als bei Debian.

    Gruß